summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-09-11 08:11:08 +0200
committerJeroen Roovers <jer@gentoo.org>2016-09-11 08:11:08 +0200
commita6787e2ba820917ba1d5f8175978341cd4fa09e8 (patch)
treece97935fce883e8ff129294e32768b8fa6c34e01 /net-libs/wandio/wandio-1.0.4.ebuild
parentx11-misc/slock: Old. (diff)
downloadgentoo-a6787e2ba820917ba1d5f8175978341cd4fa09e8.tar.gz
gentoo-a6787e2ba820917ba1d5f8175978341cd4fa09e8.tar.bz2
gentoo-a6787e2ba820917ba1d5f8175978341cd4fa09e8.zip
net-libs/wandio: Version bump.
Package-Manager: portage-2.3.0
Diffstat (limited to 'net-libs/wandio/wandio-1.0.4.ebuild')
-rw-r--r--net-libs/wandio/wandio-1.0.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-libs/wandio/wandio-1.0.4.ebuild b/net-libs/wandio/wandio-1.0.4.ebuild
new file mode 100644
index 000000000000..329989c47ce3
--- /dev/null
+++ b/net-libs/wandio/wandio-1.0.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Library for transparent file I/O with compression"
+HOMEPAGE="http://research.wand.net.nz/software/libwandio.php"
+SRC_URI="http://research.wand.net.nz/software/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/2"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 http lzma lzo static-libs zlib"
+
+RDEPEND="
+ !<net-libs/libtrace-4
+ bzip2? ( app-arch/bzip2 )
+ lzma? ( app-arch/xz-utils )
+ lzo? ( dev-libs/lzo )
+ http? ( net-misc/curl )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with bzip2) \
+ $(use_with http) \
+ $(use_with lzma) \
+ $(use_with lzo) \
+ $(use_with zlib)
+}