summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2016-12-25 12:05:58 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2016-12-26 01:03:12 +0300
commit58dac6481c32b92688e89233c0a4b10327db4a5a (patch)
tree2a1fdbff4258b3066239ee54edfc03390e445e94 /net-libs/xrootd/xrootd-4.5.0.ebuild
parentdev-util/cmake: fix linking on Solaris (diff)
downloadgentoo-58dac6481c32b92688e89233c0a4b10327db4a5a.tar.gz
gentoo-58dac6481c32b92688e89233c0a4b10327db4a5a.tar.bz2
gentoo-58dac6481c32b92688e89233c0a4b10327db4a5a.zip
net-libs/xrootd: version bump
- version bump to 4.5.0; - add USE=rbd for Ceph's Rados Block Device support; - sort cmake args. Package-Manager: portage-2.3.3 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
Diffstat (limited to 'net-libs/xrootd/xrootd-4.5.0.ebuild')
-rw-r--r--net-libs/xrootd/xrootd-4.5.0.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/net-libs/xrootd/xrootd-4.5.0.ebuild b/net-libs/xrootd/xrootd-4.5.0.ebuild
new file mode 100644
index 000000000000..c7f762555e4e
--- /dev/null
+++ b/net-libs/xrootd/xrootd-4.5.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils user
+
+DESCRIPTION="Extended ROOT remote file server"
+HOMEPAGE="http://xrootd.org/"
+SRC_URI="http://xrootd.org/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc fuse http kerberos readline rbd ssl test"
+
+RDEPEND="
+ !<sci-physics/root-5.32[xrootd]
+ sys-libs/zlib
+ fuse? ( sys-fs/fuse )
+ kerberos? ( virtual/krb5 )
+ rbd? ( sys-cluster/ceph )
+ readline? ( sys-libs/readline:0= )
+ ssl? ( dev-libs/openssl:0= )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot] )
+ test? ( dev-util/cppunit )"
+
+REQUIRED_USE="http? ( kerberos ssl )"
+PATCHES=( "${FILESDIR}"/${PN}-no-werror.patch )
+
+pkg_setup() {
+ enewgroup xrootd
+ enewuser xrootd -1 -1 "${EPREFIX}"/var/spool/xrootd xrootd
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CEPH=$(usex rbd)
+ -DENABLE_CRYPTO=$(usex ssl)
+ -DENABLE_FUSE=$(usex fuse)
+ -DENABLE_HTTP=$(usex http)
+ -DENABLE_KRB5=$(usex kerberos)
+ -DENABLE_PYTHON=OFF # TODO: install python bindings properly
+ -DENABLE_READLINE=$(usex readline)
+ -DENABLE_TESTS=$(usex test)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ if use doc; then
+ doxygen Doxyfile || die
+ fi
+}
+
+src_install() {
+ use doc && HTML_DOCS=( doxydoc/html/. )
+ dodoc docs/ReleaseNotes.txt
+ cmake-utils_src_install
+ find "${D}" \( -iname '*.md5' -o -iname '*.map' \) -delete || die
+
+ # base configs
+ insinto /etc/xrootd
+ doins packaging/common/*.cfg
+
+ fowners root:xrootd /etc/xrootd
+ keepdir /var/log/xrootd
+ fowners xrootd:xrootd /var/log/xrootd
+
+ local i
+ for i in cmsd frm_purged frm_xfrd xrootd; do
+ newinitd "${FILESDIR}"/${i}.initd ${i}
+ done
+ # all daemons MUST use single master config file
+ newconfd "${FILESDIR}"/xrootd.confd xrootd
+}