summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2016-11-04 03:35:52 +0100
committerThomas Deutschmann <whissi@gentoo.org>2016-11-04 03:41:51 +0100
commit4b759147935a2a74360e2e3c5d241fd313710b6f (patch)
tree5ca5a1fde5f9c9e2f74326ebcdf1b03f3a07eb9b /net-libs/zeromq/zeromq-4.1.6.ebuild
parentmedia-libs/{coin,SoQt,simage}: update homepage and URLs, bug 578276 (diff)
downloadgentoo-4b759147935a2a74360e2e3c5d241fd313710b6f.tar.gz
gentoo-4b759147935a2a74360e2e3c5d241fd313710b6f.tar.bz2
gentoo-4b759147935a2a74360e2e3c5d241fd313710b6f.zip
net-libs/zeromq: Bumped to v4.1.6
Package-Manager: portage-2.3.2
Diffstat (limited to 'net-libs/zeromq/zeromq-4.1.6.ebuild')
-rw-r--r--net-libs/zeromq/zeromq-4.1.6.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-libs/zeromq/zeromq-4.1.6.ebuild b/net-libs/zeromq/zeromq-4.1.6.ebuild
new file mode 100644
index 000000000000..6dc347309e20
--- /dev/null
+++ b/net-libs/zeromq/zeromq-4.1.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools eutils
+
+DESCRIPTION="A brokerless kernel"
+HOMEPAGE="http://www.zeromq.org/"
+SRC_URI="https://github.com/zeromq/zeromq4-1/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/5"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="pgm static-libs test"
+
+RDEPEND="
+ dev-libs/libsodium:=
+ pgm? ( =net-libs/openpgm-5.2.122 )"
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ app-text/xmlto
+ sys-apps/util-linux
+ pgm? ( virtual/pkgconfig )"
+
+src_prepare() {
+ sed \
+ -e '/libzmq_werror=/s:yes:no:g' \
+ -i configure.ac || die
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-shared
+ $(use_enable static-libs static)
+ --with-relaxed
+ --with-libsodium
+ $(use_with pgm)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}