summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-04-24 00:09:22 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-04-24 00:09:22 +0200
commit06ad386e8247124bd5d099a417501594e0873c86 (patch)
tree40c5d7028a13852c9aefad7e62f4471863520be5 /net-libs
parentnet-libs/libupnp: drop 1.14.17 (diff)
downloadgentoo-06ad386e8247124bd5d099a417501594e0873c86.tar.gz
gentoo-06ad386e8247124bd5d099a417501594e0873c86.tar.bz2
gentoo-06ad386e8247124bd5d099a417501594e0873c86.zip
net-libs/libupnp: add 1.14.19
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libupnp/Manifest1
-rw-r--r--net-libs/libupnp/libupnp-1.14.19.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/net-libs/libupnp/Manifest b/net-libs/libupnp/Manifest
index 357a4385463e..ab31533830c5 100644
--- a/net-libs/libupnp/Manifest
+++ b/net-libs/libupnp/Manifest
@@ -1 +1,2 @@
DIST libupnp-1.14.18.tar.gz 811092 BLAKE2B ee95cafc10838817900f82b83d15cf5d925e36a4321c7000b963e9e986ca9165af55c4c90c6fdf5d9bfaf72695711337986d25498cb838d513470f20decf10cc SHA512 68973e0e5a8f9e64b2311246b7924b0837fd2c7ef30483d3d93ebfeee62bc2293760209d8a5213c0456ce5c37f9f32a6038c9e5d8b461670ba6073db8c2f1394
+DIST libupnp-1.14.19.tar.gz 814300 BLAKE2B 119281a2e220b3b9398566b649d76fc047741a251097059920e84ef9376db03ee953ebf10934423a56613ad85aa9f77b777e33d92095b1468dfffb12e37e86bd SHA512 76ae3bf8b69fd649ede0b92e03b36a6cbc7a9df9fa7828386c97761df12f2ae6346dec9ab45f78e17eb793d4d225707ecb3a7628d7678287979115cd4ba65c49
diff --git a/net-libs/libupnp/libupnp-1.14.19.ebuild b/net-libs/libupnp/libupnp-1.14.19.ebuild
new file mode 100644
index 000000000000..13ae128fe931
--- /dev/null
+++ b/net-libs/libupnp/libupnp-1.14.19.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_PN="pupnp"
+
+DESCRIPTION="An Portable Open Source UPnP Development Kit"
+HOMEPAGE="http://pupnp.sourceforge.net/"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-release-${PV}"
+
+LICENSE="BSD"
+SLOT="0/17"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux"
+IUSE="blocking-tcp debug doc +reuseaddr samples +ssl static-libs"
+
+RDEPEND="ssl? ( dev-libs/openssl:0= )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${PN}-1.14.12-disable-network-tests.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable blocking-tcp blocking-tcp-connections)
+ $(use_enable debug)
+ --enable-ipv6
+ $(use_enable reuseaddr)
+ $(use_enable samples)
+ $(use_enable ssl open_ssl)
+ $(use_enable static-libs static)
+ )
+
+ econf ${myeconfargs[@]}
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}