summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWANG Xuerui <xen0n@gentoo.org>2023-01-14 14:31:23 +0800
committerSam James <sam@gentoo.org>2023-01-14 19:14:38 +0000
commit076d0d2bd835bbc0f21fb1b28dc5175ca59a86a2 (patch)
treec8ab50e33a4e133c317446c3074eb4f72a542611 /net-libs
parentsys-auth/passwdqc: fix build with lld-16 (diff)
downloadgentoo-076d0d2bd835bbc0f21fb1b28dc5175ca59a86a2.tar.gz
gentoo-076d0d2bd835bbc0f21fb1b28dc5175ca59a86a2.tar.bz2
gentoo-076d0d2bd835bbc0f21fb1b28dc5175ca59a86a2.zip
net-libs/libtirpc: fix build with lld-16
Signed-off-by: WANG Xuerui <xen0n@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libtirpc/libtirpc-1.3.3.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/net-libs/libtirpc/libtirpc-1.3.3.ebuild b/net-libs/libtirpc/libtirpc-1.3.3.ebuild
index 46f43a6d7b8c..1533f24eee74 100644
--- a/net-libs/libtirpc/libtirpc-1.3.3.ebuild
+++ b/net-libs/libtirpc/libtirpc-1.3.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit multilib-minimal usr-ldscript
+inherit flag-o-matic multilib-minimal toolchain-funcs usr-ldscript
DESCRIPTION="Transport Independent RPC library (SunRPC replacement)"
HOMEPAGE="https://sourceforge.net/projects/libtirpc/ https://git.linux-nfs.org/?p=steved/libtirpc.git"
@@ -33,6 +33,13 @@ src_prepare() {
}
multilib_src_configure() {
+ # ideally we want !tc-ld-is-bfd for best future-proofing, but it needs
+ # https://github.com/gentoo/gentoo/pull/28355
+ # mold needs this too but right now tc-ld-is-mold is also not available
+ if tc-ld-is-lld; then
+ append-ldflags -Wl,--undefined-version
+ fi
+
local myeconfargs=(
$(use_enable kerberos gssapi)
$(use_enable static-libs static)