summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-04-26 11:26:34 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-04-26 11:39:07 +0200
commit0cb3a0aaad1a5b0f3e3f235553fa5c1a15116a03 (patch)
treeb38408e28e42de021ddaccafad3cc6f533b1e28e /net-libs
parentMask dev-vcs/subversion below 1.8 (diff)
downloadgentoo-0cb3a0aaad1a5b0f3e3f235553fa5c1a15116a03.tar.gz
gentoo-0cb3a0aaad1a5b0f3e3f235553fa5c1a15116a03.tar.bz2
gentoo-0cb3a0aaad1a5b0f3e3f235553fa5c1a15116a03.zip
net-libs/nghttp2: Bump to version 1.10.0
Package-Manager: portage-2.2.28 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nghttp2/Manifest1
-rw-r--r--net-libs/nghttp2/nghttp2-1.10.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/net-libs/nghttp2/Manifest b/net-libs/nghttp2/Manifest
index 43ea8f4e7f87..fd80ebce3796 100644
--- a/net-libs/nghttp2/Manifest
+++ b/net-libs/nghttp2/Manifest
@@ -1,3 +1,4 @@
+DIST nghttp2-1.10.0.tar.gz 2086580 SHA256 192dc031e71e182240079befae9db7e64c9951da3a83c7a438f57cf76145b6a8 SHA512 4341f76ead38ba30e0dfda492e2e0f4c842f453e235fa90ee55b1e556092828236f21c6b212d0099cea005f149e4be3e63ad007009dd5228999101e563009a6f WHIRLPOOL 603391b0d15883cd9db734a0e4bb7d994c17ae4209d5251504e29cc59e0ccf67488b9340acefdb6d6603e9e7d3b0a0491ed18330edce4d20adb0ed19ffc5b975
DIST nghttp2-1.6.0.tar.gz 1983953 SHA256 c88012e87b80c055ddd2412efd7e96b9e8cfe0652c4b21083f2cb89b2f0d3a26 SHA512 32d5227a5ff037d50d93d43b1fdb0be51d9cca1e09dcc85320b8e09f82fdc658397ca58ca400595f138ca7b77f389d945e3562ab4074afd05e1c74eca4de2744 WHIRLPOOL 31102e596a9e93ca993cd9b8b04da6f51acb247803de16958501bdb6fe06e5bbc951430d2c2be1bd7fd1d9216d087d711de83bad6bb93eb70f4e4b8b0f864efb
DIST nghttp2-1.7.1.tar.gz 1993320 SHA256 d83858464c03555828bb603288b66a48680bf164b376d2459a5407c102098a14 SHA512 3a71153d2b30a69e79115402b7db9a04bc812025ccb67b918079f33690f18eb5b286095b8bc161df91abf6466b6bb822ecc13c49bee54265a06ba9ab7c289b54 WHIRLPOOL 41d0afd43878029069d2c339e22b8aec77fedbd1b0fb45da96b9592525c760731e2eec567999af704d63cf94c913b1d0c52063380e69170e1f2d2b928c1d70f3
DIST nghttp2-1.8.0.tar.gz 2021815 SHA256 3ac8cdf47c744cb387e6c867fe8c9a449254e9fab7fdf96782f9eaf7f635320a SHA512 447ee232abb9ea4105044567baabedc471089af7dfe72219f7c830898d3cd9bc63351d187129e43331cc775702f8dbe2afd21a2c88dc5191b858539dcb7c61d2 WHIRLPOOL b3ec7eae828c240dcd2c972d8148ceb6f2476fe8b6b8636c38b68b236e91915f07851a19a1e9daae27c636eb68898b8675e33b9e13d75c51ef99f56d992908dd
diff --git a/net-libs/nghttp2/nghttp2-1.10.0.ebuild b/net-libs/nghttp2/nghttp2-1.10.0.ebuild
new file mode 100644
index 000000000000..7d892241bc29
--- /dev/null
+++ b/net-libs/nghttp2/nghttp2-1.10.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# TODO: Add python support.
+
+EAPI=6
+
+inherit multilib-minimal
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/tatsuhiro-t/nghttp2.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/tatsuhiro-t/nghttp2/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="HTTP/2 C Library"
+HOMEPAGE="https://nghttp2.org/"
+
+LICENSE="MIT"
+SLOT="0/1.14" # <C++>.<C> SONAMEs
+IUSE="cxx debug hpack-tools jemalloc libressl static-libs test +threads utils xml"
+
+RDEPEND="
+ cxx? ( dev-libs/boost:=[${MULTILIB_USEDEP},threads] )
+ hpack-tools? ( >=dev-libs/jansson-2.5 )
+ jemalloc? ( dev-libs/jemalloc )
+ utils? (
+ >=dev-libs/libev-4.15
+ !libressl? ( >=dev-libs/openssl-1.0.2:0[-bindist] )
+ libressl? ( dev-libs/libressl )
+ >=sys-libs/zlib-1.2.3
+ )
+ xml? ( >=dev-libs/libxml2-2.7.7:2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-examples \
+ --disable-failmalloc \
+ --disable-werror \
+ --without-cython \
+ --disable-python-bindings \
+ --without-spdylay \
+ $(use_enable cxx asio-lib) \
+ $(use_enable debug) \
+ $(multilib_native_use_enable hpack-tools) \
+ $(use_enable static-libs static) \
+ $(use_enable threads) \
+ $(multilib_native_use_enable utils app) \
+ $(multilib_native_use_with jemalloc) \
+ $(multilib_native_use_with xml libxml2)
+}
+
+multilib_src_install_all() {
+ use static-libs || find "${ED}"/usr -name '*.la' -delete
+}