summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-02-11 21:17:53 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-02-11 21:18:09 +0100
commit13be6cf4352e8b49a01dd871e8a52698dcd3c95c (patch)
tree9cba3255d07dee7da7c51eec61e05915fcd08238 /net-libs
parentprofiles/prefix/linux: inherit from profiles/prefix too (diff)
downloadgentoo-13be6cf4352e8b49a01dd871e8a52698dcd3c95c.tar.gz
gentoo-13be6cf4352e8b49a01dd871e8a52698dcd3c95c.tar.bz2
gentoo-13be6cf4352e8b49a01dd871e8a52698dcd3c95c.zip
net-libs/nodejs: Unhardcode path #574460
Package-Manager: portage-2.2.27
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nodejs/nodejs-5.6.0-r1.ebuild (renamed from net-libs/nodejs/nodejs-5.6.0.ebuild)2
1 files changed, 1 insertions, 1 deletions
diff --git a/net-libs/nodejs/nodejs-5.6.0.ebuild b/net-libs/nodejs/nodejs-5.6.0-r1.ebuild
index 72657ac542fc..0c740de30cc4 100644
--- a/net-libs/nodejs/nodejs-5.6.0.ebuild
+++ b/net-libs/nodejs/nodejs-5.6.0-r1.ebuild
@@ -148,7 +148,7 @@ src_install() {
# Install bash completion for `npm`
# We need to temporarily replace default config path since
# npm otherwise tries to write outside of the sandbox
- local npm_config="usr/lib64/node_modules/npm/lib/config/core.js"
+ local npm_config="usr/$(get_libdir)/node_modules/npm/lib/config/core.js"
sed -i -e "s|'/etc'|'${D}/etc'|g" "${ED}/${npm_config}" || die
local tmp_npm_completion_file="$(emktemp)"
"${ED}/usr/bin/npm" completion > "${tmp_npm_completion_file}"