summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarlson2k (Evgeny Grin) <k2k@narod.ru>2021-12-20 16:41:40 +0300
committerSam James <sam@gentoo.org>2021-12-21 01:39:36 +0000
commit155c4d7720416a21ff0c67a2013f4ee4907c40ab (patch)
tree1c95ca4cb75061e84f65311d0f7913e98c9c55bb /net-libs
parentsys-boot/tboot: Don't call strip directly (diff)
downloadgentoo-155c4d7720416a21ff0c67a2013f4ee4907c40ab.tar.gz
gentoo-155c4d7720416a21ff0c67a2013f4ee4907c40ab.tar.bz2
gentoo-155c4d7720416a21ff0c67a2013f4ee4907c40ab.zip
net-libs/libmicrohttpd: updated to v0.9.74
Signed-off-by: Karlson2k (Evgeny Grin) <k2k@narod.ru> Closes: https://github.com/gentoo/gentoo/pull/23432 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libmicrohttpd/Manifest1
-rw-r--r--net-libs/libmicrohttpd/libmicrohttpd-0.9.74.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/net-libs/libmicrohttpd/Manifest b/net-libs/libmicrohttpd/Manifest
index 5fdb923bbc79..86e8f26e846f 100644
--- a/net-libs/libmicrohttpd/Manifest
+++ b/net-libs/libmicrohttpd/Manifest
@@ -1,3 +1,4 @@
DIST libmicrohttpd-0.9.68.tar.gz 1884342 BLAKE2B 3f74c48917fa19753a617242fa07b99a69510a14a802609d038964d927516f8f52b4330d0eee2c7b98096b2d840158e4945310edef290224ea256d9616fb4d94 SHA512 9daaab5fb35fef6f2a19b7e08eeb8473aeb0a67631808a8d7a7f78a09cb621ca5d32dbbbca616865a40afb92f8c6495f9e2ba1674880af8011a2bc798c070a13
DIST libmicrohttpd-0.9.72.tar.gz 1693553 BLAKE2B 24d9284d8cab65d4a5b6b7f3a5b860dfd8cf69b21e44ee05ae2f7561b766a72d2dbb7f57849a31c22454e211befa74e058f78814b79e7876b3d14c7252ab5800 SHA512 9695e2fb08785e4b60342226ef3a0af22da4d80f127e7db9ec80ce844f70d0d781b30af207d58d8eb691b85a5fe4691cb9ecf887ca86f5e059a05259ae041316
DIST libmicrohttpd-0.9.73.tar.gz 1738675 BLAKE2B 63845b1b7fa0aa8ce29e9917521e10bd59fa0d27658e87ef3273d5014adf5cd9514a2d84465a573df03b44dcd50da7d157ef9c4952107ebba49efdfb398476c2 SHA512 473996b087ac6734ab577a1c7681c6c0b0136e04e34e13c3b50fd758358c1516017ad79097e0c57792786f6dd0208834374c09238113efed13bb4be11ef649d3
+DIST libmicrohttpd-0.9.74.tar.gz 1962057 BLAKE2B 6751696740e2893b6ad1ecf5f6e6716dc4b053f788ca1c9c76a25051437942cd975dc0ee428a65af58da04f4cca41c4ed79cdd335b3f90d1dd52651185ee42dc SHA512 86e8b88e064f17557455617975888993a285f4de6d4051cb837ef3e7328d3718001ef280473d306724dd85a01e1787fca099d4bd18e5d78b766e41a3a9f126ef
diff --git a/net-libs/libmicrohttpd/libmicrohttpd-0.9.74.ebuild b/net-libs/libmicrohttpd/libmicrohttpd-0.9.74.ebuild
new file mode 100644
index 000000000000..0103838713fd
--- /dev/null
+++ b/net-libs/libmicrohttpd/libmicrohttpd-0.9.74.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit multilib-minimal
+
+MY_P="${P/_/}"
+
+DESCRIPTION="Small C library to run an HTTP server as part of another application"
+HOMEPAGE="https://www.gnu.org/software/libmicrohttpd/"
+SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="LGPL-2.1+"
+SLOT="0/12"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+epoll ssl static-libs test +thread-names"
+RESTRICT="!test? ( test )"
+
+RDEPEND="ssl? ( >net-libs/gnutls-2.12.20:= )"
+# libcurl and the curl binary are used during tests on CHOST
+DEPEND="${RDEPEND}
+ test? ( net-misc/curl[ssl?] )"
+BDEPEND="ssl? ( virtual/pkgconfig )"
+
+DOCS=( AUTHORS NEWS COPYING README ChangeLog )
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ --disable-nls \
+ --enable-bauth \
+ --enable-dauth \
+ --disable-examples \
+ --enable-messages \
+ --enable-postprocessor \
+ --enable-httpupgrade \
+ --disable-experimental \
+ --disable-heavy-tests \
+ $(use_enable thread-names) \
+ $(use_enable epoll) \
+ $(use_enable test curl) \
+ $(use_enable ssl https) \
+ $(use_with ssl gnutls)
+}
+
+multilib_src_install_all() {
+ default
+
+ if ! use static-libs; then
+ find "${ED}" -name '*.la' -delete || die
+ fi
+}