summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-04-10 15:18:04 -0400
committerMichael Orlitzky <mjo@gentoo.org>2020-04-10 15:37:19 -0400
commit191d0e654981bf20a008426ab864c6b5b2fedd99 (patch)
tree89d367b682c09338dc229321bfda00aa0d61294c /net-libs
parentsys-cluster/kubernetes: 1.18.1 bump (diff)
downloadgentoo-191d0e654981bf20a008426ab864c6b5b2fedd99.tar.gz
gentoo-191d0e654981bf20a008426ab864c6b5b2fedd99.tar.bz2
gentoo-191d0e654981bf20a008426ab864c6b5b2fedd99.zip
net-libs/google-cloud-cpp: new revision depending on OpenSSL.
As of v0.9.0, google-cloud-cpp now depends unconditionally on OpenSSL (according to upstream). We carry a patch that tries to eliminate the dependency, but several people (including myself) have reported that it only results in link failures these days. This commit introduces a new revision of google-cloud-cpp-0.10.0 without the patch. Note that the patch also dropped some zlib stuff, and no one remembers why. We might find out! Closes: https://bugs.gentoo.org/691352 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/google-cloud-cpp/google-cloud-cpp-0.10.0-r1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/net-libs/google-cloud-cpp/google-cloud-cpp-0.10.0-r1.ebuild b/net-libs/google-cloud-cpp/google-cloud-cpp-0.10.0-r1.ebuild
new file mode 100644
index 000000000000..b1fb2095c0c3
--- /dev/null
+++ b/net-libs/google-cloud-cpp/google-cloud-cpp-0.10.0-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+JSON_VER="3.4.0"
+GOOGLEAPIS_COMMIT="6a3277c0656219174ff7c345f31fb20a90b30b97"
+
+DESCRIPTION="Google Cloud Client Library for C++"
+HOMEPAGE="https://cloud.google.com/"
+SRC_URI="https://github.com/GoogleCloudPlatform/google-cloud-cpp/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/nlohmann/json/releases/download/v${JSON_VER}/json.hpp -> nlohmann-json-${JSON_VER}-json.hpp
+ https://github.com/googleapis/googleapis/archive/${GOOGLEAPIS_COMMIT}.tar.gz -> googleapis-${GOOGLEAPIS_COMMIT}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT="test"
+RDEPEND="dev-libs/protobuf:=
+ dev-libs/crc32c
+ dev-libs/openssl:=
+ net-misc/curl
+ net-libs/grpc:="
+DEPEND="${RDEPEND}
+ dev-cpp/gtest"
+
+DOCS=( README.md )
+PATCHES=(
+ "${FILESDIR}/google-cloud-cpp-0.9.0-offline_nlohmannjson.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DGOOGLE_CLOUD_CPP_DEPENDENCY_PROVIDER=package
+ -DBUILD_SHARED_LIBS=ON
+ -DBUILD_TESTING=OFF
+ )
+
+ cmake-utils_src_configure
+
+ mkdir -p "${BUILD_DIR}/external/nlohmann_json/src/" || die
+ cp "${DISTDIR}/nlohmann-json-${JSON_VER}-json.hpp" "${BUILD_DIR}/external/nlohmann_json/src/json.hpp" || die
+
+ mkdir -p "${BUILD_DIR}/external/googleapis/src/" || die
+ cp "${DISTDIR}/googleapis-${GOOGLEAPIS_COMMIT}.tar.gz" \
+ "${BUILD_DIR}/external/googleapis/src/${GOOGLEAPIS_COMMIT}.tar.gz" || die
+}
+
+src_test() {
+ # test fails
+ local myctestargs=(
+ -E internal_parse_rfc3339_test
+ )
+
+ cmake-utils_src_test
+}