summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-07-07 09:00:51 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-07-07 12:53:05 +0200
commit20143d93d940530d43b9f7990f9051bad2ca1266 (patch)
treecbe5d553b4f976696e2700363d88292d58ffa24b /net-libs
parentnet-irc/konversation: 22.04.3 version bump (diff)
downloadgentoo-20143d93d940530d43b9f7990f9051bad2ca1266.tar.gz
gentoo-20143d93d940530d43b9f7990f9051bad2ca1266.tar.bz2
gentoo-20143d93d940530d43b9f7990f9051bad2ca1266.zip
net-libs/libktorrent: 22.04.3 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libktorrent/Manifest1
-rw-r--r--net-libs/libktorrent/libktorrent-22.04.3.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/net-libs/libktorrent/Manifest b/net-libs/libktorrent/Manifest
index 704562713424..140140cd0d83 100644
--- a/net-libs/libktorrent/Manifest
+++ b/net-libs/libktorrent/Manifest
@@ -1,2 +1,3 @@
DIST libktorrent-21.12.3.tar.xz 605960 BLAKE2B a4c0d7d1942647a759cd3890cb675ee6ccddf3b875836f91b1006f51230b15f0b55bdffd8b79f6c96af8f30f611cf6d8cd5a7677a39a8aedb17d3c0705f19186 SHA512 04ff8cfa6a945eeb36d88972e530371b011ba664eb742436ffbb5a09c10ae25053fc3553d6d80b9d68f65a9deee65595b0554bd3ab0f2b71414c621ddd28d2d1
DIST libktorrent-22.04.2.tar.xz 606372 BLAKE2B 71e9b2dc92fc22d7124e2bbbad6853ac00e8b85d2c4de1d34a3af68c348cc044ecec5fc8a350dee75917475522dc0b6c85465174dae4c17d3400b0bb8f64bfa4 SHA512 b5ef82b2d2c9235e0760fff0c4b30339abb076f47c75bee85379d247c4b0d0fffd7d194b90ba4594d4ac6461d8045570f0bcf56dd484527338afd94a6ea2eeda
+DIST libktorrent-22.04.3.tar.xz 595672 BLAKE2B a014e6cfe8f79953422f31fe94d01c48cfbadb2a5f144c13b960d860f0c581c7c301545cfd9b5f490dd10e06a2b7d2d56e7b9609c19bb3c83524a325d9f8c86a SHA512 3ea6530c62e1a022f8d679f9ed54654c3c468cfdd0aceff4b7f6e0a1687ec1ddf59aebcdc08a258d7a169f827ea0de4e8b5489df4225f4fb15988010bd0f4b99
diff --git a/net-libs/libktorrent/libktorrent-22.04.3.ebuild b/net-libs/libktorrent/libktorrent-22.04.3.ebuild
new file mode 100644
index 000000000000..23f2d34e21d9
--- /dev/null
+++ b/net-libs/libktorrent/libktorrent-22.04.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="forceoptional"
+KDE_GEAR="true"
+KDE_ORG_CATEGORY="network"
+KFMIN=5.92.0
+QTMIN=5.15.4
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="BitTorrent library based on KDE Frameworks"
+HOMEPAGE="https://apps.kde.org/ktorrent/ https://userbase.kde.org/KTorrent"
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+COMMON_DEPEND="
+ >=app-crypt/qca-2.3.0:2
+ >=dev-libs/gmp-6.0.0a:0=
+ dev-libs/libgcrypt:0=
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-frameworks/karchive-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/solid-${KFMIN}:5
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/boost-1.71
+"
+RDEPEND="${COMMON_DEPEND}
+ !dev-libs/botan[gmp(-)]
+"
+BDEPEND="sys-devel/gettext"
+
+src_prepare() {
+ ecm_src_prepare
+
+ # Gentoo workaround because gmp.h in MULTILIB_WRAPPED_HEADERS is breaking this
+ sed -i -e "/^find_package/ s/\"\${LibGMP_MIN_VERSION}\" //" \
+ CMakeLists.txt || die
+ sed -i -e "/^find_dependency/ s/ \"@LibGMP_MIN_VERSION@\"//" \
+ KF5TorrentConfig.cmake.in || die
+}
+
+src_test() {
+ # failing network tests
+ local myctestargs=(
+ -E "(fin|packetloss|send|superseedtest|transmit|utppolltest)"
+ )
+
+ ecm_src_test
+}