summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2016-03-29 08:58:20 +0200
committerWolfram Schlich <wschlich@gentoo.org>2016-03-29 08:58:53 +0200
commit27908312b84fe2369faf4c6380738a6aa8d095d7 (patch)
treed71299dc3fa51386665f989f222f7d337df6dfce /net-libs
parentsys-infiniband/librdmacm: cleanup vulnerable packages per 438444 (diff)
downloadgentoo-27908312b84fe2369faf4c6380738a6aa8d095d7.tar.gz
gentoo-27908312b84fe2369faf4c6380738a6aa8d095d7.tar.bz2
gentoo-27908312b84fe2369faf4c6380738a6aa8d095d7.zip
net-libs/loudmouth: version bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/loudmouth/Manifest1
-rw-r--r--net-libs/loudmouth/loudmouth-1.5.3.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/net-libs/loudmouth/Manifest b/net-libs/loudmouth/Manifest
index f988948b045f..11c504d34625 100644
--- a/net-libs/loudmouth/Manifest
+++ b/net-libs/loudmouth/Manifest
@@ -1,2 +1,3 @@
DIST loudmouth-1.4.3.tar.bz2 366818 SHA256 95a93f5d009b71ea8193d994aa11f311bc330a3efe1b7cd74dc48f11c7f929e3 SHA512 02d1de14a4d626a4c9100bd24c06d4b4203eabb0f95bab40ee18ea5e68ed81d47aa977625140157b2d9f7974ac748af857c2ee3a916f0db700e2a2d0934940ec WHIRLPOOL 4f9e3e8e4f2fd0a36996e84deebeb26c789d5334af11a3d6cc6c742b59508945a6279715f6fbb02bbbc04a0d9709e7aae4cc39803b2a60acfd47d76f0482f969
DIST loudmouth-1.5.2.tar.gz 115940 SHA256 c3dd7b5690a7b6ee4768d71d2bdee4615cfb73b6eeaa342d6a931a5160e47421 SHA512 54c3eb7ef99604d7e2d5560dc6e5be176a188e6a0d82ae6c2f488e30f06553039aa03d6f818cec25f354479a2624f60f2233d7e63b54f331e934d554de9bfc87 WHIRLPOOL 99fd7fa00f08976242313c2bc11e9edfbe1aeea9918090347a1975d5ece438892afbf3b5c16ffe79b1c0a10b28f35f62937d45a234e63b26f051466799fd7685
+DIST loudmouth-1.5.3.tar.gz 114676 SHA256 12972fcffd9bbcc4a3b2b9fbf4b0e549f7b4caf0f11c8d2af2059087ce4e8792 SHA512 afae8b4ad1e9e5558cffa8f6b9f25331b01cfa09ea0b3defb74cac7d39477744e6d9181d3adefe242038020759df43558de0e61305fbc8e12a3b293b82856bf7 WHIRLPOOL 0a7d4a01ec4f0ae68f58f3267aabc2eb9f7eb0e812232a8ecd3664dd5c99ae404c4825bb5ae01f36a1cced48a9aaff67c4a92c23541e2e1fd9f69c4a67962007
diff --git a/net-libs/loudmouth/loudmouth-1.5.3.ebuild b/net-libs/loudmouth/loudmouth-1.5.3.ebuild
new file mode 100644
index 000000000000..c413070f9f50
--- /dev/null
+++ b/net-libs/loudmouth/loudmouth-1.5.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="Lightweight C Jabber library"
+HOMEPAGE="https://github.com/mcabber/loudmouth"
+SRC_URI="https://github.com/mcabber/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+#SRC_URI="https://mcabber.com/files/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos"
+
+IUSE="asyncns ssl openssl static-libs test"
+
+# Automagic libidn dependency
+RDEPEND="
+ >=dev-libs/glib-2.16:2
+ net-dns/libidn
+ ssl? (
+ !openssl? ( >=net-libs/gnutls-1.4.0 )
+ openssl? ( dev-libs/openssl:0 )
+ )
+ asyncns? ( >=net-libs/libasyncns-0.3 )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )
+ virtual/pkgconfig
+ >=dev-util/gtk-doc-1
+ >=dev-util/gtk-doc-am-1
+"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ if use ssl; then
+ if ! use openssl; then
+ myconf="${myconf} --with-ssl=gnutls"
+ else
+ myconf="${myconf} --with-ssl=openssl"
+ fi
+ else
+ myconf="${myconf} --with-ssl=no"
+ fi
+
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with asyncns) \
+ ${myconf}
+}