summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2023-09-18 11:33:11 +0200
committerGuilherme Amadio <amadio@gentoo.org>2023-09-19 08:20:40 +0200
commit32b2d14aa76a29f78a3cd80c582f07dd82b62f29 (patch)
tree235138fc9083dfac8bc2edd3c8305c9ddc01daff /net-libs
parentprofiles/package.mask: remove obsolete masks (diff)
downloadgentoo-32b2d14aa76a29f78a3cd80c582f07dd82b62f29.tar.gz
gentoo-32b2d14aa76a29f78a3cd80c582f07dd82b62f29.tar.bz2
gentoo-32b2d14aa76a29f78a3cd80c582f07dd82b62f29.zip
net-libs/xrootd: version bump to 5.6.2
Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/xrootd/Manifest1
-rw-r--r--net-libs/xrootd/files/xrootd-5.6.2-authfile.patch13
-rw-r--r--net-libs/xrootd/xrootd-5.6.2.ebuild208
3 files changed, 222 insertions, 0 deletions
diff --git a/net-libs/xrootd/Manifest b/net-libs/xrootd/Manifest
index eb7ebc34c68d..694212ed1a2a 100644
--- a/net-libs/xrootd/Manifest
+++ b/net-libs/xrootd/Manifest
@@ -1,3 +1,4 @@
DIST xrootd-5.5.4.tar.gz 3241021 BLAKE2B 505890ab7dbd0530d3c42390c9a6858cf0c8b53d42631b3bed615cb9b7c4d738bb791d26e625b010fef79f57291eb8bcd653ec629d240df92d37c12c973210f8 SHA512 1bf8fec3e20950e1dfbb5a7914c2f2b1d7d1fc1ce6b419dda129bb6cfb083ae674a14732b7b7330dee2287635749d91f8ee7e16badd71c723d189a1a44c309dd
DIST xrootd-5.5.5.tar.gz 3243062 BLAKE2B 697dbd9d42e3fd9c6d2cf86a1c120e3752e74abbae2cf69be4c20292c568ad2f20fbea9320a2e22c04b53232d32915f9f7ea08c0e93117e8e72f181d5b642044 SHA512 864b4fe686c0a618a2672b624b7c5a00a4e87b4bd97842f8e25666b48a23f01e7d91d926013e9f435fb439a9c464ebbca8818720ec6c067c04d0603d1381cdba
DIST xrootd-5.6.1.tar.gz 3278351 BLAKE2B e19bddd76e6457593a538707c1904d96a196edebe60cb59dfaff91ce3e0922adb1e83a95f9c4a9fb319071f2548b95c198bfe4b606a0ce3d96f9a1ed4cdcd27e SHA512 dc4881a5122654c6dc54f40c99eb0794c0b493e1bbcb6e8574b82105e7c1a10e4dbc0fffb004e58c90cbe1da813856ea21e31aa07937e0f0bf0f58dc3a9c9752
+DIST xrootd-5.6.2.tar.gz 3251295 BLAKE2B 74582fd256279719c40fbee8e053d45ef76709c5077ace43db2f3c3e5f1902245999e25872f18a4c60bf41e5c11bb1a195cd494b00c66dcc19705112909f0170 SHA512 53ee1f7eaf5bd61dcc6345be0193679daa76300cd5fc15e54e622e2c05cf5a312d924c6e7fe3bfb91e9d2aff8feeb9faee87259e9c2ff33bb52d1add7ec13394
diff --git a/net-libs/xrootd/files/xrootd-5.6.2-authfile.patch b/net-libs/xrootd/files/xrootd-5.6.2-authfile.patch
new file mode 100644
index 000000000000..190fddef9781
--- /dev/null
+++ b/net-libs/xrootd/files/xrootd-5.6.2-authfile.patch
@@ -0,0 +1,13 @@
+Fix compound id parsing for authfile.
+
+--- a/src/XrdAcc/XrdAccAuthFile.cc
++++ b/src/XrdAcc/XrdAccAuthFile.cc
+@@ -161,7 +161,7 @@ char XrdAccAuthFile::getID(char **id)
+ // two character specification but only validate the first to be backward
+ // compatible.
+ //
+- if (strlen(pp) <= 2 || !index("ghoru", *pp))
++ if (strlen(pp) > 2 || !index("ghoru", *pp))
+ {Eroute->Emsg("AuthFile", "Invalid ID sprecifier -", pp);
+ flags = (DBflags)(flags | dbError);
+ return 0;
diff --git a/net-libs/xrootd/xrootd-5.6.2.ebuild b/net-libs/xrootd/xrootd-5.6.2.ebuild
new file mode 100644
index 000000000000..baa00445c59b
--- /dev/null
+++ b/net-libs/xrootd/xrootd-5.6.2.ebuild
@@ -0,0 +1,208 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_EXT=1
+DISTUTILS_OPTIONAL=1
+DISTUTILS_USE_PEP517="setuptools"
+DOCS_BUILDER="doxygen"
+DOCS_DEPEND="
+ media-gfx/graphviz
+ virtual/latex-base
+ python? ( dev-python/sphinx )
+"
+
+inherit cmake docs distutils-r1 systemd
+
+DESCRIPTION="Extended ROOT remote file server"
+HOMEPAGE="https://xrootd.slac.stanford.edu/"
+LICENSE="LGPL-3+"
+
+IUSE="ceph examples fuse http kerberos +libxml2 macaroons python readline scitokens +server systemd test xrdec"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SRC_URI="https://xrootd.slac.stanford.edu/download/v${PV}/${P}.tar.gz"
+
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="
+ http? ( kerberos )
+ macaroons? ( server http )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ scitokens? ( server )
+ test? ( server )
+"
+
+CDEPEND="acct-group/xrootd
+ acct-user/xrootd
+ dev-libs/openssl:0=
+ sys-libs/zlib
+ virtual/libcrypt:=
+ ceph? ( sys-cluster/ceph )
+ fuse? ( sys-fs/fuse:0= )
+ http? (
+ net-misc/curl:=
+ net-libs/davix
+ )
+ kerberos? ( virtual/krb5 )
+ libxml2? ( dev-libs/libxml2:2= )
+ macaroons? ( dev-libs/libmacaroons )
+ python? ( ${PYTHON_DEPS} )
+ readline? ( sys-libs/readline:0= )
+ scitokens? ( dev-cpp/scitokens-cpp )
+ systemd? ( sys-apps/systemd:= )
+ xrdec? ( dev-libs/isa-l )
+"
+DEPEND="${CDEPEND}"
+BDEPEND="
+ python? (
+ ${PYTHON_DEPS}
+ ${DISTUTILS_DEPS}
+ test? ( >=dev-python/pytest-7.1.2[${PYTHON_USEDEP}] )
+ )
+ test? (
+ dev-cpp/gtest
+ dev-util/cppunit
+ )
+"
+RDEPEND="${CDEPEND}
+ dev-lang/perl
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.8.3-crc32.patch
+ "${FILESDIR}"/${PN}-5.4.3-python_tests_py3.patch
+ "${FILESDIR}"/${PN}-5.6.2-authfile.patch
+)
+
+# xrootd plugins are not intended to be linked with,
+# they are to be loaded at runtime by xrootd,
+# see https://github.com/xrootd/xrootd/issues/447
+QA_SONAME="/usr/lib.*/libXrd.*-$(ver_cut 1)\.so
+ /usr/lib.*/libXrd.*Tests\.so"
+
+pkg_setup() {
+ use python && python_setup
+}
+
+src_prepare() {
+ cmake_src_prepare
+
+ if use python; then
+ pushd "${S}"/bindings/python > /dev/null || die
+ distutils-r1_src_prepare
+ popd > /dev/null || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_SYSTEM_ISAL=TRUE
+ $(usex python "-DINSTALL_PYTHON_BINDINGS=FALSE" "")
+ -DXRDCEPH_SUBMODULE=$(usex ceph)
+ -DCMAKE_DISABLE_FIND_PACKAGE_LibXml2=$(usex libxml2 "no" "yes")
+ -DCMAKE_DISABLE_FIND_PACKAGE_systemd=$(usex systemd "no" "yes")
+ -DENABLE_FUSE=$(usex fuse)
+ -DENABLE_HTTP=$(usex http)
+ -DENABLE_KRB5=$(usex kerberos)
+ -DENABLE_MACAROONS=$(usex macaroons)
+ -DENABLE_PYTHON=$(usex python)
+ -DENABLE_READLINE=$(usex readline)
+ -DENABLE_SCITOKENS=$(usex scitokens)
+ -DENABLE_TESTS=$(usex test)
+ -DENABLE_VOMS=no
+ -DENABLE_XRDCL=yes
+ -DENABLE_XRDCLHTTP=$(usex http)
+ -DENABLE_XRDEC=$(usex xrdec)
+ -DFORCE_ENABLED=yes
+ -DXRDCL_ONLY=$(usex server "no" "yes")
+ )
+ cmake_src_configure
+
+ if use python; then
+ pushd "${BUILD_DIR}"/bindings/python > /dev/null || die
+ distutils-r1_src_configure
+ popd > /dev/null || die
+ fi
+}
+
+src_compile() {
+ cmake_src_compile
+ if use python; then
+ pushd "${BUILD_DIR}"/bindings/python > /dev/null || die
+ distutils-r1_src_compile
+ popd > /dev/null || die
+ fi
+
+ docs_compile
+ # secondary documentation for python bindings
+ if use python && use doc; then
+ emake -C bindings/python/docs html
+ fi
+}
+
+python_test() {
+ epytest
+}
+
+src_test() {
+ cmake_src_test
+ # Python tests currently require manual configuration and start-up of an xrootd server.
+ # TODO: get this to run properly.
+ #use python && distutils-r1_src_test
+}
+
+src_install() {
+ dodoc docs/ReleaseNotes.txt
+ cmake_src_install
+ find "${ED}" \( -iname '*.md5' -o -iname '*.map' \) -delete || die
+
+ if use server; then
+ local i
+ for i in cmsd frm_purged frm_xfrd xrootd; do
+ newinitd "${FILESDIR}"/${i}.initd ${i}
+ done
+ # all daemons MUST use single master config file
+ newconfd "${FILESDIR}"/xrootd.confd xrootd
+
+ if use systemd; then
+ systemd_dounit packaging/common/*.{service,socket}
+ fi
+ fi
+
+ # base configs
+ insinto /etc/xrootd
+ doins packaging/common/*.cfg
+
+ keepdir /etc/xrootd/config.d
+ keepdir /var/log/xrootd
+
+ fowners -R xrootd:xrootd /etc/xrootd
+ fowners -R xrootd:xrootd /var/log/xrootd
+
+ if use python; then
+ pushd "${BUILD_DIR}"/bindings/python > /dev/null || die
+ distutils-r1_src_install
+ popd > /dev/null || die
+
+ if use doc; then
+ docinto python
+ docompress -x "/usr/share/doc/${PF}/python/html"
+ dodoc -r bindings/python/docs/build/html
+ fi
+ if use examples; then
+ docinto python
+ dodoc -r bindings/python/examples
+ fi
+ fi
+
+ if use test; then
+ for f in test-runner xrdshmap; do
+ rm "${ED}"/usr/bin/${f} || die "Failed to remove test helper ${f} from installed tree"
+ done
+ rm "${ED}"/usr/$(get_libdir)/libXrd*Test*.so || die "Failed to remove test libraries from installed tree"
+ fi
+}