summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-02-25 00:29:05 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-02-25 00:29:15 +0100
commit4bc2745524d48d8dd4be365253f2977019e8edda (patch)
tree8e7c3f3f1395906a2dc3f3eb86dd774b498f5f37 /net-libs
parentsys-apps/portage: stable 2.2.26 for arm64 (diff)
downloadgentoo-4bc2745524d48d8dd4be365253f2977019e8edda.tar.gz
gentoo-4bc2745524d48d8dd4be365253f2977019e8edda.tar.bz2
gentoo-4bc2745524d48d8dd4be365253f2977019e8edda.zip
net-libs/libaccounts-glib: Fix SRC_URI. Thanks to Andreas Sturmlechner
Package-Manager: portage-2.2.27
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libaccounts-glib/libaccounts-glib-1.21-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-libs/libaccounts-glib/libaccounts-glib-1.21-r1.ebuild b/net-libs/libaccounts-glib/libaccounts-glib-1.21-r1.ebuild
new file mode 100644
index 000000000000..66a39ef7862d
--- /dev/null
+++ b/net-libs/libaccounts-glib/libaccounts-glib-1.21-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils vcs-snapshot
+
+DESCRIPTION="Accounts SSO (Single Sign-On) management library for GLib applications"
+HOMEPAGE="https://01.org/gsso/"
+SRC_URI="https://gitlab.com/accounts-sso/libaccounts-glib/repository/archive.tar.gz?ref=VERSION_${PV} -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/libxml2
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc
+"
+
+RESTRICT="test"
+
+DOCS=( AUTHORS NEWS )
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-python \
+ --disable-tests \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}