summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-25 12:52:01 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-25 13:50:22 +0100
commit4e4de786cd0822c77c9639e12f22225b0e64329a (patch)
tree5c116289b85cf189c2d886b86f11214d90b38287 /net-libs
parentnet-libs/libquotient: Drop 0.6.3 (diff)
downloadgentoo-4e4de786cd0822c77c9639e12f22225b0e64329a.tar.gz
gentoo-4e4de786cd0822c77c9639e12f22225b0e64329a.tar.bz2
gentoo-4e4de786cd0822c77c9639e12f22225b0e64329a.zip
net-libs/libquotient: 0.6.5 version bump
Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libquotient/Manifest1
-rw-r--r--net-libs/libquotient/libquotient-0.6.5.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/net-libs/libquotient/Manifest b/net-libs/libquotient/Manifest
index b1540c1e88d3..515c2b5d5472 100644
--- a/net-libs/libquotient/Manifest
+++ b/net-libs/libquotient/Manifest
@@ -1 +1,2 @@
DIST libquotient-0.6.4.tar.gz 559830 BLAKE2B 23a2d5bed5a5bcd30ffa00465291f5670d187d44991fe424bce5a2ce1ffc9d4fc09b0cc1e44e7b2b2470f82f6a3bcf4be2d6d9185d2952761a9a94d6f4fae2ce SHA512 6f505a697b6bd123004faaaae4ea6788ed985dafd965c5768cc838be98d6b27f65d5fb04c02d41c6a9ca2ce622acbd49264a9a14a99a087126d2852a926184ce
+DIST libquotient-0.6.5.tar.gz 560003 BLAKE2B b23437c3ef204da731723946e372685cb492ee5feab3f71f5770a27c1fa2d2810676ed2c9dbdb95499055e05a3589db92c75190471ba4dc14f3aaea8f2282216 SHA512 9079de0eec103f15cb7092319546b8be213b460ab172444e4f2f2b10d06db85485fda48546b3291db9014fddd8b22542119d6bbeb69bee1f2a208ac87990c3e4
diff --git a/net-libs/libquotient/libquotient-0.6.5.ebuild b/net-libs/libquotient/libquotient-0.6.5.ebuild
new file mode 100644
index 000000000000..0474fff2b604
--- /dev/null
+++ b/net-libs/libquotient/libquotient-0.6.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Qt5-based SDK to develop applications for Matrix"
+HOMEPAGE="https://github.com/quotient-im/libQuotient"
+SRC_URI="https://github.com/quotient-im/libQuotient/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/libQuotient-${PV}"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ # downstream patches
+ "${FILESDIR}"/${PN}-0.6.3-no-android.patch
+ "${FILESDIR}"/${PN}-0.6.3-no-tests.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DQuotient_INSTALL_TESTS=OFF
+ -DQuotient_ENABLE_E2EE=OFF # TODO: libolm, libqtolm not packaged
+ -DCMAKE_DISABLE_FIND_PACKAGE_Git=ON # no thanks.
+ )
+ cmake_src_configure
+}