summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-07-08 16:43:54 +0200
committerMarek Szuba <marecki@gentoo.org>2020-07-08 16:46:29 +0200
commit6f331c64b66482d619980b34389798d33ea04f7d (patch)
tree3e1a96cde824f92063c9d1453676a45091a13ed4 /net-libs
parentnet-misc/dhcdrop: revision bump (diff)
downloadgentoo-6f331c64b66482d619980b34389798d33ea04f7d.tar.gz
gentoo-6f331c64b66482d619980b34389798d33ea04f7d.tar.bz2
gentoo-6f331c64b66482d619980b34389798d33ea04f7d.zip
net-libs/xrootd-ceph: bump to 5.0.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/xrootd-ceph/Manifest1
-rw-r--r--net-libs/xrootd-ceph/xrootd-ceph-5.0.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/net-libs/xrootd-ceph/Manifest b/net-libs/xrootd-ceph/Manifest
index ccf5c92d389a..8d09d984f60d 100644
--- a/net-libs/xrootd-ceph/Manifest
+++ b/net-libs/xrootd-ceph/Manifest
@@ -1,2 +1,3 @@
DIST xrootd-ceph-4.12.0.tar.gz 80601 BLAKE2B 05e31ec3a03d50f36f7ef368705ca8ad064d1d9da4fc3815aaf96ce358da07348aaea264d82884da2782cf7c1069b584269fff9f2a3140057b2d4d2929639f77 SHA512 de55cc923bad3629de6428dbc4e7c7e2cb802512f03f49bcfc79f12221828cd9702f1c9a1bc28b599dce801c937146cf381dfd589c85f4f5721c4fbf13f6ad34
DIST xrootd-ceph-4.12.3.tar.gz 80615 BLAKE2B d7040be47fe3f9283036f1d56f509860c6a56f29f68835d1469f3ee48377dd90e1c76b28c65b1dab24b64e00083368e1242bd4988f15b6b9df50a0c7715d9f00 SHA512 8df64c33b97cb9d92bc0a962c34c82d789551d76a3450b56125f2924357ee46c51513f992809357a217890d1d261144a92ee1b95f075b2c8081d4646402467b0
+DIST xrootd-ceph-5.0.0.tar.gz 80615 BLAKE2B dd37dd2c76d59c8e1fe672fd9a573af8197f0f93a64e1ea1a2b02fca6be66c163c54f999089d397715135d0e209cc0b570f6d381b9f3c472a1e7316e22a03d46 SHA512 12215876bd73d59217909390595d128d03e12eed82d130ccec3b88c02620dbeb3e028e4d8101121778df5a804de1cc66bc485aa3073455ab5ef88d8ac158550f
diff --git a/net-libs/xrootd-ceph/xrootd-ceph-5.0.0.ebuild b/net-libs/xrootd-ceph/xrootd-ceph-5.0.0.ebuild
new file mode 100644
index 000000000000..f38a421f4865
--- /dev/null
+++ b/net-libs/xrootd-ceph/xrootd-ceph-5.0.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="xrootd OSS plug-in for interfacing with Ceph storage platform"
+HOMEPAGE="https://xrootd.slac.stanford.edu/"
+SRC_URI="https://github.com/xrootd/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND=">=net-libs/xrootd-5.0.0
+ sys-cluster/ceph"
+RDEPEND="${DEPEND}"
+BDEPEND="test? ( dev-util/cppunit )"
+
+# xrootd plugins are not intended to be linked with,
+# they are to be loaded at runtime by xrootd,
+# see https://github.com/xrootd/xrootd/issues/447
+QA_SONAME="/usr/lib.*/libXrdCeph.*-$(ver_cut 1)\.so
+ /usr/lib.*/libXrdCephTests\.so"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_TESTS=$(usex test)
+ # As of 5.0.0 the default plug-in version is still 4.
+ -DPLUGIN_VERSION=$(ver_cut 1)
+ )
+ cmake_src_configure
+}