summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-11-11 13:06:50 +0100
committerPacho Ramos <pacho@gentoo.org>2021-11-11 13:59:07 +0100
commit7b5ce63ca04c9e2be5fed284f067670672adf9b6 (patch)
tree5e3c592bbc718f21a2538a5196904bc54e5e5af6 /net-libs
parentsci-mathematics/genius: Bump to 1.0.27 (diff)
downloadgentoo-7b5ce63ca04c9e2be5fed284f067670672adf9b6.tar.gz
gentoo-7b5ce63ca04c9e2be5fed284f067670672adf9b6.tar.bz2
gentoo-7b5ce63ca04c9e2be5fed284f067670672adf9b6.zip
net-libs/libgfbgraph: Bump to 0.2.5
Bug: https://bugs.gentoo.org/809722 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libgfbgraph/Manifest1
-rw-r--r--net-libs/libgfbgraph/libgfbgraph-0.2.5.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/net-libs/libgfbgraph/Manifest b/net-libs/libgfbgraph/Manifest
index 9af2cbc57963..d1d22499dfad 100644
--- a/net-libs/libgfbgraph/Manifest
+++ b/net-libs/libgfbgraph/Manifest
@@ -1 +1,2 @@
DIST gfbgraph-0.2.4.tar.xz 39520 BLAKE2B 71ce5a091b5ab7d27b7b5353ff76cb67c90a358371f1afe41a561bab195c7e01353854fbd28c3970c3179ded24daf41f7150f70b5efcb1c81aac89de9fed2c88 SHA512 e6d63e56f4d67b59b0abbfb9dfe3aad8b142023413246015a84078c76f631eaa6e9fa7eb5771f64156ea01e160eb07b17783059e449036b372b4bcb26751ff68
+DIST gfbgraph-0.2.5.tar.xz 283632 BLAKE2B 7a229e098623613c3c758dd7d9d4802cf82a6b8c7f6c81ad8de2392597d13b6db9978ef1794321aa6915f9065dca030e58ef1569d64f956a7048846e996cea23 SHA512 c3a1168935272377c211d95e4efcb8ed56d129589bcaa6e0d7b5dff7ca916f0c63dc30eb1a903aea3de51cb109ae787e985bdd9485fb97cd1b5b6971bea01a1e
diff --git a/net-libs/libgfbgraph/libgfbgraph-0.2.5.ebuild b/net-libs/libgfbgraph/libgfbgraph-0.2.5.ebuild
new file mode 100644
index 000000000000..adc704afe62d
--- /dev/null
+++ b/net-libs/libgfbgraph/libgfbgraph-0.2.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GNOME_ORG_MODULE="gfbgraph"
+GNOME2_EAUTORECONF="yes"
+
+inherit gnome2
+
+DESCRIPTION="A GObject library for Facebook Graph API"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libgfbgraph/"
+
+LICENSE="LGPL-2.1+"
+SLOT="0.2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="+introspection"
+
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/json-glib[introspection?]
+ net-libs/libsoup:2.4[introspection?]
+ net-libs/gnome-online-accounts
+ net-libs/rest:0.7[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.30:= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-util/gtk-doc
+ >=dev-util/gtk-doc-am-1.14
+ virtual/pkgconfig
+"
+# gtk-doc needed for autoreconf
+
+src_prepare() {
+ # Test requires a credentials.ini file.
+ # https://gitlab.gnome.org/GNOME/libgfbgraph/-/issues/7#note_802926
+ sed -i -e 's:TESTS = gtestutils:TESTS =:' tests/Makefile.am || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection)
+}
+
+src_install() {
+ gnome2_src_install
+ # Remove files installed in the wrong place
+ # https://gitlab.gnome.org/GNOME/libgfbgraph/-/issues/10
+ rm -rf "${ED}"/usr/doc
+}