summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2018-07-16 17:17:05 +0100
committerAmy Liffey <amynka@gentoo.org>2018-07-16 16:19:36 +0100
commit7cc7c541d4b0fdacf4d1cd9e0e9bb215b3327450 (patch)
tree4444996fbee9c497e02d35c6e3bf89884606781e /net-libs
parentsci-libs/gdal: fix build with ogdi (diff)
downloadgentoo-7cc7c541d4b0fdacf4d1cd9e0e9bb215b3327450.tar.gz
gentoo-7cc7c541d4b0fdacf4d1cd9e0e9bb215b3327450.tar.bz2
gentoo-7cc7c541d4b0fdacf4d1cd9e0e9bb215b3327450.zip
net-libs/libisds: version bum 0.10.8
Closes: https://bugs.gentoo.org/660902 Submitted-by: Karel Slany <karel.slany@nic.cz> Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libisds/Manifest1
-rw-r--r--net-libs/libisds/libisds-0.10.8.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-libs/libisds/Manifest b/net-libs/libisds/Manifest
index 196ec70e70bb..b0dde93b9568 100644
--- a/net-libs/libisds/Manifest
+++ b/net-libs/libisds/Manifest
@@ -1,2 +1,3 @@
DIST libisds-0.10.6.tar.xz 724120 BLAKE2B b6d3f42d4ff84c377c9425dfd84a14ae97ccc39ea4bb96169e3a8de21b99dd6e5ceda39a6d4a574ccb418561dbec2507f72afc8b6f185c34ff92202abcc49441 SHA512 602c4e7f047dedff131cda941d02ea41fca7b8ea80eb668ab8f7ab2626a013ddc1a86f1e2c7b5759adf266c7c22c515284e6d4fdd9fd594ad310bed1be6016f4
DIST libisds-0.10.7.tar.xz 724840 BLAKE2B 73d93b518271cbd08787a38da454ceb8fa6c2d421b0291c61cded8f1438d44c5607d1e90d75714c3d76e0886ac723e38dc2a41d60284a58d567abdcba76becd4 SHA512 ba2ef11c2983cb3bc8f779e7af3fb8319d38a786911e68c6b53c25aff339b4630bdf78886825ea3da671e87f689cab376cd9e41398f3f74608af932abe7a0023
+DIST libisds-0.10.8.tar.xz 726040 BLAKE2B e3509202cb95e6e2bd0a6e7592c3d1d649ecb47806823265e5e12fa3a79a5daff9d249b2f0642d13aaebf1c64243690d06c9387fcb3a166f4b989c19f337c059 SHA512 648ba30c3156ece329d663d0d6e649319d8d104de97ca1946d94c24205c44189be08cb0c573df1f5a889fba487f2d088ac472c3f922a1920e172dda0c592b41e
diff --git a/net-libs/libisds/libisds-0.10.8.ebuild b/net-libs/libisds/libisds-0.10.8.ebuild
new file mode 100644
index 000000000000..1470c31c1070
--- /dev/null
+++ b/net-libs/libisds/libisds-0.10.8.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Client library for accessing ISDS Soap services"
+HOMEPAGE="http://xpisar.wz.cz/libisds/"
+SRC_URI="http://xpisar.wz.cz/${PN}/dist/${P}.tar.xz"
+KEYWORDS="~amd64 ~mips ~x86"
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="+curl debug nls openssl static-libs test"
+
+COMMON_DEPEND="
+ dev-libs/expat
+ dev-libs/libxml2
+ curl? ( net-misc/curl[ssl] )
+ openssl? ( dev-libs/openssl:= )
+ !openssl? (
+ app-crypt/gpgme
+ dev-libs/libgcrypt:=
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ test? ( >=net-libs/gnutls-2.12.0 )
+"
+RDEPEND="${COMMON_DEPEND}
+ !openssl? ( >=app-crypt/gnupg-2 )
+"
+
+DOCS=( NEWS README AUTHORS ChangeLog )
+
+src_configure() {
+ local myeconfargs=(
+ --disable-fatalwarnings
+ $(use_with curl libcurl)
+ $(use_enable curl curlreauthorizationbug)
+ $(use_enable debug)
+ $(use_enable nls)
+ $(use_enable openssl openssl-backend)
+ $(use_enable static-libs static)
+ $(use_enable test)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}/" \( -name "*.a" -o -name "*.la" \) -delete || die
+}