summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-08-20 11:01:15 +0200
committerJeroen Roovers <jer@gentoo.org>2019-08-20 11:02:26 +0200
commit7f7c94aee5a43251ac2812993d0c7ab51f0d17a2 (patch)
treed88673dccd1a86fcf81bafc18d28c20bd82fb31a /net-libs
parentdev-util/debhelper: Old (diff)
downloadgentoo-7f7c94aee5a43251ac2812993d0c7ab51f0d17a2.tar.gz
gentoo-7f7c94aee5a43251ac2812993d0c7ab51f0d17a2.tar.bz2
gentoo-7f7c94aee5a43251ac2812993d0c7ab51f0d17a2.zip
net-libs/libtrace: Add include for SIOCGSTAMP definition
Package-Manager: Portage-2.3.72, Repoman-2.3.17 Fixes: https://bugs.gentoo.org/692430 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libtrace/files/libtrace-4.0.9_p1-SIOCGSTAMP.patch12
-rw-r--r--net-libs/libtrace/libtrace-4.0.9_p1-r1.ebuild61
2 files changed, 73 insertions, 0 deletions
diff --git a/net-libs/libtrace/files/libtrace-4.0.9_p1-SIOCGSTAMP.patch b/net-libs/libtrace/files/libtrace-4.0.9_p1-SIOCGSTAMP.patch
new file mode 100644
index 000000000000..0693601356b2
--- /dev/null
+++ b/net-libs/libtrace/files/libtrace-4.0.9_p1-SIOCGSTAMP.patch
@@ -0,0 +1,12 @@
+diff --git a/lib/format_linux_common.h b/lib/format_linux_common.h
+index 244144b1..b6a66d30 100644
+--- a/lib/format_linux_common.h
++++ b/lib/format_linux_common.h
+@@ -44,6 +44,7 @@
+ #include <netpacket/packet.h>
+ #include <net/ethernet.h>
+ #include <net/if_arp.h>
++#include <linux/sockios.h>
+
+ #include <net/if.h>
+ #include <sys/ioctl.h>
diff --git a/net-libs/libtrace/libtrace-4.0.9_p1-r1.ebuild b/net-libs/libtrace/libtrace-4.0.9_p1-r1.ebuild
new file mode 100644
index 000000000000..84bdf221362d
--- /dev/null
+++ b/net-libs/libtrace/libtrace-4.0.9_p1-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="A library and tools for trace processing"
+HOMEPAGE="https://research.wand.net.nz/software/libtrace.php"
+SRC_URI="https://github.com/${PN^}Team/${PN}/archive//${PV/_p/-}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc ncurses numa static-libs"
+
+RDEPEND="
+ >=net-libs/libpcap-0.8
+ dev-libs/libyaml
+ dev-libs/openssl:0=
+ net-libs/wandio
+ ncurses? ( sys-libs/ncurses:0= )
+ numa? ( sys-process/numactl )
+"
+DEPEND="
+ ${RDEPEND}
+ app-doc/doxygen
+ sys-devel/flex
+ virtual/os-headers
+ virtual/pkgconfig
+ virtual/yacc
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.0.20-autoconf-1.13.patch
+ "${FILESDIR}"/${PN}-4.0.0-no-examples.patch
+ "${FILESDIR}"/${PN}-4.0.0-with-numa.patch
+ "${FILESDIR}"/${PN}-4.0.9_p1-tinfo.patch
+ "${FILESDIR}"/${PN}-4.0.9_p1-SIOCGSTAMP.patch
+)
+S=${WORKDIR}/${P/_p/-}
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with ncurses) \
+ $(use_with numa) \
+ --with-man
+}
+
+src_install() {
+ default
+
+ use doc && dodoc -r docs/doxygen/html
+
+ find "${D}" -name "*.la" -delete || die
+}