summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-11-26 23:04:54 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-11-28 00:57:24 +0100
commit882bf43a70268245456531e33e9caaefdba0a29e (patch)
treec0c1a40a6cca549c16bfc451bc244637c9765bf8 /net-libs
parentmedia-sound/tomahawk: Drop old (diff)
downloadgentoo-882bf43a70268245456531e33e9caaefdba0a29e.tar.gz
gentoo-882bf43a70268245456531e33e9caaefdba0a29e.tar.bz2
gentoo-882bf43a70268245456531e33e9caaefdba0a29e.zip
net-libs/jreen: Drop USE qt4,qt5
Build Qt5-based only. Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/jreen/jreen-1.3.0-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-libs/jreen/jreen-1.3.0-r1.ebuild b/net-libs/jreen/jreen-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..d8834856d8fb
--- /dev/null
+++ b/net-libs/jreen/jreen-1.3.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="https://github.com/euroelessar/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc ~x86"
+else
+ GIT_ECLASS="git-r3"
+ EGIT_REPO_URI="https://github.com/euroelessar/${PN}.git"
+fi
+
+inherit cmake-utils ${GIT_ECLASS}
+
+DESCRIPTION="Qt XMPP library"
+HOMEPAGE="https://github.com/euroelessar/jreen"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5
+ media-libs/speex
+ net-libs/libgsasl
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog README.md )
+
+src_configure() {
+ local mycmakeargs=(
+ -DJREEN_FORCE_QT4=OFF
+ )
+ cmake-utils_src_configure
+}