summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-11-17 10:45:39 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-11-17 10:45:39 +0000
commit92ece2968e225eb32fe4c0859e65ce19605a1035 (patch)
tree906404e88e474f9fa1d28096d8d52bfcea0da882 /net-libs
parentMerge remote-tracking branch 'github/pr/370'. (diff)
parentnet-libs/gupnp-ui: Mend underlinking issue. Fixes bug 522490. (diff)
downloadgentoo-92ece2968e225eb32fe4c0859e65ce19605a1035.tar.gz
gentoo-92ece2968e225eb32fe4c0859e65ce19605a1035.tar.bz2
gentoo-92ece2968e225eb32fe4c0859e65ce19605a1035.zip
Merge remote-tracking branch 'github/pr/359'.
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gupnp-ui/files/gupnp-ui-0.1.1-underlinking.patch25
-rw-r--r--net-libs/gupnp-ui/gupnp-ui-0.1.1.ebuild11
2 files changed, 35 insertions, 1 deletions
diff --git a/net-libs/gupnp-ui/files/gupnp-ui-0.1.1-underlinking.patch b/net-libs/gupnp-ui/files/gupnp-ui-0.1.1-underlinking.patch
new file mode 100644
index 000000000000..207eecc7f12c
--- /dev/null
+++ b/net-libs/gupnp-ui/files/gupnp-ui-0.1.1-underlinking.patch
@@ -0,0 +1,25 @@
+--- configure.ac
++++ configure.ac
+@@ -11,7 +11,7 @@
+ AC_PROG_LIBTOOL
+
+ PKG_CHECK_MODULES(LIBGUPNP_UI, gupnp-1.0 >= 0.3 gtk+-2.0)
+-
++PKG_CHECK_MODULES(GSSDP, gssdp-1.0)
+ PKG_CHECK_MODULES(GTHREAD, gthread-2.0)
+
+ # Debugging
+--- tests/Makefile.am
++++ tests/Makefile.am
+@@ -1,9 +1,9 @@
+-AM_CFLAGS = $(LIBGUPNP_UI_CFLAGS) $(GTHREAD_CFLAGS) -I$(top_srcdir)
++AM_CFLAGS = $(LIBGUPNP_UI_CFLAGS) $(GTHREAD_CFLAGS) $(GSSDP_CFLAGS) -I$(top_srcdir)
+
+ noinst_PROGRAMS = test-view
+
+ test_view_SOURCES = test-view.c
+-test_view_LDADD = $(top_builddir)/libgupnp-ui/libgupnp-ui-1.0.la $(GTHREAD_LIBS)
++test_view_LDADD = $(top_builddir)/libgupnp-ui/libgupnp-ui-1.0.la $(GTHREAD_LIBS) $(GSSDP_LIBS)
+
+ CLEANFILES = $(BUILT_SOURCES)
+ DISTCLEANFILES = $(BUILT_SOURCES)
diff --git a/net-libs/gupnp-ui/gupnp-ui-0.1.1.ebuild b/net-libs/gupnp-ui/gupnp-ui-0.1.1.ebuild
index 6ccd7ffb44cc..1d129c2e6dd1 100644
--- a/net-libs/gupnp-ui/gupnp-ui-0.1.1.ebuild
+++ b/net-libs/gupnp-ui/gupnp-ui-0.1.1.ebuild
@@ -2,7 +2,12 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=2
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit autotools-utils
DESCRIPTION="Collection of simple GTK+ widgets on top of GUPnP"
HOMEPAGE="http://gupnp.org"
@@ -19,6 +24,10 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
sys-devel/gettext"
+PATCHES=(
+ "${FILESDIR}"/${P}-underlinking.patch
+)
+
src_configure() {
econf \
--disable-dependency-tracking \