summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2022-11-21 13:04:17 -0300
committerMatt Turner <mattst88@gentoo.org>2022-11-23 11:43:37 -0500
commit95d6ac566d44ef4788387f815de6506495275acf (patch)
tree8290f127624d52944018df434b927f6122e1ef28 /net-libs
parentsys-fs/dmraid: rename intel_led to intel-led (diff)
downloadgentoo-95d6ac566d44ef4788387f815de6506495275acf.tar.gz
gentoo-95d6ac566d44ef4788387f815de6506495275acf.tar.bz2
gentoo-95d6ac566d44ef4788387f815de6506495275acf.zip
net-libs/gupnp: Version bump to 1.6.2
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gupnp/Manifest1
-rw-r--r--net-libs/gupnp/gupnp-1.6.2.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/net-libs/gupnp/Manifest b/net-libs/gupnp/Manifest
index 58dd7bd7d213..bd4b47865d82 100644
--- a/net-libs/gupnp/Manifest
+++ b/net-libs/gupnp/Manifest
@@ -1,3 +1,4 @@
DIST gupnp-1.4.3.tar.xz 154812 BLAKE2B b41a8805853061399412f5eb7267e9913adb3054ebf8a3bd78f6df4c1607d4a944654f3bc6e154fefa98f1289a80055d0feb0168801d83a1ad59c25f5fcac784 SHA512 1963ce917458168c8bc5d669ee30a4071d83d3768ce1be8cbbd81c767853ca01950623a88628a0b1e403d1cce1f0bbc9df80acf4b75f91bfc0403e0d0e6bcedb
DIST gupnp-1.6.0.tar.xz 2212044 BLAKE2B bc10b405f79845dd6a86c9110d26430bd6c67d36c761e38ddeee01135c27d196dbdc32fe09f322f9c0e19d2d424bb4f8b042531c81ce9da18e3f3d4f2d93e255 SHA512 5cf7a6c27f5b183e4f4387e478cb6f3ccdf4169a8e6a878f087ebf61aa41d31181480a42a8c38155af8a410c342dc6140a9cc44e30295f8f10333fd12fa53cc4
DIST gupnp-1.6.1.tar.xz 2215460 BLAKE2B 8bac4cfbe2fde421746be093db0043cf7333d647963a7a79c470247c6adbe58eee164b1b70f349e7aedeb7ccefb29d963beab02fc1e752306bf8587357154f4c SHA512 eccdf79eb4291af0720cda8aaf0d352eb71816ace5483bc68ede899d42d1d0b359558cc74017ceff8d0bf591b188794735b3d10d71ba85cb2b376038c7de1761
+DIST gupnp-1.6.2.tar.xz 2215220 BLAKE2B 457a334a6fe07c8038e83e63472809211751f4292a0ab176e61275d77ab904a91845bc2302dba6f320e3bc4dce5cef768489b81083e21a0cad0ed4961296aebd SHA512 52024295b86fa180cb8676541da8350cbba0758a19c90c26bc922cea68bb4584a5fc414915e73449ba10107492684edec25dcf60b1af203727c59944aa2cac34
diff --git a/net-libs/gupnp/gupnp-1.6.2.ebuild b/net-libs/gupnp/gupnp-1.6.2.ebuild
new file mode 100644
index 000000000000..14582c85caaa
--- /dev/null
+++ b/net-libs/gupnp/gupnp-1.6.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit gnome.org meson-multilib python-single-r1 vala xdg
+
+DESCRIPTION="An object-oriented framework for creating UPnP devs and control points"
+HOMEPAGE="https://wiki.gnome.org/Projects/GUPnP https://gitlab.gnome.org/GNOME/gupnp"
+
+LICENSE="LGPL-2+ GPL-2+" # gupnp-binding-tool is GPL-2+
+SLOT="1.6/1.6-0" # <API version>-<soname>
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="connman gtk-doc +introspection networkmanager +vala"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ ?? ( connman networkmanager )
+ gtk-doc? ( introspection )
+"
+
+# prefix: uuid dependency can be adapted to non-linux platforms
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.70:2[${MULTILIB_USEDEP}]
+ >=net-libs/gssdp-1.5.2:1.6=[introspection?,${MULTILIB_USEDEP}]
+ >=dev-libs/libxml2-2.9.1-r4[${MULTILIB_USEDEP}]
+ >=net-libs/libsoup-2.99.0:3.0[introspection?,${MULTILIB_USEDEP}]
+ >=sys-apps/util-linux-2.24.1-r3[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gi-docgen-2021.1 )
+ dev-libs/libxslt
+ app-text/docbook-xsl-stylesheets
+ virtual/pkgconfig
+ !connman? ( !networkmanager? ( kernel_linux? ( sys-kernel/linux-headers ) ) )
+ vala? ( $(vala_depend)
+ >=net-libs/gssdp-1.5.2:1.6[vala]
+ net-libs/libsoup:3.0[vala]
+ )
+"
+
+src_prepare() {
+ default
+ use vala && vala_setup
+}
+
+multilib_src_configure() {
+ local backend=system
+ use kernel_linux && backend=linux
+ use connman && backend=connman
+ use networkmanager && backend=network-manager
+
+ local emesonargs=(
+ -Dcontext_manager=${backend}
+ $(meson_native_use_bool introspection)
+ $(meson_native_use_bool vala vapi)
+ $(meson_native_use_bool gtk-doc gtk_doc)
+ -Dexamples=false
+ )
+ meson_src_configure
+}
+
+multilib_src_install_all() {
+ python_fix_shebang "${ED}"/usr/bin/gupnp-binding-tool-1.6
+ if use gtk-doc ; then
+ mkdir "${ED}"/usr/share/gtk-doc || die
+ mv "${ED}"/usr/share/{doc,gtk-doc}/gupnp-1.6 || die
+ fi
+}