summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2016-01-05 23:41:47 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2016-01-05 23:45:29 +0100
commit9a0e41c643cff912978733441f12e675c5c3c184 (patch)
tree81c79d4958afec50b2e07854238ddefe487da5f0 /net-libs
parentmedia-libs/sdl2-mixer: use upstream patch instead of sed hack to fix mp3 conf... (diff)
downloadgentoo-9a0e41c643cff912978733441f12e675c5c3c184.tar.gz
gentoo-9a0e41c643cff912978733441f12e675c5c3c184.tar.bz2
gentoo-9a0e41c643cff912978733441f12e675c5c3c184.zip
net-libs/gssdp: version bump to 0.14.13
Package-Manager: portage-2.2.26
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gssdp/Manifest1
-rw-r--r--net-libs/gssdp/gssdp-0.14.13.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/net-libs/gssdp/Manifest b/net-libs/gssdp/Manifest
index e3cc0cf63e4a..e6162f4dc04f 100644
--- a/net-libs/gssdp/Manifest
+++ b/net-libs/gssdp/Manifest
@@ -1,2 +1,3 @@
DIST gssdp-0.14.11.tar.xz 291872 SHA256 7bf5aeaf2119fe0bec5f3632ecf39dae15bc85276c72c2ad8dd4b0e345c6535a SHA512 1954f048b073338a744cc3d8b31c3e006a52ab2223d1b4adbeed5c563fb4cd0bd51bb4dfa018b0fd200e175e4c12d11b9a1de43a5109c5c647dcc26398dd774b WHIRLPOOL 069647057f4feaffeff6dd5fadd4a51ba2a3fba742a6b2c022292bcdafdea72dc5db5405c6417db4e7962824105978c487ed2cffe30ca347282565bff18c4887
DIST gssdp-0.14.12.1.tar.xz 297532 SHA256 b3d570455746284f3e65843c7f94d9595be54d68a9525629b625196bad2cac07 SHA512 c0d1445858f4303e353ff1287eb6e28e150e8162d095c3ffde18dee8426486b0f7bcd120e67076380f5a7f4b559b335e759d2aea4032ec2152a20c5a1ac268f5 WHIRLPOOL 7d1e670c26271a8e7509159668b7c1f0fd3156c182f5aab06bb4509b04c026c25a439f0d97733150764bc954ba8f635d6dd09c682209120d3375f7e3154a9db1
+DIST gssdp-0.14.13.tar.xz 297668 SHA256 43057f0e3c07a12ad698cfb70420da21fc6e6eefe3c83161ef69e8308979eaea SHA512 e9411d9afee28458d841b2455e08714260bd857384288603e8593adb3f48461b8b14e6f8b8b48f6b16715364e24119b32cd69a57f470fae3f7d6d74ba3784aca WHIRLPOOL e8ecdfec3b52386cfea719ea07d790420089a33d06b6f71ec29b0d6a75f7a1bda442c4ca39b690095424249a95c96d4e55beeb5881fa22a2b56f8fe10b2e50fc
diff --git a/net-libs/gssdp/gssdp-0.14.13.ebuild b/net-libs/gssdp/gssdp-0.14.13.ebuild
new file mode 100644
index 000000000000..5cdb35137672
--- /dev/null
+++ b/net-libs/gssdp/gssdp-0.14.13.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 multilib-minimal vala
+
+DESCRIPTION="A GObject-based API for handling resource discovery and announcement over SSDP"
+HOMEPAGE="https://wiki.gnome.org/Projects/GUPnP"
+
+LICENSE="LGPL-2"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="+introspection +gtk"
+
+RDEPEND="
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ >=net-libs/libsoup-2.44.2:2.4[${MULTILIB_USEDEP},introspection?]
+ gtk? ( >=x11-libs/gtk+-3.0:3 )
+ introspection? (
+ $(vala_depend)
+ >=dev-libs/gobject-introspection-1.36:= )
+ !<net-libs/gupnp-vala-0.10.3
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.14
+ sys-devel/gettext
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+"
+
+src_prepare() {
+ # Disable functional test as it requires port that might be used by rygel to
+ # be free of use
+ sed 's/\(check_PROGRAMS.*\)test-functional$(EXEEXT)/\1/' \
+ -i "${S}"/tests/Makefile.in || die
+
+ use introspection && vala_src_prepare
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ $(multilib_native_use_enable introspection) \
+ $(multilib_native_use_with gtk) \
+ --disable-static
+
+ if multilib_is_native_abi; then
+ # fix gtk-doc
+ ln -s "${S}"/doc/html doc/html || die
+ fi
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}