summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-03-25 20:55:05 +0100
committerJakov Smolić <jsmolic@gentoo.org>2022-04-21 18:35:14 +0200
commita41f166f29ca3995195e2e3179cc868a18cf8310 (patch)
tree3ae4c66ddcadcb20f89cfa4cbf6930a83ca5c320 /net-libs
parentdev-ml/base: use github archive (diff)
downloadgentoo-a41f166f29ca3995195e2e3179cc868a18cf8310.tar.gz
gentoo-a41f166f29ca3995195e2e3179cc868a18cf8310.tar.bz2
gentoo-a41f166f29ca3995195e2e3179cc868a18cf8310.zip
net-libs/libproxy: Enable mozjs detection
Closes: https://bugs.gentoo.org/811858 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/24750 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libproxy/files/libproxy-0.4.17-mozjs.patch15
-rw-r--r--net-libs/libproxy/libproxy-0.4.17-r1.ebuild (renamed from net-libs/libproxy/libproxy-0.4.17.ebuild)5
2 files changed, 19 insertions, 1 deletions
diff --git a/net-libs/libproxy/files/libproxy-0.4.17-mozjs.patch b/net-libs/libproxy/files/libproxy-0.4.17-mozjs.patch
new file mode 100644
index 000000000000..cf31c77ae53f
--- /dev/null
+++ b/net-libs/libproxy/files/libproxy-0.4.17-mozjs.patch
@@ -0,0 +1,15 @@
+Enable mozjs detection.
+Backported from https://github.com/libproxy/libproxy/commit/66b30ef388a45f66f9b118d51cc76b53fdb8bbf4
+Bug: https://bugs.gentoo.org/811858
+
+--- a/libproxy/cmake/modules.cmk
++++ b/libproxy/cmake/modules.cmk
+@@ -44,7 +44,7 @@ if(NM_FOUND)
+ set(NM_BUILD 1)
+ endif(NM_FOUND)
+ px_module(network_networkmanager "${NM_BUILD}" 0 ${NM_LIBRARIES})
+-px_module(pacrunner_mozjs 0 ${BIPR} ${MOZJS_LIBRARIES})
++px_module(pacrunner_mozjs "${MOZJS_FOUND}" ${BIPR} ${MOZJS_LIBRARIES})
+ px_module(pacrunner_natus "${NATUS_FOUND}" ${BIPR} ${NATUS_LIBRARIES})
+ px_module(pacrunner_webkit "${WEBKIT_FOUND}" ${BIPR} ${WEBKIT_LIBRARIES})
+ px_module(wpad_dns_alias 1 1)
diff --git a/net-libs/libproxy/libproxy-0.4.17.ebuild b/net-libs/libproxy/libproxy-0.4.17-r1.ebuild
index 4777e3c49fcd..0f5687d4a18a 100644
--- a/net-libs/libproxy/libproxy-0.4.17.ebuild
+++ b/net-libs/libproxy/libproxy-0.4.17-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -44,6 +44,9 @@ PATCHES=(
# prevent dependency loop with networkmanager, libsoup, glib-networking; bug #467696
# https://github.com/libproxy/libproxy/issues/28
"${FILESDIR}/${PN}-0.4.16-avoid-nm-build-dep.patch"
+
+ # enable mozjs detection, bug #811858
+ "${FILESDIR}/${PN}-0.4.17-mozjs.patch"
)
multilib_src_configure() {