summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-16 05:06:18 +0000
committerSam James <sam@gentoo.org>2021-04-16 05:33:14 +0000
commitaa2a0078975b69bf146413abc329432cd32d68e1 (patch)
tree6870d01a19cde58453668ce7dac31a057205c0ab /net-libs
parentnet-analyzer/tcpdump: add verify-sig support (diff)
downloadgentoo-aa2a0078975b69bf146413abc329432cd32d68e1.tar.gz
gentoo-aa2a0078975b69bf146413abc329432cd32d68e1.tar.bz2
gentoo-aa2a0078975b69bf146413abc329432cd32d68e1.zip
net-libs/libpcap: use live template
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libpcap/libpcap-1.10.0.ebuild18
-rw-r--r--net-libs/libpcap/libpcap-9999.ebuild32
2 files changed, 31 insertions, 19 deletions
diff --git a/net-libs/libpcap/libpcap-1.10.0.ebuild b/net-libs/libpcap/libpcap-1.10.0.ebuild
index d14f51abdc5d..eb782dc7c1a4 100644
--- a/net-libs/libpcap/libpcap-1.10.0.ebuild
+++ b/net-libs/libpcap/libpcap-1.10.0.ebuild
@@ -6,16 +6,20 @@ EAPI=7
inherit autotools multilib-minimal
DESCRIPTION="A system-independent library for user-level network packet capture"
-HOMEPAGE="
- https://www.tcpdump.org/
- https://github.com/the-tcpdump-group/libpcap
-"
-SRC_URI="https://github.com/the-tcpdump-group/${PN}/archive/${P/_pre/-bp}.tar.gz"
-S="${WORKDIR}/${PN}-${P/_pre/-bp}"
+HOMEPAGE="https://www.tcpdump.org/ https://github.com/the-tcpdump-group/libpcap"
+
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/the-tcpdump-group/libpcap"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/the-tcpdump-group/${PN}/archive/${P/_pre/-bp}.tar.gz"
+ S="${WORKDIR}/${PN}-${P/_pre/-bp}"
+
+ KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
+fi
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
IUSE="bluetooth dbus netlink rdma -remote static-libs usb -yydebug"
RDEPEND="
diff --git a/net-libs/libpcap/libpcap-9999.ebuild b/net-libs/libpcap/libpcap-9999.ebuild
index b716f8505940..2f01831d36e6 100644
--- a/net-libs/libpcap/libpcap-9999.ebuild
+++ b/net-libs/libpcap/libpcap-9999.ebuild
@@ -1,20 +1,26 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools git-r3 multilib-minimal
+
+inherit autotools multilib-minimal
DESCRIPTION="A system-independent library for user-level network packet capture"
-EGIT_REPO_URI="https://github.com/the-tcpdump-group/libpcap"
-HOMEPAGE="
- https://www.tcpdump.org/
- https://github.com/the-tcpdump-group/libpcap
-"
+HOMEPAGE="https://www.tcpdump.org/ https://github.com/the-tcpdump-group/libpcap"
+
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/the-tcpdump-group/libpcap"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/the-tcpdump-group/${PN}/archive/${P/_pre/-bp}.tar.gz"
+ S="${WORKDIR}/${PN}-${P/_pre/-bp}"
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
+fi
LICENSE="BSD"
SLOT="0"
IUSE="bluetooth dbus netlink rdma -remote static-libs usb -yydebug"
-KEYWORDS=""
RDEPEND="
bluetooth? ( net-wireless/bluez:=[${MULTILIB_USEDEP}] )
@@ -23,9 +29,7 @@ RDEPEND="
rdma? ( sys-cluster/rdma-core )
usb? ( virtual/libusb:1[${MULTILIB_USEDEP}] )
"
-DEPEND="
- ${RDEPEND}
-"
+DEPEND="${RDEPEND}"
BDEPEND="
sys-devel/flex
virtual/yacc
@@ -41,6 +45,10 @@ PATCHES=(
src_prepare() {
default
+ if ! [[ -f VERSION ]]; then
+ echo ${PV} > VERSION || die
+ fi
+
eautoreconf
}
@@ -62,7 +70,7 @@ multilib_src_compile() {
}
multilib_src_install_all() {
- dodoc CREDITS CHANGES VERSION TODO README*
+ dodoc CREDITS CHANGES VERSION TODO README.* doc/README.*
# remove static libraries (--disable-static does not work)
if ! use static-libs; then