summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2018-02-11 21:27:17 -0500
committerChris Reffett <creffett@gentoo.org>2018-02-11 21:27:57 -0500
commitb03cc15b3ecb2adfaa8738d482c46f393c3f20ec (patch)
treead26f56e6575a0527dae646310d9c4fb3ae59b48 /net-libs
parentapp-emulation/virt-manager: version bump to 1.5.0 (diff)
downloadgentoo-b03cc15b3ecb2adfaa8738d482c46f393c3f20ec.tar.gz
gentoo-b03cc15b3ecb2adfaa8738d482c46f393c3f20ec.tar.bz2
gentoo-b03cc15b3ecb2adfaa8738d482c46f393c3f20ec.zip
net-libs/libosmocore: Version + EAPI bump
Bug: https://bugs.gentoo.org/608896 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libosmocore/Manifest2
-rw-r--r--net-libs/libosmocore/libosmocore-0.10.2.ebuild46
-rw-r--r--net-libs/libosmocore/libosmocore-0.6.6.ebuild37
-rw-r--r--net-libs/libosmocore/libosmocore-9999.ebuild31
4 files changed, 62 insertions, 54 deletions
diff --git a/net-libs/libosmocore/Manifest b/net-libs/libosmocore/Manifest
index ebd2c2ed787e..995316315f4e 100644
--- a/net-libs/libosmocore/Manifest
+++ b/net-libs/libosmocore/Manifest
@@ -1,2 +1,2 @@
-DIST libosmocore-0.6.6.tar.bz2 396707 BLAKE2B 087036c4c0e583d1c071292bb4cbd659c44560d193c9cf82a3ed11a952c0fb6cd9b5c996ae9083aeb25dd4ff6feb9607634703a391eba3730513fc0948e372af SHA512 d0b2a4f0efb8c364a3c3da8cd888a30eb19f193ae13e9ecbb7126b33dd18c2c23a19672866efc365cdc49b0a971ce87d828ec3fbf7e0df4f4d6ff5f3e32a9c17
+DIST libosmocore-0.10.2.tar.bz2 646555 BLAKE2B 62dbabdbb8a397662b618863aade394ef4638dd266e059ef4c6fa54364aba60db29cce1fc6c2692af095f32b3ce186ee5b788598595fe2128f0d04caad9d83d2 SHA512 a42db3467faec9c814efe40ae8cf4a41e610b97cac04c1da30c211f116e1f7907117aaab89aca8af3dcd8aedc2be73c9e1c194b9062d33856de02feddf4bda22
DIST libosmocore-0.8.0.tar.bz2 439320 BLAKE2B 2614ddb8a1f7a0a72bae888d601264d90836daf2067716f2a264f0632699929db9b0a3d3f353629c08aaaecc84f429d6fa2c36481c8bd27ecb078f4447c937c8 SHA512 4ffd5943807440f80f70e381e477631a592fef41a3485819d94e7ce9523785e20057759aec6cac7abe57ba21b7d48e38164b7272c5bcd89882a3a8e213d89361
diff --git a/net-libs/libosmocore/libosmocore-0.10.2.ebuild b/net-libs/libosmocore/libosmocore-0.10.2.ebuild
new file mode 100644
index 000000000000..fbd3f9ee9b99
--- /dev/null
+++ b/net-libs/libosmocore/libosmocore-0.10.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Utility functions for OsmocomBB, OpenBSC and related projects"
+HOMEPAGE="http://bb.osmocom.org/trac/wiki/libosmocore"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.osmocom.org/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="http://cgit.osmocom.org/cgit/libosmocore/snapshot/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="GPL-2 LGPL-3"
+SLOT="0"
+IUSE="pcsc-lite"
+
+RDEPEND="
+ sys-libs/talloc
+ pcsc-lite? ( sys-apps/pcsc-lite )
+"
+
+DEPEND="${RDEPEND}
+ app-doc/doxygen
+"
+
+PATCHES=( "${FILESDIR}/${PN}-0.6.0-automake-1.13.patch" )
+
+src_prepare() {
+ default_src_prepare
+ # set correct version in pkgconfig files
+ sed -i "s/UNKNOWN/${PV}/" git-version-gen || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable pcsc-lite pcsc)
+}
diff --git a/net-libs/libosmocore/libosmocore-0.6.6.ebuild b/net-libs/libosmocore/libosmocore-0.6.6.ebuild
deleted file mode 100644
index 5910efc66f2a..000000000000
--- a/net-libs/libosmocore/libosmocore-0.6.6.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools eutils
-
-DESCRIPTION="Utility functions for OsmocomBB, OpenBSC and related projects"
-HOMEPAGE="http://bb.osmocom.org/trac/wiki/libosmocore"
-SRC_URI="http://cgit.osmocom.org/cgit/libosmocore/snapshot/${P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="embedded"
-
-RDEPEND="embedded? ( sys-libs/talloc )"
-DEPEND="${RDEPEND}
- app-doc/doxygen"
-
-src_prepare() {
- # set correct version in pkgconfig files
- sed -i "s/UNKNOWN/${PV}/" git-version-gen || die
-
- epatch "${FILESDIR}"/${PN}-0.6.0-automake-1.13.patch
- eautoreconf
-}
-
-src_configure() {
- econf $(use_enable embedded)
-}
-
-src_install() {
- default
- # install to correct documentation directory
- mv "${ED}"/usr/share/doc/${PN} "${ED}"/usr/share/doc/${PF} || die
-}
diff --git a/net-libs/libosmocore/libosmocore-9999.ebuild b/net-libs/libosmocore/libosmocore-9999.ebuild
index ea57bb86c30e..fbd3f9ee9b99 100644
--- a/net-libs/libosmocore/libosmocore-9999.ebuild
+++ b/net-libs/libosmocore/libosmocore-9999.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-inherit autotools eutils
+inherit autotools
DESCRIPTION="Utility functions for OsmocomBB, OpenBSC and related projects"
HOMEPAGE="http://bb.osmocom.org/trac/wiki/libosmocore"
if [[ ${PV} == 9999* ]]; then
- inherit git-2
+ inherit git-r3
EGIT_REPO_URI="git://git.osmocom.org/${PN}.git"
KEYWORDS=""
else
@@ -19,29 +19,28 @@ fi
LICENSE="GPL-2 LGPL-3"
SLOT="0"
-IUSE="embedded pcsc-lite"
+IUSE="pcsc-lite"
+
+RDEPEND="
+ sys-libs/talloc
+ pcsc-lite? ( sys-apps/pcsc-lite )
+"
-RDEPEND="embedded? ( sys-libs/talloc )
- pcsc-lite? ( sys-apps/pcsc-lite )"
DEPEND="${RDEPEND}
- app-doc/doxygen"
+ app-doc/doxygen
+"
+
+PATCHES=( "${FILESDIR}/${PN}-0.6.0-automake-1.13.patch" )
src_prepare() {
+ default_src_prepare
# set correct version in pkgconfig files
sed -i "s/UNKNOWN/${PV}/" git-version-gen || die
- epatch "${FILESDIR}"/${PN}-0.6.0-automake-1.13.patch
eautoreconf
}
src_configure() {
econf \
- $(use_enable embedded) \
$(use_enable pcsc-lite pcsc)
}
-
-src_install() {
- default
- # install to correct documentation directory
- mv "${ED}"/usr/share/doc/${PN} "${ED}"/usr/share/doc/${PF} || die
-}