summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-11-19 22:47:07 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-11-19 22:47:07 +0100
commitb15c84b67c83303acb38ed8c9c20c83ec5db4868 (patch)
tree73e6b138cbb1eec91061573a1b40903f7a4c6dec /net-libs
parentsci-mathematics/alt-ergo: remove seq reference from dune build file (diff)
downloadgentoo-b15c84b67c83303acb38ed8c9c20c83ec5db4868.tar.gz
gentoo-b15c84b67c83303acb38ed8c9c20c83ec5db4868.tar.bz2
gentoo-b15c84b67c83303acb38ed8c9c20c83ec5db4868.zip
net-libs/libupnp: add 1.14.15
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libupnp/Manifest1
-rw-r--r--net-libs/libupnp/libupnp-1.14.15.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/net-libs/libupnp/Manifest b/net-libs/libupnp/Manifest
index 9c9cad635574..ec1669c53f19 100644
--- a/net-libs/libupnp/Manifest
+++ b/net-libs/libupnp/Manifest
@@ -1 +1,2 @@
DIST libupnp-1.14.14.tar.gz 808851 BLAKE2B e1f69df386e2781cf17248733bf720c7e88c0d818ef8589648cdb4ec800c3a0cf381aa44fadcfdabcac31bf5d44091b8f421a1d53310046fb6a6c87e6035245f SHA512 bf134e87981ceb051e101b104f143672711de19a1b35cfc89a49e18f3a289fab443fbdef4a918e1f8a464de38a1eccbeee9c847c243e35f73a92373473b2465f
+DIST libupnp-1.14.15.tar.gz 809246 BLAKE2B 5918f41b64fe5e4a0209058f4706d724d0fcad74c8e3bfc2a54d6d5a1af253d4461ec43b0c896f1da14dcb3fb0925cbae3bc6eb015380e1cd23a3d88e6ed656f SHA512 dde2563eaacdd288066012f001b819ec25ab51bc36aef23db71d2eb67eef778b6b2b10b35a2f6b3041ecef20167e873e1c54e17fc4a26e8d1d9f408e2050279d
diff --git a/net-libs/libupnp/libupnp-1.14.15.ebuild b/net-libs/libupnp/libupnp-1.14.15.ebuild
new file mode 100644
index 000000000000..bbac11e95b48
--- /dev/null
+++ b/net-libs/libupnp/libupnp-1.14.15.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_PN="pupnp"
+
+DESCRIPTION="An Portable Open Source UPnP Development Kit"
+HOMEPAGE="http://pupnp.sourceforge.net/"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-release-${PV}"
+
+LICENSE="BSD"
+SLOT="0/17"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux"
+IUSE="blocking-tcp debug doc +reuseaddr samples +ssl static-libs"
+
+RDEPEND="ssl? ( dev-libs/openssl:0= )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${PN}-1.14.12-disable-network-tests.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable blocking-tcp blocking-tcp-connections)
+ $(use_enable debug)
+ --enable-ipv6
+ $(use_enable reuseaddr)
+ $(use_enable samples)
+ $(use_enable ssl open_ssl)
+ $(use_enable static-libs static)
+ )
+
+ econf ${myeconfargs[@]}
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}