summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-10-31 14:47:50 -0400
committerAnthony G. Basile <blueness@gentoo.org>2015-10-31 14:47:50 -0400
commitb7658b1a3fda7337d00de712e76494ba43c8f280 (patch)
tree6a49606d550cc4b975a3c070407a71606650f4e1 /net-libs
parentdev-java/xstream: Version bump. Fixes security bug 497652. (diff)
downloadgentoo-b7658b1a3fda7337d00de712e76494ba43c8f280.tar.gz
gentoo-b7658b1a3fda7337d00de712e76494ba43c8f280.tar.bz2
gentoo-b7658b1a3fda7337d00de712e76494ba43c8f280.zip
net-libs/libmicrohttpd: version bump 0.9.45
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libmicrohttpd/Manifest1
-rw-r--r--net-libs/libmicrohttpd/libmicrohttpd-0.9.45.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/net-libs/libmicrohttpd/Manifest b/net-libs/libmicrohttpd/Manifest
index 7e8d2735610f..176a7fc544eb 100644
--- a/net-libs/libmicrohttpd/Manifest
+++ b/net-libs/libmicrohttpd/Manifest
@@ -1,2 +1,3 @@
DIST libmicrohttpd-0.9.42.tar.gz 1232516 SHA256 00352073367003da40607319e4090a6a8308748b59246ae80e9871f34dad7d5b SHA512 6516f545a5b81aa23bb0d22582f6d7e7f028069d94e0d33d9d6f929e111a3c0e0432eb43b26b4eec87860e8b9f50de38f1b5e6e20cd8faf30512e4891f29b9f3 WHIRLPOOL 9d42c08ee37042debf2e16ddd244c91375e4cecb9843e08d58581a9838677148d90d469bcd4890d4a0680a62e691c659394067da1c7060f7c4e49b309be4417c
DIST libmicrohttpd-0.9.44.tar.gz 1244988 SHA256 f2739cc05112dc00a5ebe1a470174970ca3a3fd71dcd67fb7539af9d83b8411e SHA512 4f8e679e70e95411f762615593fcf2271df542ffab2ddd89f2c435215590ffe375c8e8c1e09cc2d21389d335cad2062944d65591b9478ea26e65123ed5dd56d9 WHIRLPOOL 8cfce79be2c8c6683a8c1b5f1c2d749a6a598346b032726e4f045dda86074fc3a4b44083385a9117eab9a1f85104962aefa2c8e805bb16104e18f6e3c0646cdf
+DIST libmicrohttpd-0.9.45.tar.gz 1246332 SHA256 1075def48da9327be22441f4a3460d24159fae2bf4bcfb4ab6e7ca5e95e54a69 SHA512 670d1d1f47ea8657d389302c9bfa8b6d8d12658fb28ce6ed7549db0d4483b1023e7e7d419651f38cef5b024f853d83f336b365624a346b811c2d94ab0d84fb01 WHIRLPOOL 691c1577fd17f6db4bd1990dcfbe4f20cb8944dd51014b349d26bfc8844e367c337eb03c91342b2d9e9923979e36e7464530ed6808636085a2daa006c5295bf6
diff --git a/net-libs/libmicrohttpd/libmicrohttpd-0.9.45.ebuild b/net-libs/libmicrohttpd/libmicrohttpd-0.9.45.ebuild
new file mode 100644
index 000000000000..a5624d651fba
--- /dev/null
+++ b/net-libs/libmicrohttpd/libmicrohttpd-0.9.45.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+MY_P="${P/_/}"
+
+DESCRIPTION="A small C library that makes it easy to run an HTTP server as part of another application"
+HOMEPAGE="https://www.gnu.org/software/libmicrohttpd/"
+SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="epoll messages ssl static-libs test"
+
+RDEPEND="ssl? (
+ dev-libs/libgcrypt:0=
+ net-libs/gnutls
+ )"
+
+# We disable tests below because they're broken,
+# but if enabled, we'll need this.
+DEPEND="${RDEPEND}
+ test? (
+ ssl? ( net-misc/curl[ssl] )
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS NEWS README ChangeLog"
+
+src_configure() {
+ econf \
+ --enable-bauth \
+ --enable-dauth \
+ --disable-examples \
+ --disable-spdy \
+ --enable-postprocessor \
+ --runstatedir=/run \
+ $(use_enable epoll) \
+ $(use_enable test curl) \
+ $(use_enable messages) \
+ $(use_enable ssl https) \
+ $(use_with ssl gnutls) \
+ $(use_enable static-libs static)
+}
+
+# tests are broken in the portage environment.
+src_test() {
+ :
+}
+
+src_install() {
+ default
+
+ use static-libs || find "${ED}" -name '*.la' -delete
+}