summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Huettel <dilfridge@gentoo.org>2021-01-06 19:14:01 +0200
committerAndreas K. Huettel <dilfridge@gentoo.org>2021-01-06 19:14:33 +0200
commitc63e887fcb8523f59de5a908b6328f12a7b0d764 (patch)
tree25436c10bd3ccbfbcfa030872bd1d900b9499c56 /net-libs
parentmedia-plugins/gst-plugins-lv2: Remove old (diff)
downloadgentoo-c63e887fcb8523f59de5a908b6328f12a7b0d764.tar.gz
gentoo-c63e887fcb8523f59de5a908b6328f12a7b0d764.tar.bz2
gentoo-c63e887fcb8523f59de5a908b6328f12a7b0d764.zip
Revert "net-libs/libgadu: Remove old"
This reverts commit 6177ebec706cc24a338e6a4b69fc9b0a00d88e2c. Signed-off-by: Andreas K. Huettel <dilfridge@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libgadu/Manifest1
-rw-r--r--net-libs/libgadu/libgadu-1.11.4.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/net-libs/libgadu/Manifest b/net-libs/libgadu/Manifest
index 3d5259346d2c..a5e8481cce0b 100644
--- a/net-libs/libgadu/Manifest
+++ b/net-libs/libgadu/Manifest
@@ -1 +1,2 @@
+DIST libgadu-1.11.4.tar.gz 210937 BLAKE2B 05719b31f1d3ffd7df059d33597943787c1f10ac1dea89dce893050719394e1f2c7b5858b4ff3d0d2421bf68c977d4dfafd20689b3a7c0dc2c0593cb4d49599c SHA512 3fc8e414470864eb953d6d0d7dc6071679907c435d76e05a0b95a2e58365fc795427679f893d337dbf9896611a6bf68047c36806b977643cf4a773d930916639
DIST libgadu-1.12.2.tar.gz 298884 BLAKE2B eee364204e9106b080a62ed4e180739b4dd9f2699fe3ddcb36493e3e29cc4e8074df17601900372c0a68da4b119f938521d4dd33baf730b279a13d80f74dbbee SHA512 d3b4fde94327ef312b1df668b8eb73fea9325c9258d85aa65e2746b73f00c2606ebe23f3330493a135a0fec1d0f24988f0cec607d4d899d880853ee8bf60e677
diff --git a/net-libs/libgadu/libgadu-1.11.4.ebuild b/net-libs/libgadu/libgadu-1.11.4.ebuild
new file mode 100644
index 000000000000..889a044752bf
--- /dev/null
+++ b/net-libs/libgadu/libgadu-1.11.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils
+
+DESCRIPTION="This library implements the client side of the Gadu-Gadu protocol"
+HOMEPAGE="http://toxygen.net/libgadu/"
+SRC_URI="https://github.com/wojtekka/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+# Bug 373215, last checked 2012.01.28
+RESTRICT="test"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha amd64 arm ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+SLOT="0"
+IUSE="doc ssl static-libs threads"
+
+COMMON_DEPEND="
+ sys-libs/zlib
+ ssl? ( net-libs/gnutls:= )
+"
+DEPEND="${COMMON_DEPEND}
+ doc? ( app-doc/doxygen )
+"
+RDEPEND="${COMMON_DEPEND}
+ !=net-im/kadu-0.6.0.2
+ !=net-im/kadu-0.6.0.1
+"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+DOCS=(AUTHORS ChangeLog NEWS README)
+
+src_configure() {
+ local myeconfargs=(
+ --without-openssl
+ $(use_with threads pthread)
+ $(use_with ssl gnutls)
+ )
+
+ autotools-utils_src_configure
+}
+
+src_install() {
+ use doc && HTML_DOCS=(docs/html/)
+ autotools-utils_src_install
+}