summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-03-28 15:45:59 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-03-28 16:15:53 +0200
commitc9806b6d0b793029d75d1db0c774ab69e3f94251 (patch)
treedecc8617149a73a15d2c57c7e94855a9418da3e1 /net-libs
parentmedia-libs/phonon-vlc: 0.11.3 version bump (diff)
downloadgentoo-c9806b6d0b793029d75d1db0c774ab69e3f94251.tar.gz
gentoo-c9806b6d0b793029d75d1db0c774ab69e3f94251.tar.bz2
gentoo-c9806b6d0b793029d75d1db0c774ab69e3f94251.zip
net-libs/libquotient: 0.6.6 version bump
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libquotient/Manifest1
-rw-r--r--net-libs/libquotient/libquotient-0.6.6.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/net-libs/libquotient/Manifest b/net-libs/libquotient/Manifest
index 515c2b5d5472..3a3648f0a636 100644
--- a/net-libs/libquotient/Manifest
+++ b/net-libs/libquotient/Manifest
@@ -1,2 +1,3 @@
DIST libquotient-0.6.4.tar.gz 559830 BLAKE2B 23a2d5bed5a5bcd30ffa00465291f5670d187d44991fe424bce5a2ce1ffc9d4fc09b0cc1e44e7b2b2470f82f6a3bcf4be2d6d9185d2952761a9a94d6f4fae2ce SHA512 6f505a697b6bd123004faaaae4ea6788ed985dafd965c5768cc838be98d6b27f65d5fb04c02d41c6a9ca2ce622acbd49264a9a14a99a087126d2852a926184ce
DIST libquotient-0.6.5.tar.gz 560003 BLAKE2B b23437c3ef204da731723946e372685cb492ee5feab3f71f5770a27c1fa2d2810676ed2c9dbdb95499055e05a3589db92c75190471ba4dc14f3aaea8f2282216 SHA512 9079de0eec103f15cb7092319546b8be213b460ab172444e4f2f2b10d06db85485fda48546b3291db9014fddd8b22542119d6bbeb69bee1f2a208ac87990c3e4
+DIST libquotient-0.6.6.tar.gz 560130 BLAKE2B a8f12af320e0f67b0fe40ec3892cfb2bb7686f066633c061936007e0eceefe5133d3c021a0d1856504f606b5c1bdb66ffa9d8d304b0b631be34f938ffaa061d6 SHA512 7560194bee5b6478ac8efd15d6cfef9cc003073744b4860e3177e51e49135cf2ad96c69e8cd21e64c1f9902ea4d27c26d84d200fc862c5c0daeb0cc4bb4ea65d
diff --git a/net-libs/libquotient/libquotient-0.6.6.ebuild b/net-libs/libquotient/libquotient-0.6.6.ebuild
new file mode 100644
index 000000000000..0474fff2b604
--- /dev/null
+++ b/net-libs/libquotient/libquotient-0.6.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Qt5-based SDK to develop applications for Matrix"
+HOMEPAGE="https://github.com/quotient-im/libQuotient"
+SRC_URI="https://github.com/quotient-im/libQuotient/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/libQuotient-${PV}"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ # downstream patches
+ "${FILESDIR}"/${PN}-0.6.3-no-android.patch
+ "${FILESDIR}"/${PN}-0.6.3-no-tests.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DQuotient_INSTALL_TESTS=OFF
+ -DQuotient_ENABLE_E2EE=OFF # TODO: libolm, libqtolm not packaged
+ -DCMAKE_DISABLE_FIND_PACKAGE_Git=ON # no thanks.
+ )
+ cmake_src_configure
+}