summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-12-16 12:35:27 +0000
committerMarek Szuba <marecki@gentoo.org>2021-12-16 15:48:25 +0000
commitcce0e7c564e13513046fc16d4156f8517fa76a88 (patch)
tree338e2850c2131e8be43f6e0fdb7ef9aa03dfa8c1 /net-libs
parentnet-libs/xrootd: block OpenSSL-3.0 (diff)
downloadgentoo-cce0e7c564e13513046fc16d4156f8517fa76a88.tar.gz
gentoo-cce0e7c564e13513046fc16d4156f8517fa76a88.tar.bz2
gentoo-cce0e7c564e13513046fc16d4156f8517fa76a88.zip
net-libs/xrootd: add 5.4.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/xrootd/Manifest1
-rw-r--r--net-libs/xrootd/metadata.xml3
-rw-r--r--net-libs/xrootd/xrootd-5.4.0.ebuild125
3 files changed, 128 insertions, 1 deletions
diff --git a/net-libs/xrootd/Manifest b/net-libs/xrootd/Manifest
index fa1e42cc0cca..9d0af636c386 100644
--- a/net-libs/xrootd/Manifest
+++ b/net-libs/xrootd/Manifest
@@ -2,3 +2,4 @@ DIST xrootd-5.0.3.tar.gz 2766694 BLAKE2B 1fe7743de4d09c95257c3d761c2056024ba3ba5
DIST xrootd-5.1.1.tar.gz 2869346 BLAKE2B daad5f4e1253dce7d83d144aabbbd24afca9affafc6643b8e7124c68ff8651a3a15ed1b40680a40b737411132ccd0b697d4cacfcdd2bd64d5b5640875684c464 SHA512 aee5373f2064eaa489abc7a560ca61b98f824e8f0b3665dbea82e0362a91a3b4f9e6457d0a304692ae58619ef7c16333a8c69a69d282bd48948a968dd4a06e4f
DIST xrootd-5.2.0.tar.gz 2935040 BLAKE2B 1aa58ea188faef3e3691e77b08529d14e0bf04c18127b8b8ae6a7154700af67b1d900b64cf4f505b90963e2925e32935d4bcf9d1d913ba0973713b5c69301dd2 SHA512 cfd41d2e678ad339677abb62f329828de368ea5af9c9103722b75bcbb0812a2f1695986ca953651e2418fc839d7a50072635b806c9292aeaff702e269bbc11da
DIST xrootd-5.3.1.tar.gz 2957788 BLAKE2B 6669ce4811e6c65ef17f06ae219e19e1f12027f4f9b620ad447df53ac437b30ce6425dc783a0ac7e4557d18ab562c266ac2497d93e93a2058fe5bd4aa7bc1d42 SHA512 a65436fe649233bb28123d9529d496c11b4ff40ba5490cbcbb32ff5379e555cfd684fad350c784c80e70056bb5d2e9701a80543c7f4a8ceb11e935aea01800b3
+DIST xrootd-5.4.0.tar.gz 3225065 BLAKE2B cda6b14fae4c4c8d34367fa3ff448c02bf3ecda9c6bb4029d3a6b53370a57445ac25de77d5324dd4dab8c92cda77490efdbb862e4db6b926e19ad3363278f046 SHA512 59f93db433f0e88439d5edfffb75d7813bae253e50c390fe8c43ef924bc36f5f4a56db9b00a44013c60c4b4bd5a0accaff2a8ca793fe37e59dc77dd8ab8f6837
diff --git a/net-libs/xrootd/metadata.xml b/net-libs/xrootd/metadata.xml
index 07427db64e20..a911c7c2e75c 100644
--- a/net-libs/xrootd/metadata.xml
+++ b/net-libs/xrootd/metadata.xml
@@ -9,12 +9,13 @@
XROOTD software framework is a fully generic suite for fast, low latency
and scalable data access, which can serve natively any kind of data,
organized as a hierarchical filesystem-like namespace, based on the
- concept of directory.
+ concept of directory.
It is usually used with <pkg>sci-physics/root</pkg> and its PROOF
facilities for cluster computing in high energy physics.
</longdescription>
<use>
<flag name="fuse">Enable the <pkg>sys-fs/fuse</pkg> filesystem driver</flag>
<flag name="http">Enable http protocol support</flag>
+ <flag name="server">Install xrootd server and related plug-ins</flag>
</use>
</pkgmetadata>
diff --git a/net-libs/xrootd/xrootd-5.4.0.ebuild b/net-libs/xrootd/xrootd-5.4.0.ebuild
new file mode 100644
index 000000000000..b13ed2e2e71d
--- /dev/null
+++ b/net-libs/xrootd/xrootd-5.4.0.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+# Upstream does not support the building of Python bindings
+# via CMake for more than one implementation at a time.
+inherit cmake python-single-r1
+
+DESCRIPTION="Extended ROOT remote file server"
+HOMEPAGE="https://xrootd.slac.stanford.edu/"
+SRC_URI="https://xrootd.slac.stanford.edu/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples fuse http kerberos python readline +server ssl systemd test"
+RESTRICT="!test? ( test )"
+
+CDEPEND="acct-group/xrootd
+ acct-user/xrootd
+ sys-libs/zlib
+ virtual/libcrypt:=
+ fuse? ( sys-fs/fuse:= )
+ kerberos? ( virtual/krb5 )
+ python? ( ${PYTHON_DEPS} )
+ readline? ( sys-libs/readline:0= )
+ ssl? ( <dev-libs/openssl-3.0.0:0= )
+ systemd? ( sys-apps/systemd:= )
+"
+DEPEND="${CDEPEND}"
+BDEPEND="
+ doc? (
+ app-doc/doxygen[dot]
+ virtual/latex-base
+ python? ( dev-python/sphinx )
+ )
+ test? ( dev-util/cppunit )
+"
+RDEPEND="${CDEPEND}
+ dev-lang/perl
+"
+REQUIRED_USE="
+ http? ( kerberos ssl )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ test? ( server )
+"
+
+PATCHES=( "${FILESDIR}"/xrootd-4.8.3-crc32.patch )
+
+# xrootd plugins are not intended to be linked with,
+# they are to be loaded at runtime by xrootd,
+# see https://github.com/xrootd/xrootd/issues/447
+QA_SONAME="/usr/lib.*/libXrd.*-$(ver_cut 1)\.so
+ /usr/lib.*/libXrdClTests\.so"
+
+pkg_setup() {
+ use python && python_setup
+}
+
+# FIXME: no systemd automagic!
+# FIXME: support xrdec - currently only builds against bundled isa-l
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CRYPTO=$(usex ssl)
+ -DENABLE_FUSE=$(usex fuse)
+ -DENABLE_HTTP=$(usex http)
+ -DENABLE_KRB5=$(usex kerberos)
+ -DENABLE_PYTHON=$(usex python)
+ -DENABLE_READLINE=$(usex readline)
+ -DENABLE_TESTS=$(usex test)
+ -DXRDCL_ONLY=$(usex server "no" "yes")
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ if use doc; then
+ doxygen Doxyfile || die
+ if use python; then
+ emake -C bindings/python/docs html
+ fi
+ fi
+}
+
+src_install() {
+ use doc && HTML_DOCS=( doxydoc/html/. )
+ dodoc docs/ReleaseNotes.txt
+ cmake_src_install
+ find "${D}" \( -iname '*.md5' -o -iname '*.map' \) -delete || die
+
+ # base configs
+ insinto /etc/xrootd
+ doins packaging/common/*.cfg
+
+ fowners root:xrootd /etc/xrootd
+ keepdir /var/log/xrootd
+ fowners xrootd:xrootd /var/log/xrootd
+
+ if use server; then
+ local i
+ for i in cmsd frm_purged frm_xfrd xrootd; do
+ newinitd "${FILESDIR}"/${i}.initd ${i}
+ done
+ # all daemons MUST use single master config file
+ newconfd "${FILESDIR}"/xrootd.confd xrootd
+ fi
+
+ if use python; then
+ python_optimize "${D}/$(python_get_sitedir)"
+
+ if use doc; then
+ docinto python
+ docompress -x "/usr/share/doc/${PF}/python/html"
+ dodoc -r bindings/python/docs/build/html
+ fi
+ if use examples; then
+ docinto python
+ dodoc -r bindings/python/examples
+ fi
+ fi
+}