summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-09-02 18:47:21 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-09-02 20:00:59 +0200
commitd0adfdcb6fc1804c44f7753a36f1e44134cbf987 (patch)
treea383c2afe36f017bc54984e1ed5f2ed75f41fb68 /net-libs
parentsys-block/tgt: stabilize 1.0.87-r1 for amd64, arm64, ppc64, x86 (diff)
downloadgentoo-d0adfdcb6fc1804c44f7753a36f1e44134cbf987.tar.gz
gentoo-d0adfdcb6fc1804c44f7753a36f1e44134cbf987.tar.bz2
gentoo-d0adfdcb6fc1804c44f7753a36f1e44134cbf987.zip
net-libs/libquotient: add 0.8.1.1
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libquotient/Manifest1
-rw-r--r--net-libs/libquotient/libquotient-0.8.1.1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/net-libs/libquotient/Manifest b/net-libs/libquotient/Manifest
index 0c92d936edf6..3a29c54c7a3f 100644
--- a/net-libs/libquotient/Manifest
+++ b/net-libs/libquotient/Manifest
@@ -1,2 +1,3 @@
DIST libquotient-0.7.2.tar.gz 671676 BLAKE2B 37a22c01b94bb77b89534e48ebcf8427429760095ecdc9427297c57e1d7dabdaaeaf9c7498b4695d23e468b89e1ac9cd44b9f64593454e5c3f8f452b95745c75 SHA512 ba849b938c0bf93e075da466a8360703fb903ac2735b35a7e83944a1288c9324ff76daaf57164144c55cef450fc658e42e6dcacfd23f87a4db455019e9c21f47
DIST libquotient-0.8.0.tar.gz 725645 BLAKE2B f8374e31755f73957bef5ec960e04e131bddaba8f05b43cb369dd2dda62021f22ab1e7c640f73c874db83b580a5ef789df1c5cf4590d8395d2aaaa5fdce7c506 SHA512 5ea12d8c1e0091a0dd1a6130b9ca540f993ad560acbe6391522eacae6c38ef83665338bb407d0898d03bac5e0660b46db2f735b9ded35ff4b195a8d34c8c96ff
+DIST libquotient-0.8.1.1.tar.gz 730335 BLAKE2B 6c26ab8dd5a1687aedf008ce54045022b10b4e7612964aa5e09151601f1c904a999d874f84d3c18ed3aad5f49d9df94aaa202f1fe369b4e2d4050bec897db7c1 SHA512 ac877b39a2a5869016b099d1175945de6e28fa57e561a14855a96859a3f9334870448d650e06a9574c70d1700e79af12b948244b79415238f279a027dbfde38e
diff --git a/net-libs/libquotient/libquotient-0.8.1.1.ebuild b/net-libs/libquotient/libquotient-0.8.1.1.ebuild
new file mode 100644
index 000000000000..028bf333bf11
--- /dev/null
+++ b/net-libs/libquotient/libquotient-0.8.1.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Qt-based SDK to develop applications for Matrix"
+HOMEPAGE="https://github.com/quotient-im/libQuotient"
+SRC_URI="https://github.com/quotient-im/libQuotient/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/libQuotient-${PV}"
+
+LICENSE="LGPL-2+"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/olm
+ dev-libs/openssl:=
+ dev-libs/qtkeychain:=[qt5(+)]
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsql:5
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-qt/qtconcurrent:5
+ dev-qt/qttest:5
+ )
+"
+
+PATCHES=(
+ # downstream patches
+ "${FILESDIR}"/${PN}-0.8.0-no-android.patch
+ "${FILESDIR}"/${PN}-0.8.0-no-tests.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_WITH_QT6=OFF
+ -DBUILD_TESTING=$(usex test)
+ -DQuotient_ENABLE_E2EE=ON
+ )
+ use test && mycmakeargs+=(
+ -DQuotient_INSTALL_TESTS=OFF
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ # https://github.com/quotient-im/libQuotient/issues/435
+ # testolmaccount requires network connection/server set up
+ local myctestargs=(
+ -j1
+ -E "(testolmaccount)"
+ )
+ cmake_src_test
+}