summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-08-21 09:38:26 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-08-21 09:39:15 +0200
commitd227fa184a79bacb57acd5a7858afb3027b5aeb7 (patch)
tree93ee1164436ee7185622e2d4212a1e0a0e8d921b /net-libs
parentnet-print/cups-filters: Removed old. (diff)
downloadgentoo-d227fa184a79bacb57acd5a7858afb3027b5aeb7.tar.gz
gentoo-d227fa184a79bacb57acd5a7858afb3027b5aeb7.tar.bz2
gentoo-d227fa184a79bacb57acd5a7858afb3027b5aeb7.zip
net-libs/nghttp2: Bump to version 1.25.0
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nghttp2/Manifest1
-rw-r--r--net-libs/nghttp2/nghttp2-1.25.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/net-libs/nghttp2/Manifest b/net-libs/nghttp2/Manifest
index 4e8f68bf3fe6..54df780d7bd7 100644
--- a/net-libs/nghttp2/Manifest
+++ b/net-libs/nghttp2/Manifest
@@ -2,3 +2,4 @@ DIST nghttp2-1.10.0.tar.gz 2086580 SHA256 192dc031e71e182240079befae9db7e64c9951
DIST nghttp2-1.19.0.tar.gz 2159530 SHA256 b67946ad211aa3f7c91f4d866f47b056e821da8e31ab4636130d59be87f53016 SHA512 50f45082f725c237a0e1d25af57992b9cded6c9b68f0aa95c44c16eb4448e05b14e06c853032924d03034115286163de0ad684827cfa5d70896656868fdb4e01 WHIRLPOOL d6178a31aadfcfc3547ab4b0f58ba8f5b34a95ebc1168b7f03b4bfba58a03737b061eea020c264a2da882f0f6541620cd001e62919b82f5b1ada552402c2fab0
DIST nghttp2-1.23.1.tar.gz 2175088 SHA256 ff8eb39a3e19b438c38ec99fcf783fba4f9cb2484c6a7207b42b356210c5e41a SHA512 eb709f0174b6f2030d52f76e386e1240a1708bf948c0437eda0a6ea1bc828af3dfaaaf951629043edbd986f8ba2de6b6f838cb56523028494037e36b968ad39f WHIRLPOOL 73b368e2d67f3879b166a56ece4484a4a46f328b53099d90a89e3dd38d8bc43c716ef8f9aa120490615575876380d34080db066194e5a5f93a95f50ff1db2dd4
DIST nghttp2-1.24.0.tar.gz 2177551 SHA256 5058da99c94764ff39f4a7046b9c8f0b6bafa10ec2fc096945a5d9d693654840 SHA512 e69a286c0dbd15073f19b908995021c78a25c94f1d435c1ddc5f7277d346d6cc57d2c826588076e269bf700980c7f355f2e0d45f08f0bbb768f7d78e7f543671 WHIRLPOOL 0915a0789aa0d147131bfa0ad40db90030819f40bff5c28d3a5ce07da9eca8ec8fa453747ef99b66bc20957b446b41cd3861e4db588e4d0251d348d6c8b71f10
+DIST nghttp2-1.25.0.tar.gz 2213656 SHA256 23fe0c97505a73154bbdfd2fcf47f5fa652ad8be4a88c3a4bfe8ff517026ef0f SHA512 2264b073ddcf1852c9f9c6d104ecba3c6b08385d6933f89f01b0ba915c1715c6a963da69c96eb4eb41622994bac6cd222d24c4dc8e152a45787f06d17693e809 WHIRLPOOL 28fecceefd294d2a7950cc740e01898db6e5901fbf8357f7f3c5cb6170909451be28924de28c1fb2d97fe60a5acfd1599a260aef3bb3ab5fe4173a05fef818cf
diff --git a/net-libs/nghttp2/nghttp2-1.25.0.ebuild b/net-libs/nghttp2/nghttp2-1.25.0.ebuild
new file mode 100644
index 000000000000..3ec4b994bb7c
--- /dev/null
+++ b/net-libs/nghttp2/nghttp2-1.25.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# TODO: Add python support.
+
+EAPI=6
+
+inherit multilib-minimal
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/tatsuhiro-t/nghttp2.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/tatsuhiro-t/nghttp2/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="HTTP/2 C Library"
+HOMEPAGE="https://nghttp2.org/"
+
+LICENSE="MIT"
+SLOT="0/1.14" # <C++>.<C> SONAMEs
+IUSE="cxx debug hpack-tools jemalloc libressl static-libs test +threads utils xml"
+
+RDEPEND="
+ cxx? ( dev-libs/boost:=[${MULTILIB_USEDEP},threads] )
+ hpack-tools? ( >=dev-libs/jansson-2.5 )
+ jemalloc? ( dev-libs/jemalloc[${MULTILIB_USEDEP}] )
+ utils? (
+ >=dev-libs/libev-4.15[${MULTILIB_USEDEP}]
+ !libressl? ( >=dev-libs/openssl-1.0.2:0[-bindist,${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
+ >=sys-libs/zlib-1.2.3[${MULTILIB_USEDEP}]
+ net-dns/c-ares:=[${MULTILIB_USEDEP}]
+ )
+ xml? ( >=dev-libs/libxml2-2.7.7:2[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-examples \
+ --disable-failmalloc \
+ --disable-werror \
+ --without-cython \
+ --disable-python-bindings \
+ --without-spdylay \
+ $(use_enable cxx asio-lib) \
+ $(use_enable debug) \
+ $(multilib_native_use_enable hpack-tools) \
+ $(use_enable static-libs static) \
+ $(use_enable threads) \
+ $(multilib_native_use_enable utils app) \
+ $(multilib_native_use_with jemalloc) \
+ $(multilib_native_use_with xml libxml2)
+}
+
+multilib_src_install_all() {
+ use static-libs || find "${ED}"/usr -name '*.la' -delete
+}