summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-05-28 21:11:43 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-06-11 13:47:19 +0200
commitf33655f96805bd97322879065539c8445757cb88 (patch)
treed7e5f11446492b4ca0f884083e86efee83ec6837 /net-libs
parentnet-im/kadu: Drop old (diff)
downloadgentoo-f33655f96805bd97322879065539c8445757cb88.tar.gz
gentoo-f33655f96805bd97322879065539c8445757cb88.tar.bz2
gentoo-f33655f96805bd97322879065539c8445757cb88.zip
net-libs/qxmpp: Revbump without USE=qt4,qt5
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/qxmpp/qxmpp-0.9.3-r1.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/net-libs/qxmpp/qxmpp-0.9.3-r1.ebuild b/net-libs/qxmpp/qxmpp-0.9.3-r1.ebuild
new file mode 100644
index 000000000000..688a4490a702
--- /dev/null
+++ b/net-libs/qxmpp/qxmpp-0.9.3-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit qmake-utils
+
+DESCRIPTION="A cross-platform C++ XMPP client library based on the Qt framework"
+HOMEPAGE="https://github.com/qxmpp-project/qxmpp/"
+SRC_URI="https://github.com/${PN}-project/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="debug doc opus +speex test theora vpx"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtxml:5
+ opus? ( media-libs/opus )
+ speex? ( media-libs/speex )
+ theora? ( media-libs/libtheora )
+ vpx? ( media-libs/libvpx )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-qt/qttest:5 )
+"
+
+src_prepare(){
+ if ! use doc; then
+ sed -i \
+ -e '/SUBDIRS/s/doc//' \
+ -e '/INSTALLS/d' \
+ qxmpp.pro || die "sed for removing docs failed"
+ fi
+ if ! use test; then
+ sed -i -e '/SUBDIRS/s/tests//' \
+ qxmpp.pro || die "sed for removing tests failed"
+ fi
+ # There is no point in building examples. Also, they require dev-qt/qtgui
+ sed -i -e '/SUBDIRS/s/examples//' \
+ qxmpp.pro || die "sed for removing examples failed"
+ default_src_prepare
+}
+
+src_configure(){
+ local conf_speex
+ local conf_theora
+ local conf_vpx
+
+ use opus && conf_opus="QXMPP_USE_OPUS=1"
+ use speex && conf_speex="QXMPP_USE_SPEEX=1"
+ use theora && conf_theora="QXMPP_USE_THEORA=1"
+ use vpx && conf_vpx="QXMPP_USE_VPX=1"
+
+ eqmake5 "${S}"/qxmpp.pro "PREFIX=${EPREFIX}/usr" "LIBDIR=$(get_libdir)" "${conf_opus}" "${conf_speex}" "${conf_theora}" "${conf_vpx}"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+ if use doc; then
+ # Use proper path for documentation
+ mv "${ED}"/usr/share/doc/${PN} "${ED}"/usr/share/doc/${PF} || die "doc mv failed"
+ fi
+}
+
+src_test() {
+ MAKEOPTS="-j1" # random tests fail otherwise
+ default_src_test
+}