summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-11-09 21:07:45 -0500
committerAaron Bauman <bman@gentoo.org>2019-11-09 21:07:45 -0500
commit27c97baf660c9c63c948d91dc8760ea937e77b56 (patch)
tree1afb8546b33a6acd349e562f0531824a1975db1d /net-mail/altermime/altermime-0.3.11.ebuild
parentmedia-gfx/sam2p: drop old EAPI (diff)
downloadgentoo-27c97baf660c9c63c948d91dc8760ea937e77b56.tar.gz
gentoo-27c97baf660c9c63c948d91dc8760ea937e77b56.tar.bz2
gentoo-27c97baf660c9c63c948d91dc8760ea937e77b56.zip
net-mail/altermime: bump EAPI and stuff
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'net-mail/altermime/altermime-0.3.11.ebuild')
-rw-r--r--net-mail/altermime/altermime-0.3.11.ebuild22
1 files changed, 12 insertions, 10 deletions
diff --git a/net-mail/altermime/altermime-0.3.11.ebuild b/net-mail/altermime/altermime-0.3.11.ebuild
index 9d8ff8c549ae..1e09d54ec526 100644
--- a/net-mail/altermime/altermime-0.3.11.ebuild
+++ b/net-mail/altermime/altermime-0.3.11.ebuild
@@ -1,22 +1,24 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit eutils toolchain-funcs
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION=" alterMIME is a small program which is used to alter your mime-encoded mailpacks"
-SRC_URI="http://www.pldaniels.com/altermime/${P}.tar.gz"
-HOMEPAGE="http://pldaniels.com/altermime/"
+HOMEPAGE="https://pldaniels.com/altermime/"
+SRC_URI="https://www.pldaniels.com/altermime/${P}.tar.gz"
+
+KEYWORDS="amd64 ppc x86"
LICENSE="Sendmail"
SLOT="0"
-KEYWORDS="amd64 ppc x86"
IUSE=""
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.3.10-MIME_headers-overflow.patch \
- "${FILESDIR}"/${P}-respect-flags.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.3.10-MIME_headers-overflow.patch
+ "${FILESDIR}"/${P}-respect-flags.patch
+)
src_compile() {
emake CC="$(tc-getCC)"