summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2020-03-28 11:19:00 -0500
committerMarc Schiffbauer <mschiff@gentoo.org>2020-03-28 11:19:00 -0500
commit0fa3fcf4a6601fb1719db169aea4783391c608e1 (patch)
treec3dedaac27fcddef637e662a4cda9bc86cfbec8c /net-mail/automx2
parentnet-mail/automx2: Depend on dev-python/ldap3 (diff)
downloadgentoo-0fa3fcf4a6601fb1719db169aea4783391c608e1.tar.gz
gentoo-0fa3fcf4a6601fb1719db169aea4783391c608e1.tar.bz2
gentoo-0fa3fcf4a6601fb1719db169aea4783391c608e1.zip
net-mail/automx2: remove old version
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Marc Schiffbauer <mschiff@gentoo.org>
Diffstat (limited to 'net-mail/automx2')
-rw-r--r--net-mail/automx2/automx2-2020.1.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/net-mail/automx2/automx2-2020.1.ebuild b/net-mail/automx2/automx2-2020.1.ebuild
deleted file mode 100644
index cce12b5bc749..000000000000
--- a/net-mail/automx2/automx2-2020.1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="Email client autoconfiguration service"
-HOMEPAGE="https://automx.org/"
-SRC_URI="https://gitlab.com/automx/automx2/-/archive/${PV}/${P}.tar.bz2"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="doc"
-
-BDEPEND="acct-user/automx2
- >=dev-python/flask-migrate-2.5.2[${PYTHON_USEDEP}]"
-RDEPEND="${BDEPEND}"
-
-python_prepare_all() {
- sed -i -e "/('scripts'/d" setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- export AUTOMX2_CONF="tests/unittest.conf"
- ${EPYTHON} -m unittest discover tests/ || die
-}
-
-python_install_all() {
- if use doc; then
- DOCS="*.adoc doc/*.adoc contrib/*sample.conf"
- HTML_DOCS="doc/*.html doc/*.svg"
- fi
- sed -e "s/@EPYTHON@/${EPYTHON}/" "${FILESDIR}/init" | newinitd - "${PN}"
- newconfd "${FILESDIR}/confd" "${PN}"
- insinto /etc
- newins "${FILESDIR}/conf" "${PN}.conf"
- distutils-r1_python_install_all
-}