summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Seichter <github@seichter.de>2021-04-20 21:45:21 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-06-06 19:19:47 +0300
commit26d9b43260f7f74783c30e1a552de41893b5731c (patch)
tree76d1ef54a65566fa362da7dc1fb4f3d93538939d /net-mail/automx2
parentsci-libs/cbflib & sci-chemistry/rasmol: remove last-rited packages (diff)
downloadgentoo-26d9b43260f7f74783c30e1a552de41893b5731c.tar.gz
gentoo-26d9b43260f7f74783c30e1a552de41893b5731c.tar.bz2
gentoo-26d9b43260f7f74783c30e1a552de41893b5731c.zip
net-mail/automx2: Bump to version 2021.4
Upstream bugfix release. Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Ralph Seichter <gentoo@seichter.de> Closes: https://github.com/gentoo/gentoo/pull/20477 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-mail/automx2')
-rw-r--r--net-mail/automx2/Manifest1
-rw-r--r--net-mail/automx2/automx2-2021.4.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/net-mail/automx2/Manifest b/net-mail/automx2/Manifest
index 26d3221f2ceb..2d161d945fc3 100644
--- a/net-mail/automx2/Manifest
+++ b/net-mail/automx2/Manifest
@@ -1,2 +1,3 @@
DIST automx2-2021.2.tar.gz 155311 BLAKE2B 6ace715e24a27a8e98f09920150bd5d6fef7567fa7c3884825140ea8eebebb1392dcfbfab2b5a464f7967adcf421af5997023a7d33f41036608948b59e58155f SHA512 89113d3a37ee66ae44f98d64480419e6c6b10662560a5319ca0f5522d6195a68f586ec94793c2212d859693a50455a8b43292dd859b912404b5abb2ddfc939b6
DIST automx2-2021.3.1.tar.gz 169574 BLAKE2B cc9fcb1f2009e4c7ee9d827b89dbc7e0e95002b2ee7e6e30f1e27edcef439198db8e1ea3435a124dae3f6af19e12bb9f535af57e02fd56dd12185077db50bba8 SHA512 842cc824a8c10ac86f1d8c1f12984035f58c5c935ab7e0e306ed639100f850b47b65f911328f2d391f20dd2e7fad7c0eb6c533b2f2e1776261cffc934e8ae10a
+DIST automx2-2021.4.tar.gz 170903 BLAKE2B 9c8e9bc95eeac9a8a59430248d532d540e70a40c4d61f006d5d2649198e856e4b404ed75df745cfb06887c58049a9a233a597059e2f2971bf9f1c8ce65a34f3d SHA512 f306bfdca10dc884bef404e5ff24181dc9adfb8514fd0e0d984bac84ca4996f0978eda7161be46f1b3d93a9c0e61aaabdfb4b2886012570a51ad0aaf2286dd2c
diff --git a/net-mail/automx2/automx2-2021.4.ebuild b/net-mail/automx2/automx2-2021.4.ebuild
new file mode 100644
index 000000000000..66b5081f4c4d
--- /dev/null
+++ b/net-mail/automx2/automx2-2021.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Email client autoconfiguration service"
+HOMEPAGE="https://automx.org/"
+SRC_URI="https://github.com/rseichter/automx2/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+BDEPEND="acct-user/automx2"
+RDEPEND="
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-migrate[${PYTHON_USEDEP}]
+ dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/ldap3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ sed -i -e "/('scripts'/d" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ export AUTOMX2_CONF="tests/unittest.conf"
+ ${EPYTHON} -m unittest discover tests/ || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use doc; then
+ DOCS="*.adoc doc/*.adoc contrib/*sample.conf"
+ HTML_DOCS="doc/*.html doc/*.svg"
+ fi
+ sed -e "s/@EPYTHON@/${EPYTHON}/" "${FILESDIR}/init" | newinitd - "${PN}"
+ newconfd "${FILESDIR}/confd" "${PN}"
+ insinto /etc
+ newins "${FILESDIR}/conf" "${PN}.conf"
+ distutils-r1_python_install_all
+}