summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/bincimap
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/bincimap')
-rw-r--r--net-mail/bincimap/Manifest1
-rw-r--r--net-mail/bincimap/bincimap-1.2.13.ebuild99
-rw-r--r--net-mail/bincimap/files/bincimap-1.2-gcc43.patch64
-rw-r--r--net-mail/bincimap/files/bincimap-1.2.12-gentoo.diff32
-rw-r--r--net-mail/bincimap/files/bincimap-1.2.13-gentoo.diff32
-rw-r--r--net-mail/bincimap/files/bincimap-1.2.13-glibc-2.10.patch12
-rw-r--r--net-mail/bincimap/metadata.xml8
7 files changed, 248 insertions, 0 deletions
diff --git a/net-mail/bincimap/Manifest b/net-mail/bincimap/Manifest
new file mode 100644
index 000000000000..2b46aee78e76
--- /dev/null
+++ b/net-mail/bincimap/Manifest
@@ -0,0 +1 @@
+DIST bincimap-1.2.13final.tar.bz2 416152 SHA256 152368a1674a521a2006b8a27ff36c4db1b8bb0cf766ab1a0ada02698fae4528
diff --git a/net-mail/bincimap/bincimap-1.2.13.ebuild b/net-mail/bincimap/bincimap-1.2.13.ebuild
new file mode 100644
index 000000000000..816032a6f3dc
--- /dev/null
+++ b/net-mail/bincimap/bincimap-1.2.13.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="IMAP server for Maildir"
+SRC_URI="http://www.bincimap.org/dl/tarballs/1.2/${P}final.tar.bz2"
+HOMEPAGE="http://freshmeat.net/projects/bincimap/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~ppc x86"
+IUSE="ssl"
+
+DEPEND="ssl? ( dev-libs/openssl )"
+
+RDEPEND="${DEPEND}
+ virtual/daemontools
+ sys-apps/ucspi-tcp
+ net-mail/checkpassword"
+
+# get rid of old style virtual - bug 350792
+# all blockers really needed?
+RDEPEND="${RDEPEND}
+ !mail-mta/courier
+ !net-mail/courier-imap
+ !net-mail/cyrus-imapd
+ !net-mail/uw-imap"
+
+S="${WORKDIR}/${P}final"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-gentoo.diff
+ epatch "${FILESDIR}"/${PN}-1.2-gcc43.patch
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
+}
+
+src_compile() {
+ econf $(use_enable ssl) --sysconfdir=/etc/bincimap || die
+ emake localstatedir=/etc/bincimap || die
+}
+
+src_install () {
+ make DESTDIR="${D}" localstatedir=/etc/bincimap prefix=/usr install || die
+ keepdir /var/log/bincimap || die
+ if use ssl; then
+ keepdir /var/log/bincimap-ssl || die
+ fi
+
+ dodoc AUTHORS ChangeLog INSTALL \
+ NEWS README README.SSL TODO
+ dohtml doc/*.{html,css}
+ rm -rf "${D}"/usr/share/doc/"${PN}"
+
+ # backward compatibility
+ dosym /etc/bincimap/service/bincimap /etc/bincimap/service/imap
+ dosym /etc/bincimap/service/bincimaps /etc/bincimap/service/imaps
+}
+
+pkg_postinst() {
+ elog "To start bicimap at boot you have to enable the /etc/init.d/svscan rc file"
+ elog "and create the following link:"
+ elog "ln -s /etc/bincimap/service/bincimap /service/bincimap"
+ elog
+
+ if use ssl; then
+ elog "If you want to use ssl connections, create the following link:"
+ elog "ln -s /etc/bincimap/service/bincimaps /service/bincimaps"
+ elog
+ elog "And this command will setup bincimap-ssl on your system."
+ elog "emerge --config =${CATEGORY}/${PF}"
+ elog
+ fi
+
+ elog "NOTE: Default Maildir path is '~/.maildir'. If you want to modify it,"
+ elog "edit /etc/bincimap/bincimap.conf"
+ elog
+}
+
+pkg_config() {
+ if use ssl; then
+ local pemfile=/etc/bincimap/bincimap.pem
+ if [ ! -f $pemfile ]; then
+ echo "Creating a self-signed ssl-cert:"
+ /usr/bin/openssl req -new -x509 -nodes -out $pemfile -days 366 -keyout $pemfile
+ chmod 640 $pemfile
+
+ einfo "If You want to have a signed cert, do the following:"
+ einfo "openssl req -new -nodes -out req.pem \\"
+ einfo "-keyout $pemfile"
+ einfo "chmod 640 $pemfile"
+ einfo "Send req.pem to your CA to obtain signed_req.pem, and do:"
+ einfo "cat signed_req.pem >> $pemfile"
+ fi
+ fi
+}
diff --git a/net-mail/bincimap/files/bincimap-1.2-gcc43.patch b/net-mail/bincimap/files/bincimap-1.2-gcc43.patch
new file mode 100644
index 000000000000..76cb3a96d6b5
--- /dev/null
+++ b/net-mail/bincimap/files/bincimap-1.2-gcc43.patch
@@ -0,0 +1,64 @@
+diff -NrU5 bincimap-1.2.13final.orig/src/convert.cc bincimap-1.2.13final/src/convert.cc
+--- bincimap-1.2.13final.orig/src/convert.cc 2005-01-08 11:20:48.000000000 +0100
++++ bincimap-1.2.13final/src/convert.cc 2008-05-07 12:32:33.000000000 +0200
+@@ -37,10 +37,12 @@
+
+ #include "convert.h"
+ #include "io.h"
+ #include <string>
+
++#include <cstring>
++
+ using namespace ::std;
+ using namespace Binc;
+
+ //------------------------------------------------------------------------
+ BincStream::BincStream(void)
+diff -NrU5 bincimap-1.2.13final.orig/src/convert.h bincimap-1.2.13final/src/convert.h
+--- bincimap-1.2.13final.orig/src/convert.h 2005-02-08 21:30:22.000000000 +0100
++++ bincimap-1.2.13final/src/convert.h 2008-05-07 12:32:33.000000000 +0200
+@@ -35,10 +35,11 @@
+ #include <config.h>
+ #endif
+
+ #ifndef convert_h_included
+ #define convert_h_included
++#include <cstdlib>
+ #include <string>
+ #include <vector>
+ #include <iomanip>
+ #include <iostream>
+
+@@ -46,10 +47,12 @@
+ #include <sys/stat.h>
+
+ #include "address.h"
+ #include "depot.h"
+
++#include <cstring>
++
+ namespace Binc {
+
+ //----------------------------------------------------------------------
+ inline std::string toString(int i_in)
+ {
+diff -NrU5 bincimap-1.2.13final.orig/src/tools.cc bincimap-1.2.13final/src/tools.cc
+--- bincimap-1.2.13final.orig/src/tools.cc 2005-01-08 11:20:48.000000000 +0100
++++ bincimap-1.2.13final/src/tools.cc 2008-05-07 12:32:33.000000000 +0200
+@@ -33,13 +33,16 @@
+ */
+ #ifdef HAVE_CONFIG_H
+ #include <config.h>
+ #endif
+ #include <errno.h>
++#include <cstdlib>
+
+ #include "tools.h"
+
++#include <cstring>
++
+ using namespace ::std;
+ using namespace Binc;
+
+ //------------------------------------------------------------------------
+ Tools::Tools(void)
diff --git a/net-mail/bincimap/files/bincimap-1.2.12-gentoo.diff b/net-mail/bincimap/files/bincimap-1.2.12-gentoo.diff
new file mode 100644
index 000000000000..32841b1cfa88
--- /dev/null
+++ b/net-mail/bincimap/files/bincimap-1.2.12-gentoo.diff
@@ -0,0 +1,32 @@
+diff -Naru bincimap-1.2.11final.org/conf/bincimap.conf bincimap-1.2.11final/conf/bincimap.conf
+--- bincimap-1.2.11final.org/conf/bincimap.conf 2004-04-18 20:23:28.000000000 +0100
++++ bincimap-1.2.11final/conf/bincimap.conf 2004-04-24 13:53:10.011618795 +0100
+@@ -56,7 +56,7 @@
+ type = "Maildir", /* only Maildir
+ * support */
+
+- path = "Maildir", /* default path */
++ path = ".maildir", /* default path */
+
+ auto create inbox = "yes", /* create INBOX in
+ * given format if
+diff -Naru bincimap-1.2.11final.org/service/log/run-ssl.in bincimap-1.2.11final/service/log/run-ssl.in
+--- bincimap-1.2.11final.org/service/log/run-ssl.in 2004-03-02 20:16:02.000000000 +0000
++++ bincimap-1.2.11final/service/log/run-ssl.in 2004-04-24 13:52:30.562843106 +0100
+@@ -14,5 +14,5 @@
+
+ exec 2>&1
+
+-exec multilog t n5 s1048576 @localstatedir@/log/bincimap-ssl
++exec multilog t n5 s1048576 /var/log/bincimap-ssl
+
+diff -Naru bincimap-1.2.11final.org/service/log/run.in bincimap-1.2.11final/service/log/run.in
+--- bincimap-1.2.11final.org/service/log/run.in 2004-03-02 20:16:02.000000000 +0000
++++ bincimap-1.2.11final/service/log/run.in 2004-04-24 13:52:37.988613029 +0100
+@@ -14,5 +14,5 @@
+
+ exec 2>&1
+
+-exec multilog t n5 s1048576 @localstatedir@/log/bincimap
++exec multilog t n5 s1048576 /var/log/bincimap
+
diff --git a/net-mail/bincimap/files/bincimap-1.2.13-gentoo.diff b/net-mail/bincimap/files/bincimap-1.2.13-gentoo.diff
new file mode 100644
index 000000000000..d969622ab85f
--- /dev/null
+++ b/net-mail/bincimap/files/bincimap-1.2.13-gentoo.diff
@@ -0,0 +1,32 @@
+diff -Naru bincimap-1.2.13final.org/conf/bincimap.conf bincimap-1.2.13final/conf/bincimap.conf
+--- bincimap-1.2.13final.org/conf/bincimap.conf 2004-04-18 20:23:28.000000000 +0100
++++ bincimap-1.2.13final/conf/bincimap.conf 2004-04-24 13:53:10.011618795 +0100
+@@ -56,7 +56,7 @@
+ type = "Maildir", /* only Maildir
+ * support */
+
+- path = "Maildir", /* default path */
++ path = ".maildir", /* default path */
+
+ auto create inbox = "yes", /* create INBOX in
+ * given format if
+diff -Naru bincimap-1.2.13final.org/service/log/run-ssl.in bincimap-1.2.13final/service/log/run-ssl.in
+--- bincimap-1.2.13final.org/service/log/run-ssl.in 2004-03-02 20:16:02.000000000 +0000
++++ bincimap-1.2.13final/service/log/run-ssl.in 2004-04-24 13:52:30.562843106 +0100
+@@ -14,5 +14,5 @@
+
+ exec 2>&1
+
+-exec multilog t n5 s1048576 @localstatedir@/log/bincimap-ssl
++exec multilog t n5 s1048576 /var/log/bincimap-ssl
+
+diff -Naru bincimap-1.2.13final.org/service/log/run.in bincimap-1.2.13final/service/log/run.in
+--- bincimap-1.2.13final.org/service/log/run.in 2004-03-02 20:16:02.000000000 +0000
++++ bincimap-1.2.13final/service/log/run.in 2004-04-24 13:52:37.988613029 +0100
+@@ -14,5 +14,5 @@
+
+ exec 2>&1
+
+-exec multilog t n5 s1048576 @localstatedir@/log/bincimap
++exec multilog t n5 s1048576 /var/log/bincimap
+
diff --git a/net-mail/bincimap/files/bincimap-1.2.13-glibc-2.10.patch b/net-mail/bincimap/files/bincimap-1.2.13-glibc-2.10.patch
new file mode 100644
index 000000000000..063f7a54dc3d
--- /dev/null
+++ b/net-mail/bincimap/files/bincimap-1.2.13-glibc-2.10.patch
@@ -0,0 +1,12 @@
+diff -ur bincimap-1.2.13final.orig/src/convert.h bincimap-1.2.13final/src/convert.h
+--- bincimap-1.2.13final.orig/src/convert.h 2005-02-08 22:30:22.000000000 +0200
++++ bincimap-1.2.13final/src/convert.h 2009-08-08 10:38:08.000000000 +0300
+@@ -111,7 +111,7 @@
+ unsigned char c = *i;
+ unsigned char d = *(i + 1);
+
+- char *t;
++ const char *t;
+ if ((t = strchr(hexchars, c)) == 0)
+ return "out of range";
+ n = (t - hexchars) << 4;
diff --git a/net-mail/bincimap/metadata.xml b/net-mail/bincimap/metadata.xml
new file mode 100644
index 000000000000..87a19246cf13
--- /dev/null
+++ b/net-mail/bincimap/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+ <upstream>
+ <remote-id type="freshmeat">bincimap</remote-id>
+ </upstream>
+</pkgmetadata>