summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-11-25 22:44:05 +0100
committerMarek Szuba <marecki@gentoo.org>2021-11-25 22:44:05 +0100
commit7835daf2c9c04178eb6a7dac950296bfea955b19 (patch)
treee41bad189774db64323e5b1ef804f6fdccab5fa7 /net-mail/courierpassd/courierpassd-1.1.2-r2.ebuild
parentnet-mail/asmail: update EAPI 5 -> 8 (diff)
downloadgentoo-7835daf2c9c04178eb6a7dac950296bfea955b19.tar.gz
gentoo-7835daf2c9c04178eb6a7dac950296bfea955b19.tar.bz2
gentoo-7835daf2c9c04178eb6a7dac950296bfea955b19.zip
net-mail/courierpassd: update EAPI 5 -> 8
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-mail/courierpassd/courierpassd-1.1.2-r2.ebuild')
-rw-r--r--net-mail/courierpassd/courierpassd-1.1.2-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-mail/courierpassd/courierpassd-1.1.2-r2.ebuild b/net-mail/courierpassd/courierpassd-1.1.2-r2.ebuild
new file mode 100644
index 000000000000..2e1822bfc4c5
--- /dev/null
+++ b/net-mail/courierpassd/courierpassd-1.1.2-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Courierpassd is a utility for changing a user's password from across a network"
+HOMEPAGE="http://www.arda.homeunix.net/"
+SRC_URI="http://www.arda.homeunix.net/?ddownload=375 -> ${P}.tar.gz"
+RESTRICT="mirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="xinetd"
+
+DEPEND="net-libs/courier-authlib
+ xinetd? ( sys-apps/xinetd )"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ default
+
+ if use xinetd; then
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/${PN}.xinetd ${PN}
+ fi
+}