summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/email
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/email')
-rw-r--r--net-mail/email/Manifest4
-rw-r--r--net-mail/email/email-2.5.0.ebuild49
-rw-r--r--net-mail/email/email-3.0.5.ebuild55
-rw-r--r--net-mail/email/email-3.1.2.ebuild49
-rw-r--r--net-mail/email/email-3.1.3.ebuild25
-rw-r--r--net-mail/email/metadata.xml8
6 files changed, 190 insertions, 0 deletions
diff --git a/net-mail/email/Manifest b/net-mail/email/Manifest
new file mode 100644
index 000000000000..9c9c6aaa9c56
--- /dev/null
+++ b/net-mail/email/Manifest
@@ -0,0 +1,4 @@
+DIST email-2.5.0.tar.bz2 133167 SHA256 617d6d9cca146cdf3985c3432408ce8e855c8394d54824736fab549ec351935b
+DIST email-3.0.5.tar.bz2 176575 SHA256 811d99654df55c98ca29d6467cfe8489eb52b3a724e6f61dfeadb5bea89ecc58
+DIST email-3.1.2.tar.bz2 179546 SHA256 3b82d877276bc9f8eb58c613daf011454d5f4f0600335bc770cb4c3562547f75
+DIST email-3.1.3.tar.bz2 178396 SHA256 e96b9341946878c68c3143ac77ddf78e8dc07772056e47cc5781daf804789092
diff --git a/net-mail/email/email-2.5.0.ebuild b/net-mail/email/email-2.5.0.ebuild
new file mode 100644
index 000000000000..54763bea89d0
--- /dev/null
+++ b/net-mail/email/email-2.5.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Advanced CLI tool for sending email"
+HOMEPAGE="http://email.cleancode.org"
+SRC_URI="http://email.cleancode.org/download/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="alpha amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ local myconf=""
+
+ if [ -f /etc/conf.d/clock ]; then
+ . /etc/conf.d/clock
+ if [ x$CLOCK = "xUTC" ]; then
+ elog "Using UTC timestamps (from /etc/conf.d/clock)"
+ myconf="${myconf} --with-utc"
+ fi
+ fi
+
+ sed -i -e "s:/doc/email-\${version}:/share/doc:" configure
+ sed -i -e "s:DIVIDER = '---':DIVIDER = '-- ':" email.conf
+
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ doman email.1
+ dodoc INSTALL quoted-printable.rfc RFC821 TODO
+ make DESTDIR="${D}" install || die "install failed"
+}
+
+pkg_preinst() {
+ rm "${D}"/usr/share/doc/"${P}"/email.1
+}
+
+pkg_postinst() {
+ echo
+ elog "Do not forget to edit /etc/email/email.conf file before using email."
+ echo
+}
diff --git a/net-mail/email/email-3.0.5.ebuild b/net-mail/email/email-3.0.5.ebuild
new file mode 100644
index 000000000000..5fccbfe59348
--- /dev/null
+++ b/net-mail/email/email-3.0.5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit flag-o-matic
+
+DESCRIPTION="Advanced CLI tool for sending email"
+HOMEPAGE="http://www.cleancode.org/projects/email"
+SRC_URI="http://www.cleancode.org/downloads/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ append-ldflags $(no-as-needed)
+}
+
+src_compile() {
+ local myconf=""
+
+ if [ -f /etc/conf.d/clock ]; then
+ . /etc/conf.d/clock
+ if [ x$CLOCK = "xUTC" ]; then
+ elog "Using UTC timestamps (from /etc/conf.d/clock)"
+ myconf="${myconf} --with-utc"
+ fi
+ fi
+
+ sed -i -e "s:/doc/email-\${version}:/share/doc:" configure
+ sed -i -e "s:DIVIDER = '---':DIVIDER = '-- ':" email.conf
+
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ doman email.1
+ dodoc INSTALL quoted-printable.rfc RFC821 TODO
+ make DESTDIR="${D}" install || die "install failed"
+}
+
+pkg_preinst() {
+ rm "${D}"/usr/share/doc/"${P}"/email.1
+}
+
+pkg_postinst() {
+ echo
+ elog "Do not forget to edit /etc/email/email.conf file before using email."
+ echo
+}
diff --git a/net-mail/email/email-3.1.2.ebuild b/net-mail/email/email-3.1.2.ebuild
new file mode 100644
index 000000000000..236ca1bf0798
--- /dev/null
+++ b/net-mail/email/email-3.1.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Advanced CLI tool for sending email"
+HOMEPAGE="http://www.cleancode.org/projects/email"
+SRC_URI="http://www.cleancode.org/downloads/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ local myconf=""
+
+ if [ -f /etc/conf.d/clock ]; then
+ . /etc/conf.d/clock
+ if [ x$CLOCK = "xUTC" ]; then
+ elog "Using UTC timestamps (from /etc/conf.d/clock)"
+ myconf="${myconf} --with-utc"
+ fi
+ fi
+
+ sed -i -e "s:/doc/email-\${version}:/share/doc:" configure
+ sed -i -e "s:DIVIDER = '---':DIVIDER = '-- ':" email.conf
+
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ doman email.1
+ dodoc INSTALL quoted-printable.rfc RFC821 TODO
+ make DESTDIR="${D}" install || die "install failed"
+}
+
+pkg_preinst() {
+ rm "${D}"/usr/share/doc/"${P}"/email.1
+}
+
+pkg_postinst() {
+ echo
+ elog "Do not forget to edit /etc/email/email.conf file before using email."
+ echo
+}
diff --git a/net-mail/email/email-3.1.3.ebuild b/net-mail/email/email-3.1.3.ebuild
new file mode 100644
index 000000000000..442647c22df0
--- /dev/null
+++ b/net-mail/email/email-3.1.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+DESCRIPTION="Advanced CLI tool for sending email"
+HOMEPAGE="http://www.cleancode.org/projects/email"
+SRC_URI="http://www.cleancode.org/downloads/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="alpha amd64 x86"
+IUSE=""
+
+src_prepare() {
+ sed -i -e "s:/doc/email-\${version}:/share/doc:" configure || die
+ sed -i -e "s:DIVIDER = '---':DIVIDER = '-- ':" email.conf || die
+}
+
+src_install() {
+ default
+ doman email.1
+ dodoc README TODO
+}
diff --git a/net-mail/email/metadata.xml b/net-mail/email/metadata.xml
new file mode 100644
index 000000000000..ca387b18c097
--- /dev/null
+++ b/net-mail/email/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+ <longdescription lang="en">
+ Advanced CLI tool for sending mail.
+ </longdescription>
+</pkgmetadata>