summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2023-03-04 12:20:16 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2023-03-04 21:38:32 +0100
commit44af12ec13d340e12bced09a7c0520fe23db20f3 (patch)
treee84cd8786d3b618779fed6135294b218c3ac5c90 /net-mail/fetchmail
parentapp-backup/rdiff-backup: add 2.2.4 (diff)
downloadgentoo-44af12ec13d340e12bced09a7c0520fe23db20f3.tar.gz
gentoo-44af12ec13d340e12bced09a7c0520fe23db20f3.tar.bz2
gentoo-44af12ec13d340e12bced09a7c0520fe23db20f3.zip
net-mail/fetchmail: add 6.4.37
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'net-mail/fetchmail')
-rw-r--r--net-mail/fetchmail/Manifest1
-rw-r--r--net-mail/fetchmail/fetchmail-6.4.37.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/net-mail/fetchmail/Manifest b/net-mail/fetchmail/Manifest
index 1638f11b87c9..37e00b700a77 100644
--- a/net-mail/fetchmail/Manifest
+++ b/net-mail/fetchmail/Manifest
@@ -2,3 +2,4 @@ DIST fetchmail-6.4.27.tar.xz 1326668 BLAKE2B fb349f8e4b17929d8ab5ec144e2d6e4227b
DIST fetchmail-6.4.33.tar.xz 1330708 BLAKE2B ca76a4315c47013edc27859f4e6a16eec2564718a04bc82e5df72520b1dfabd3c746cabc5eb01c24f1fb552a0a9ea55eb8d659c9b4f6c313c8d993baa88635e6 SHA512 b95b89eaecdc98a92e1542f1bbdc6e1e51d38d392b564462413b602b3d5ebb004e4f4354694e369e6aceb6724753db55957e31a290e231fded74f1f523af41ac
DIST fetchmail-6.4.34.tar.xz 1331428 BLAKE2B 796972391a0ac2c71382aaaad3d75fd5c10ddcc58807f6c7ef9940907779e0ec0a8403e077b24afd50e1a7df0646e852cba02ba314e99ea423904e9f8288df01 SHA512 5ebb11dad48736647c879a81826a57719978029833254b67df6bd571842bcfe552589d49161e55b22a565728902558ace6fec9d9783392383da1a3150fb677b6
DIST fetchmail-6.4.36.tar.xz 1203448 BLAKE2B eb2f68d8e9254bd1cabb20aa8058326ee1c1e6819fc2ce011943708018b455d4259a2cf21d6eec0a4898ee1768c14f32d3617302ad418ccfbf6746c75c92c1fa SHA512 c9658f7b79de5e4f1dcaee4eee9b3a0039295e9dff8be1fb6c4ad0c3513b9c2bd14dce58e9cbca974716dd805621c83948168659345c7c190f3cb6f06b544b5d
+DIST fetchmail-6.4.37.tar.xz 1202860 BLAKE2B 4dc7d116e9dc32c2ff070f669306d9f2c0f93d5638b748d7362d6c9ab8684ae7ed8e26278ecf63bf23e2fff27916f83f7287aff891bd90bad82793bb84775c40 SHA512 99a620380d9bd0713d76495f587adbcc95fc16e5fcb048dc528f3039ebd8fcfbb1e2f44e10fc25f70e50940ce89922ff39f1f3d724d1f47a8d4918a37c07d8d0
diff --git a/net-mail/fetchmail/fetchmail-6.4.37.ebuild b/net-mail/fetchmail/fetchmail-6.4.37.ebuild
new file mode 100644
index 000000000000..524c47fe5b3b
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-6.4.37.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools systemd tmpfiles toolchain-funcs
+
+DESCRIPTION="the legendary remote-mail retrieval and forwarding utility"
+HOMEPAGE="https://www.fetchmail.info/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="ssl nls kerberos tk socks"
+
+RDEPEND="acct-user/fetchmail
+ ssl? (
+ >=dev-libs/openssl-1.1.1:=
+ )
+ kerberos? (
+ virtual/krb5
+ >=dev-libs/openssl-1.0.2:=
+ )
+ nls? ( virtual/libintl )
+ !elibc_glibc? ( sys-fs/e2fsprogs )
+ socks? ( net-proxy/dante )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ sys-devel/flex
+ nls? ( sys-devel/gettext )"
+
+DOCS="FAQ FEATURES NEWS NOTES README README.NTLM README.SSL* TODO"
+HTML_DOCS="*.html"
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.3.26-python-optional.patch
+)
+S=${WORKDIR}/${P/_/.}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ export PYTHON=:
+
+ econf \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ $(use_enable nls) \
+ $(use_with ssl ssl "${EPREFIX}/usr") \
+ $(use kerberos && echo "--with-ssl=${EPREFIX}/usr") \
+ $(use_with kerberos gssapi) \
+ $(use_with kerberos kerberos5) \
+ --without-hesiod \
+ $(use_with socks)
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/fetchmail.initd fetchmail
+ newconfd "${FILESDIR}"/fetchmail.confd fetchmail
+
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ systemd_newunit "${FILESDIR}"/${PN}_at.service "${PN}@.service"
+ dotmpfiles "${FILESDIR}"/${PN}.conf
+
+ docinto contrib
+ local f
+ for f in contrib/* ; do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "Please see /etc/conf.d/fetchmail if you want to adjust"
+ elog "the polling delay used by the fetchmail init script."
+ fi
+}