summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2022-09-19 16:07:09 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2022-09-19 16:07:09 +0200
commitc981dc14e17b037f9c9311054663e234834ea9f9 (patch)
tree145058814206e408f51ed7c9ac4b997aa89ad848 /net-mail/fetchmail
parentnet-ftp/filezilla: add 3.61.0 (diff)
downloadgentoo-c981dc14e17b037f9c9311054663e234834ea9f9.tar.gz
gentoo-c981dc14e17b037f9c9311054663e234834ea9f9.tar.bz2
gentoo-c981dc14e17b037f9c9311054663e234834ea9f9.zip
net-mail/fetchmail: add 6.4.33
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'net-mail/fetchmail')
-rw-r--r--net-mail/fetchmail/Manifest1
-rw-r--r--net-mail/fetchmail/fetchmail-6.4.33.ebuild107
2 files changed, 108 insertions, 0 deletions
diff --git a/net-mail/fetchmail/Manifest b/net-mail/fetchmail/Manifest
index ccc5ffc692f6..3a6ecc82e8c9 100644
--- a/net-mail/fetchmail/Manifest
+++ b/net-mail/fetchmail/Manifest
@@ -1,3 +1,4 @@
DIST fetchmail-6.4.27.tar.xz 1326668 BLAKE2B fb349f8e4b17929d8ab5ec144e2d6e4227b56143112eb3745830c339f8dfdaa80fb47060ad3671258563198ed1283a903fcd5a82564b7320a829ceb4c5826642 SHA512 75650c2a8bcfa6f4364dacd6964f00848a23e1bc96eed10f7fcfd9c8c6f6b6fe60eee2730c57c8a5263c11f01b3031cbef7d6b2bffa730de63e7ec262448af2f
DIST fetchmail-6.4.30.tar.xz 1333524 BLAKE2B 67e6aff00b1678ad68a4539c40147c79fbb22970248a97fd16340dbc64e90339a476ea322afde7345858b7041a00364e181af37dc96a09dcdca2e096f62922ea SHA512 0ec540c4102267e6e72fefa5e76aa76f45d25a0e68ec40f1fd834719f2a4b5f3f78c587b050fc33d97dd8fc6f674950949e5c23f960ebcd3046d5cc2e06db1d0
DIST fetchmail-6.4.31.tar.xz 1332264 BLAKE2B b92e098b6799b9af480f00a99eb229c584230adaea1c6c86c5a4c4ef333403f4892087fbcc4c79e4835bed0ab63912656cb544c58c47bb9e3ebc3b406b4d58f6 SHA512 08aa8dc2c09d59aad5815479e3b6d449a0e65a1d3e8f62fe0cc30d15d9ac94d780b8e88074f43941a7e442b536808260794ac39d6257e24dea4f16ac0627d539
+DIST fetchmail-6.4.33.tar.xz 1330708 BLAKE2B ca76a4315c47013edc27859f4e6a16eec2564718a04bc82e5df72520b1dfabd3c746cabc5eb01c24f1fb552a0a9ea55eb8d659c9b4f6c313c8d993baa88635e6 SHA512 b95b89eaecdc98a92e1542f1bbdc6e1e51d38d392b564462413b602b3d5ebb004e4f4354694e369e6aceb6724753db55957e31a290e231fded74f1f523af41ac
diff --git a/net-mail/fetchmail/fetchmail-6.4.33.ebuild b/net-mail/fetchmail/fetchmail-6.4.33.ebuild
new file mode 100644
index 000000000000..0dcbee8a098d
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-6.4.33.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="tk"
+
+inherit autotools python-single-r1 systemd tmpfiles toolchain-funcs
+
+DESCRIPTION="the legendary remote-mail retrieval and forwarding utility"
+HOMEPAGE="https://www.fetchmail.info/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="ssl nls kerberos tk socks"
+REQUIRED_USE="tk? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="acct-user/fetchmail
+ ssl? (
+ >=dev-libs/openssl-1.1.1:=
+ )
+ kerberos? (
+ virtual/krb5
+ >=dev-libs/openssl-1.0.2:=
+ )
+ nls? ( virtual/libintl )
+ !elibc_glibc? ( sys-fs/e2fsprogs )
+ socks? ( net-proxy/dante )
+ tk? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/future[${PYTHON_USEDEP}]
+ ')
+ )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ sys-devel/flex
+ nls? ( sys-devel/gettext )"
+
+DOCS="FAQ FEATURES NEWS NOTES README README.NTLM README.SSL* TODO"
+HTML_DOCS="*.html"
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.3.26-python-optional.patch
+)
+S=${WORKDIR}/${P/_/.}
+
+pkg_setup() {
+ use tk && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ # don't compile during src_install
+ use tk && : > "${S}"/py-compile
+ eautoreconf
+}
+
+src_configure() {
+ use tk || export PYTHON=:
+
+ econf \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ $(use_enable nls) \
+ $(use_with ssl ssl "${EPREFIX}/usr") \
+ $(use kerberos && echo "--with-ssl=${EPREFIX}/usr") \
+ $(use_with kerberos gssapi) \
+ $(use_with kerberos kerberos5) \
+ --without-hesiod \
+ $(use_with socks)
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/fetchmail.initd fetchmail
+ newconfd "${FILESDIR}"/fetchmail.confd fetchmail
+
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ systemd_newunit "${FILESDIR}"/${PN}_at.service "${PN}@.service"
+ dotmpfiles "${FILESDIR}"/${PN}.conf
+
+ docinto contrib
+ local f
+ for f in contrib/* ; do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+
+ use tk && python_optimize
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "Please see /etc/conf.d/fetchmail if you want to adjust"
+ elog "the polling delay used by the fetchmail init script."
+ fi
+}