summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilipp Rösner <rndxelement@protonmail.com>2022-01-23 23:50:36 +0100
committerSam James <sam@gentoo.org>2022-01-28 07:53:32 +0000
commitd4b59f063a05e65f354e4256582dfa2a4d3f8c15 (patch)
treed3188394c6be3e3c82512f7f0abfbba3f0d8f979 /net-mail/grepmail
parentapp-i18n/transifex-client: skip tests depending on network connection. (diff)
downloadgentoo-d4b59f063a05e65f354e4256582dfa2a4d3f8c15.tar.gz
gentoo-d4b59f063a05e65f354e4256582dfa2a4d3f8c15.tar.bz2
gentoo-d4b59f063a05e65f354e4256582dfa2a4d3f8c15.zip
net-mail/grepmail: version bump to 5.3111
We added an ebuild for grepmail-5.3111 with support for EAPI 8. The new ebuild doesn't need patches, it uses a source from CTAN and the tests are working now. Closes: https://bugs.gentoo.org/494350 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Philipp Roesner <rndxelement@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/23936 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-mail/grepmail')
-rw-r--r--net-mail/grepmail/Manifest1
-rw-r--r--net-mail/grepmail/grepmail-5.3111.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/net-mail/grepmail/Manifest b/net-mail/grepmail/Manifest
index 3e7e1bb7fc14..d2fa605992b3 100644
--- a/net-mail/grepmail/Manifest
+++ b/net-mail/grepmail/Manifest
@@ -1 +1,2 @@
DIST grepmail-5.3033.tar.gz 536791 BLAKE2B 400cc3c30a291f6075d343522a4f506997e3328c2adda2cfa7d4449052ce5bd6112fc06a44f8359def6358c716422b5c33353c7247dd6b5cf6c5a0502a2c34d6 SHA512 58fb63c42b534ba32d8224753cd11701adc3ab6eeca838753982cd6fdc46c05142eeb34106ae585b48698c299648cc2e0135215900ce28dd7c84921c8ad7831f
+DIST grepmail-5.3111.tar.gz 560547 BLAKE2B 88c9e841aed419ae428c45dd9a1bfb294076d73a3635e06b50a1f5b3bb3d2d447a8c586054b80ad793ccd6b2b2cb16394486d044f988c5760c04f9fe2da0e73e SHA512 50df6585ecebb838a2b60c048e66588d7a161a88256ffce2c7313e61d32751739b3c30a64deb43dcd2a5933970cacc812fbb2dbd9f91a8ac34012e0581cd2962
diff --git a/net-mail/grepmail/grepmail-5.3111.ebuild b/net-mail/grepmail/grepmail-5.3111.ebuild
new file mode 100644
index 000000000000..b64820f1bd52
--- /dev/null
+++ b/net-mail/grepmail/grepmail-5.3111.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit perl-module
+
+DESCRIPTION="Search normal or compressed mailbox using a regular expression or dates"
+HOMEPAGE="https://github.com/coppit/grepmail"
+SRC_URI="mirror://cpan/authors/id/D/DC/DCOPPIT/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-perl/Date-Manip
+ dev-perl/File-HomeDir
+ dev-perl/Inline
+ >=dev-perl/Mail-Mbox-MessageParser-1.40.01
+ dev-perl/TimeDate
+ virtual/perl-Digest-MD5
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-perl/Test-Compile
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ )
+"
+
+src_prepare() {
+ perl-module_src_prepare
+}