summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2015-11-23 12:02:07 -0500
committerMichael Orlitzky <mjo@gentoo.org>2015-11-23 12:02:40 -0500
commit536ff0601d4558e338550ee3a18a7e465c63114e (patch)
tree01a0562eff4115b68df1a6ae3909ef56dcfe647a /net-mail/mailshears/mailshears-0.0.2-r1.ebuild
parentsys-process/nmon: remove old (diff)
downloadgentoo-536ff0601d4558e338550ee3a18a7e465c63114e.tar.gz
gentoo-536ff0601d4558e338550ee3a18a7e465c63114e.tar.bz2
gentoo-536ff0601d4558e338550ee3a18a7e465c63114e.zip
net-mail/mailshears: new revision fixing asterisk dependency.
The behavior of the asterisk dependency recently changes (bug 560466) and is making repoman unhappy (bug 566606). It's been replaced by greater/less-than operators. Gentoo-Bug: 566606 Gentoo-Bug: 560466 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'net-mail/mailshears/mailshears-0.0.2-r1.ebuild')
-rw-r--r--net-mail/mailshears/mailshears-0.0.2-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-mail/mailshears/mailshears-0.0.2-r1.ebuild b/net-mail/mailshears/mailshears-0.0.2-r1.ebuild
new file mode 100644
index 000000000000..8cc176cbe23f
--- /dev/null
+++ b/net-mail/mailshears/mailshears-0.0.2-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22"
+
+# The tests are dangerous and shouldn't be run by anyone!
+# They mess with your local postgres databases.
+RUBY_FAKEGEM_RECIPE_TEST=none
+RUBY_FAKEGEM_RECIPE_DOC=yard
+RUBY_FAKEGEM_EXTRADOC="doc/${PN}.example.conf.yml"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Mangle your mail garden"
+HOMEPAGE="http://michael.orlitzky.com/code/mailshears.php"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/pg-0.17 <dev-ruby/pg-1"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman "doc/man1/${PN}.1"
+}