summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/mboxgrep
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/mboxgrep')
-rw-r--r--net-mail/mboxgrep/Manifest1
-rw-r--r--net-mail/mboxgrep/files/mboxgrep-0.7.9-ldflags.patch52
-rw-r--r--net-mail/mboxgrep/mboxgrep-0.7.9-r1.ebuild32
-rw-r--r--net-mail/mboxgrep/metadata.xml8
4 files changed, 93 insertions, 0 deletions
diff --git a/net-mail/mboxgrep/Manifest b/net-mail/mboxgrep/Manifest
new file mode 100644
index 000000000000..7e1fd7c38362
--- /dev/null
+++ b/net-mail/mboxgrep/Manifest
@@ -0,0 +1 @@
+DIST mboxgrep-0.7.9.tar.gz 76067 SHA256 78d375a05c3520fad4bca88509d4da0dbe9fba31f36790bd20880e212acd99d7 SHA512 d7e768a0ad11bc3df8619f2a888d2943c68ef72dd036c2fe58268686efb50cb1f62ba379571b6cd6efa8493c5ea0d7c09a29520eae6c68f66d9453710eeeba11 WHIRLPOOL 597da876492b703314df7bcb1a594927522ae674800651a91198e9e5fefb4a9f8443aa738cf282e8ad0950538f530033e8333abf6a1dbeb8274d95851ac2e6e9
diff --git a/net-mail/mboxgrep/files/mboxgrep-0.7.9-ldflags.patch b/net-mail/mboxgrep/files/mboxgrep-0.7.9-ldflags.patch
new file mode 100644
index 000000000000..dd0742626b47
--- /dev/null
+++ b/net-mail/mboxgrep/files/mboxgrep-0.7.9-ldflags.patch
@@ -0,0 +1,52 @@
+commit f51a9eafb80a5c5e506d7fe416c0b768ec1a6655
+Author: Eray Aslan <eras@gentoo.org>
+Date: Mon Jun 6 20:11:32 2011 +0300
+
+ Respect LDFLAGS and do not strip
+
+diff --git a/src/Makefile.in b/src/Makefile.in
+index fc5ac74..2b89866 100644
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -39,7 +39,7 @@ INCLUDES = -I. -I$(srcdir)
+ $(CC) $(CFLAGS) $(INCLUDES) -c $<
+
+ $(TARGET): $(OBJS)
+- $(CC) $(CFLAGS) -o $(TARGET) $(OBJS) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(TARGET) $(OBJS) $(LIBS)
+
+ .PHONY: clean
+ clean:
+@@ -52,6 +52,6 @@ distclean:
+ .PHONY: install
+ install: mboxgrep
+ $(INSTALL) -d $(prefix)/bin
+- $(INSTALL) -s $(TARGET) $(prefix)/bin
++ $(INSTALL) $(TARGET) $(prefix)/bin
+
+ .NOEXPORT:
+commit 1a0a345ad4c38df41227e3f2600bcf05ed49bbd7
+Author: Eray Aslan <eras@gentoo.org>
+Date: Mon Jun 6 20:52:06 2011 +0300
+
+ everyone has standard C headers nowadays
+
+diff --git a/src/md5.c b/src/md5.c
+index d6b8013..a797552 100644
+--- a/src/md5.c
++++ b/src/md5.c
+@@ -26,14 +26,8 @@
+
+ #include <sys/types.h>
+
+-#if STDC_HEADERS || defined _LIBC
+ # include <stdlib.h>
+ # include <string.h>
+-#else
+-# ifndef HAVE_MEMCPY
+-# define memcpy(d, s, n) bcopy ((s), (d), (n))
+-# endif
+-#endif
+
+ #include "md5.h"
+
diff --git a/net-mail/mboxgrep/mboxgrep-0.7.9-r1.ebuild b/net-mail/mboxgrep/mboxgrep-0.7.9-r1.ebuild
new file mode 100644
index 000000000000..397c2ea907ee
--- /dev/null
+++ b/net-mail/mboxgrep/mboxgrep-0.7.9-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Grep for mbox files"
+SRC_URI="mirror://sourceforge/mboxgrep/${P}.tar.gz"
+HOMEPAGE="http://mboxgrep.sf.net"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ppc x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+}
+
+src_install () {
+ emake \
+ prefix="${D}"/usr \
+ mandir="${D}"/usr/share/man \
+ infodir="${D}"/usr/share/info \
+ install
+ dodoc ChangeLog NEWS TODO README
+}
diff --git a/net-mail/mboxgrep/metadata.xml b/net-mail/mboxgrep/metadata.xml
new file mode 100644
index 000000000000..9bd46c587b7f
--- /dev/null
+++ b/net-mail/mboxgrep/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+ <upstream>
+ <remote-id type="sourceforge">mboxgrep</remote-id>
+ </upstream>
+</pkgmetadata>