summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno <hanno@gentoo.org>2019-10-25 14:54:43 +0200
committerHanno <hanno@gentoo.org>2019-10-25 14:55:12 +0200
commit773b70395c0378ccebcccb2ef7db25d16507468d (patch)
treec565e28b19c6649b27e72ec889f7a1af0bf4be62 /net-mail/mhonarc/mhonarc-2.6.19.ebuild
parentdev-libs/libffi-compat: x86 stable wrt bug #698458 (diff)
downloadgentoo-773b70395c0378ccebcccb2ef7db25d16507468d.tar.gz
gentoo-773b70395c0378ccebcccb2ef7db25d16507468d.tar.bz2
gentoo-773b70395c0378ccebcccb2ef7db25d16507468d.zip
net-mail/mhonarc: Version bump.
Remove unneeded mirror restriction (code is GPL-2). Add patch from upstream bugtracker for compatibility with current perl. Closes: https://bugs.gentoo.org/531320 Closes: https://bugs.gentoo.org/540946 Closes: https://bugs.gentoo.org/565098 Signed-off-by: Hanno Boeck <hanno@gentoo.org> Package-Manager: Portage-2.3.78, Repoman-2.3.17
Diffstat (limited to 'net-mail/mhonarc/mhonarc-2.6.19.ebuild')
-rw-r--r--net-mail/mhonarc/mhonarc-2.6.19.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-mail/mhonarc/mhonarc-2.6.19.ebuild b/net-mail/mhonarc/mhonarc-2.6.19.ebuild
new file mode 100644
index 000000000000..927fad6c59b0
--- /dev/null
+++ b/net-mail/mhonarc/mhonarc-2.6.19.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit perl-module
+
+DESCRIPTION="Perl Mail-to-HTML Converter"
+HOMEPAGE="https://www.mhonarc.org/"
+SRC_URI="https://www.mhonarc.org/release/MHonArc/tar/MHonArc-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~x86"
+# Warrants IUSE examples, and here it is + ? IUSE doc; see also extras folder with html docs
+IUSE="examples"
+
+S="${WORKDIR}/${P/mhonarc/MHonArc}"
+mydoc="README.txt"
+
+# From upstream bugtracker: https://savannah.nongnu.org/bugs/?49997
+PATCHES=( "${FILESDIR}/mhonarc-fix-perl-defined-bugs.diff" )
+
+src_install() {
+ sed -e "s|-prefix |-docpath '${D}/usr/share/doc/${PF}/html' -prefix '${D}'|g" -i Makefile || die 'sed on Makefile failed'
+ sed -e "s|installsitelib|installvendorlib|g" -i install.me || die 'sed on install.me failed'
+ perl-module_src_install
+ if use examples; then
+ docompress -x usr/share/doc/${PF}/examples
+ insinto usr/share/doc/${PF}/
+ doins -r examples/
+ fi
+}