summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-12-09 01:48:16 -0500
committerTim Harder <radhermit@gentoo.org>2016-12-09 01:48:16 -0500
commit5c7d553f51a141e5a6959642ceb1200668bd564b (patch)
treee4611b47a74dd99afd10fa91653f56e6505d1d8b /net-mail/mpop/mpop-1.2.6.ebuild
parentnet-mail/offlineimap: remove old (diff)
downloadgentoo-5c7d553f51a141e5a6959642ceb1200668bd564b.tar.gz
gentoo-5c7d553f51a141e5a6959642ceb1200668bd564b.tar.bz2
gentoo-5c7d553f51a141e5a6959642ceb1200668bd564b.zip
net-mail/mpop: version bump to 1.2.6
Diffstat (limited to 'net-mail/mpop/mpop-1.2.6.ebuild')
-rw-r--r--net-mail/mpop/mpop-1.2.6.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/net-mail/mpop/mpop-1.2.6.ebuild b/net-mail/mpop/mpop-1.2.6.ebuild
new file mode 100644
index 000000000000..4c5f7f5d7a0e
--- /dev/null
+++ b/net-mail/mpop/mpop-1.2.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="A small, fast, and portable POP3 client"
+HOMEPAGE="http://mpop.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="gnutls idn libressl libsecret nls sasl ssl vim-syntax"
+
+RDEPEND="
+ idn? ( net-dns/libidn )
+ libsecret? ( app-crypt/libsecret )
+ nls? ( virtual/libintl )
+ sasl? ( virtual/gsasl )
+ ssl? (
+ gnutls? ( net-libs/gnutls )
+ !gnutls? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig"
+
+REQUIRED_USE="gnutls? ( ssl )"
+
+DOCS="AUTHORS ChangeLog NEWS NOTES README THANKS"
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with ssl ssl $(usex gnutls "gnutls" "openssl")) \
+ $(use_with sasl libgsasl) \
+ $(use_with idn libidn) \
+ $(use_with libsecret )
+}
+
+src_install() {
+ default
+
+ if use vim-syntax ; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins scripts/vim/mpop.vim
+ fi
+}