summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-02-13 21:51:49 +0100
committerPacho Ramos <pacho@gentoo.org>2018-02-13 21:52:04 +0100
commit420773ffe8786e43ee7a053035c8e6fb7670c405 (patch)
treedfd7f624488f8a4ca04efdceda8c97928638efc9 /net-mail/mu/mu-0.9.16.ebuild
parentnet-mail/mu: amd64 stable, bug #645860 (diff)
downloadgentoo-420773ffe8786e43ee7a053035c8e6fb7670c405.tar.gz
gentoo-420773ffe8786e43ee7a053035c8e6fb7670c405.tar.bz2
gentoo-420773ffe8786e43ee7a053035c8e6fb7670c405.zip
net-mail/mu: Drop old
Package-Manager: Portage-2.3.20, Repoman-2.3.6
Diffstat (limited to 'net-mail/mu/mu-0.9.16.ebuild')
-rw-r--r--net-mail/mu/mu-0.9.16.ebuild85
1 files changed, 0 insertions, 85 deletions
diff --git a/net-mail/mu/mu-0.9.16.ebuild b/net-mail/mu/mu-0.9.16.ebuild
deleted file mode 100644
index d6af3e33c345..000000000000
--- a/net-mail/mu/mu-0.9.16.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools-utils base elisp-common
-
-DESCRIPTION="Set of tools to deal with Maildirs, in particular, searching and indexing"
-HOMEPAGE="http://www.djcbsoftware.nl/code/mu/"
-SRC_URI="https://github.com/djcb/mu/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="emacs gui"
-
-# net-mail/mailutils also installes /usr/bin/mu. Block it until somebody
-# really wants both installed at the same time.
-DEPEND="
- dev-libs/gmime:2.6
- dev-libs/xapian
- dev-libs/glib:2
- gui? (
- x11-libs/gtk+:3
- net-libs/webkit-gtk:3 )
- emacs? ( >=virtual/emacs-23 )
- !net-mail/mailutils"
-RDEPEND="${DEPEND}"
-
-SITEFILE="70mu-gentoo.el"
-
-src_prepare(){
- eautoreconf
-}
-
-src_configure() {
- # Todo: Make a guile USE-flag as soon as >=guile-2 is avaiable
- # Note: --disable-silent-rules is included in EAPI-5
- econf --disable-guile \
- $(use_enable gui webkit) \
- $(use_enable gui gtk) \
- $(use_enable emacs mu4e)
-}
-
-src_install () {
- dobin mu/mu
- if use gui; then
- dobin toys/mug/mug
- fi
- dodoc AUTHORS HACKING NEWS NEWS.org TODO README README.org ChangeLog
- if use emacs; then
- elisp-install ${PN} mu4e/*.el mu4e/*.elc
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
- # TODO: Add guile man page when guile-2 is available.
- doman man/mu-add.1 man/mu-bookmarks.5 man/mu-cfind.1 man/mu-easy.1 \
- man/mu-extract.1 man/mu-find.1 man/mu-help.1 man/mu-index.1 \
- man/mu-mkdir.1 man/mu-remove.1 man/mu-server.1 man/mu-verify.1 \
- man/mu-view.1 man/mu.1
- if use gui; then
- dobin man/mug.1
- fi
-}
-
-src_test () {
- # Note: Fails with parallel make
- emake -j1 check
-}
-
-pkg_postinst() {
- if use emacs; then
- einfo "To use mu4e you need to configure it in your .emacs file"
- einfo "See the manual for more information:"
- einfo "http://www.djcbsoftware.nl/code/mu/mu4e/"
- fi
-
- elog "If you upgrade from an older major version,"
- elog "then you need to rebuild your mail index."
-
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}