summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Smith <matt@offtopica.uk>2021-03-13 09:34:47 +0000
committerSam James <sam@gentoo.org>2021-03-13 12:57:21 +0000
commit09fab44e1365c97d0db0e22fd64e507f7e5820b5 (patch)
treeca2356cbbb207cfb8fbd30dbdf80519967d9b733 /net-mail/mu
parentnet-mail/mu: Drop old (diff)
downloadgentoo-09fab44e1365c97d0db0e22fd64e507f7e5820b5.tar.gz
gentoo-09fab44e1365c97d0db0e22fd64e507f7e5820b5.tar.bz2
gentoo-09fab44e1365c97d0db0e22fd64e507f7e5820b5.zip
net-mail/mu: Use correct release tarball
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Matt Smith <matt@offtopica.uk> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-mail/mu')
-rw-r--r--net-mail/mu/Manifest1
-rw-r--r--net-mail/mu/mu-1.4.15-r1.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/net-mail/mu/Manifest b/net-mail/mu/Manifest
index e55b93daf158..0fd99ac368b9 100644
--- a/net-mail/mu/Manifest
+++ b/net-mail/mu/Manifest
@@ -1 +1,2 @@
DIST mu-1.4.15.tar.gz 2309695 BLAKE2B 9808e59b758525937ec97e0ca6515108c1fb4287f3134d0c6038a74ef57b4992fede6b8957ba4e7e1681d8d307aec32fa6b2931e588004849e6c1dfb7da2f7f5 SHA512 dd0426c1fb7fe2430b47fc1232e067d1c017b3c428bbd8012c542f6e1ffa7741bb145c6851f40cbc945403534dabb4aa99faf369166167d187f083dde1d30546
+DIST mu-1.4.15.tar.xz 846052 BLAKE2B 933d04696c4ac145f20ca6c84f6fbe62f70fa3e45e50dfdf2e48a7007acecc56d8650f965dc6810fc7f8bbdae6595b7b7349f2675b08cd9fb619ee9eb24eb251 SHA512 e7741b77bce5c7c1c818549e803fb386f0b8727b995a7ac9b961b74e89cc7dbeed52b45d70895995a1640cfd36a49b052eeeed9be6c48999f2182a68bf5c205e
diff --git a/net-mail/mu/mu-1.4.15-r1.ebuild b/net-mail/mu/mu-1.4.15-r1.ebuild
new file mode 100644
index 000000000000..66b40d2b1002
--- /dev/null
+++ b/net-mail/mu/mu-1.4.15-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp-common
+
+DESCRIPTION="Set of tools to deal with Maildirs, in particular, searching and indexing"
+HOMEPAGE="https://www.djcbsoftware.nl/code/mu/ https://github.com/djcb/mu"
+SRC_URI="https://github.com/djcb/mu/releases/download/${PV}/mu-${PV}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~x64-macos"
+IUSE="emacs guile mug"
+
+DEPEND="
+ dev-libs/glib:2=
+ dev-libs/gmime:3.0=
+ >=dev-libs/xapian-1.4:=
+ emacs? ( >=app-editors/emacs-24.4:* )
+ guile? ( >=dev-scheme/guile-2.2:* )
+ mug? (
+ net-libs/webkit-gtk:4=
+ x11-libs/gtk+:3=
+ )"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+SITEFILE="70mu-gentoo-autoload.el"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable emacs mu4e)
+ $(use_enable mug gtk)
+ $(use_enable mug webkit)
+ $(use_enable guile)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ dobin mu/mu
+ dodoc AUTHORS HACKING NEWS NEWS.org TODO README ChangeLog
+ if use emacs; then
+ elisp-install ${PN} mu4e/*.el mu4e/*.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ doinfo mu4e/mu4e.info
+ fi
+
+ doman man/mu-*.*
+
+ if use guile; then
+ doinfo guile/mu-guile.info
+ fi
+
+ if use mug; then
+ dobin toys/mug/mug
+ fi
+}
+
+pkg_preinst() {
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog "After upgrading from an old major version, you should"
+ elog "rebuild your mail index."
+ fi
+}
+
+pkg_postinst() {
+ if use emacs; then
+ einfo "To use mu4e you need to configure it in your .emacs file"
+ einfo "See the manual for more information:"
+ einfo "https://www.djcbsoftware.nl/code/mu/mu4e/"
+
+ elisp-site-regen
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}