summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-06-02 19:21:08 -0400
committerTim Harder <radhermit@gentoo.org>2017-06-02 19:22:21 -0400
commit31d548c5f4e493f42fa486bae5ef8e95e931056e (patch)
treed7f02257af18a638defb34978bd3e49deb37bcae /net-mail/offlineimap
parentapp-crypt/p11-kit: version bump to 0.23.7 (diff)
downloadgentoo-31d548c5f4e493f42fa486bae5ef8e95e931056e.tar.gz
gentoo-31d548c5f4e493f42fa486bae5ef8e95e931056e.tar.bz2
gentoo-31d548c5f4e493f42fa486bae5ef8e95e931056e.zip
net-mail/offlineimap: version bump to 7.1.1
Diffstat (limited to 'net-mail/offlineimap')
-rw-r--r--net-mail/offlineimap/Manifest1
-rw-r--r--net-mail/offlineimap/offlineimap-7.1.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/net-mail/offlineimap/Manifest b/net-mail/offlineimap/Manifest
index bf2f997d5dd0..0570e877b1d1 100644
--- a/net-mail/offlineimap/Manifest
+++ b/net-mail/offlineimap/Manifest
@@ -2,3 +2,4 @@ DIST offlineimap-6.5.6.tar.gz 187801 SHA256 650fa588bdf86624575a5196fa12e9059b74
DIST offlineimap-6.7.0.3.tar.gz 679221 SHA256 0b7cd43501d1a65fb5e7e4f3a5d0a61f61435ec6b3a7385cc146e924eb6b03ed SHA512 21800eb14e814fa04b983e9718a5780deda4c99ae55ef900ccec9f1e65f9bb783c3469e00e6595c7dfddb60d760a6b3c98ae979da3219de51c8ae107ff1c077a WHIRLPOOL d8983260f309f427abcab65bc539bf8ff7ab38168643a863cc3d7e10a85dc864e4a6a11511a1cba32d2eb74833714f9b3f499b7d14d28800174c58816d59608c
DIST offlineimap-7.0.14.tar.gz 698081 SHA256 19494ecad4d7234ac69480abb7462d0cdcfcec444b55f5381651057d9fdfad44 SHA512 05d5ee81e5b0483038ad3bf8ba27f7b57423a75a3456df192c0c8b7926d7252424ef8f357f99dee2fa2f2590341e9f95d225ee2ad7d01af3466fb9d5488541f9 WHIRLPOOL a791cb67f1e51197fce9005ffbbbbdb8f4ee986d78a7ba46feff6aed6b50e17c5e57a9fa03bba9db0f90325b92c23b9d76071d460f6fec60fa878616cfc6544a
DIST offlineimap-7.1.0.tar.gz 698600 SHA256 dc998d1032f0e4f944cae0e584a146b70ea732422fc52c909eebe6e8f95b1ae4 SHA512 9e9d5ea2b58dc212c9b69adb701fb4cd1ac1a7c8af90623dcfba3115ee7e1f63cc8569c352bae8f1fe09eb8c9255c39d0bf947dfb5d683ee4b03c0c822cb192d WHIRLPOOL dbf33188c790b43e4b7756a1be6c1c7950bb192e079ba729a8ec159fb3d07a505e5892dc08b2cf8b7b55e2d3dc998f74354339e1c8ed6d3a0e190a5e904bbfdc
+DIST offlineimap-7.1.1.tar.gz 701776 SHA256 a624f8a77eae664dd458be47c5306c28911d4a1f788ff5641d7bb37e01ecb703 SHA512 a04a8bdbd2b22f8b74681707faa4fcd768a11abd4eeab1e3b6fd7e7851d97c5c7f7db56c7e7e4809a7cb661a357c38941ea320d9bcb0fc509b3f79b223a0c602 WHIRLPOOL 8fe84b4cd82c5e9d8816b4dce6aafae88ad718375927f6aa7cd08fd9b010ea0550a420045ad8f0c376102a0926c1c9ff404802b528d20cf3bf2587ab508f247d
diff --git a/net-mail/offlineimap/offlineimap-7.1.1.ebuild b/net-mail/offlineimap/offlineimap-7.1.1.ebuild
new file mode 100644
index 000000000000..c38b4b231571
--- /dev/null
+++ b/net-mail/offlineimap/offlineimap-7.1.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# Normally you need only one version of this.
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python{2_7,3_4} )
+PYTHON_REQ_USE="threads,sqlite,ssl?"
+
+inherit distutils-r1
+
+DESCRIPTION="Powerful IMAP/Maildir synchronization and reader support"
+HOMEPAGE="http://offlineimap.org"
+SRC_URI="https://github.com/OfflineIMAP/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc ssl"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="doc? ( app-text/asciidoc )"
+
+# see http://pogma.com/2009/09/09/snow-leopard-and-offlineimap/ and bug 284925
+PATCHES=(
+ "${FILESDIR}/${PN}-7.0.3-darwin10.patch"
+)
+
+src_compile() {
+ distutils-r1_src_compile
+ use doc && emake -C docs man
+}
+
+src_install() {
+ distutils-r1_src_install
+ dodoc offlineimap.conf offlineimap.conf.minimal
+ use doc && doman docs/{offlineimap.1,offlineimapui.7}
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "You will need to configure offlineimap by creating ~/.offlineimaprc"
+ elog "Sample configurations are in /usr/share/doc/${PF}/"
+ elog ""
+ elog "If you connect via ssl/tls and don't use CA cert checking, it will"
+ elog "display the server's cert fingerprint and require you to add it to the"
+ elog "configuration file to be sure it connects to the same server every"
+ elog "time. This serves to help fixing CVE-2010-4532 (offlineimap doesn't"
+ elog "check SSL server certificate) in cases where you have no CA cert."
+ fi
+}