summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2021-10-14 23:16:13 -0400
committerCraig Andrews <candrews@gentoo.org>2021-10-14 23:16:57 -0400
commit326caf9d88469e804cd3bfc8674c34d9e467d6c4 (patch)
tree5e682554c1a72d59dd27def3a6eeb8a3f8f6ee4f /net-mail/onionrouter
parentnet-ftp/pure-ftpd: Stabilize 1.0.49-r5 x86, #818196 (diff)
downloadgentoo-326caf9d88469e804cd3bfc8674c34d9e467d6c4.tar.gz
gentoo-326caf9d88469e804cd3bfc8674c34d9e467d6c4.tar.bz2
gentoo-326caf9d88469e804cd3bfc8674c34d9e467d6c4.zip
net-mail/onionrouter: dev-python/pyyaml-6.0 and Python 3.10 support
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-mail/onionrouter')
-rw-r--r--net-mail/onionrouter/files/onionrouter-0.6.1-pyyaml-6.0.patch24
-rw-r--r--net-mail/onionrouter/onionrouter-0.6.1-r1.ebuild54
-rw-r--r--net-mail/onionrouter/onionrouter-9999.ebuild4
3 files changed, 80 insertions, 2 deletions
diff --git a/net-mail/onionrouter/files/onionrouter-0.6.1-pyyaml-6.0.patch b/net-mail/onionrouter/files/onionrouter-0.6.1-pyyaml-6.0.patch
new file mode 100644
index 000000000000..32dedec57128
--- /dev/null
+++ b/net-mail/onionrouter/files/onionrouter-0.6.1-pyyaml-6.0.patch
@@ -0,0 +1,24 @@
+https://github.com/ehloonion/onionrouter/pull/26
+
+From 45853184a610fd83c77adaebb240f164214bd450 Mon Sep 17 00:00:00 2001
+From: Craig Andrews <candrews@integralblue.com>
+Date: Thu, 14 Oct 2021 22:45:25 -0400
+Subject: [PATCH] Allow pyyaml 6.0
+
+---
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index ad634ac..3b7d94c 100644
+--- a/setup.py
++++ b/setup.py
+@@ -11,7 +11,7 @@
+
+ requirements = [
+ "dnspython>=2.0.0,<3.0.0",
+- "PyYAML>=4.2b1,<6.0.0",
++ "PyYAML>=4.2b1",
+ ]
+
+ test_requirements = [
diff --git a/net-mail/onionrouter/onionrouter-0.6.1-r1.ebuild b/net-mail/onionrouter/onionrouter-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..e977bc3b27fe
--- /dev/null
+++ b/net-mail/onionrouter/onionrouter-0.6.1-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9,10} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 systemd
+
+DESCRIPTION=".onion discovery via SRV DNS lookups for use with postfix"
+HOMEPAGE="https://pypi.org/project/onionrouter/ https://github.com/ehloonion/onionrouter/"
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/ehloonion/onionrouter.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://pypi.io/packages/source/${PN::1}/${PN}/${P}.tar.gz"
+fi
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="$(python_gen_cond_dep '
+ dev-python/dnspython[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+')"
+BDEPEND="$(python_gen_cond_dep '
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+')"
+
+PATCHES=(
+ "${FILESDIR}/${P}-pyyaml-6.0.patch"
+)
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ insinto /etc/onionrouter
+ doins "${S}/onionrouter/configs/onionrouter.ini"
+}
diff --git a/net-mail/onionrouter/onionrouter-9999.ebuild b/net-mail/onionrouter/onionrouter-9999.ebuild
index 2efd032bc84b..396599972a75 100644
--- a/net-mail/onionrouter/onionrouter-9999.ebuild
+++ b/net-mail/onionrouter/onionrouter-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{7,8,9,10} )
DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_SETUPTOOLS=rdepend